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1 About Tesseral Pro 

Tesseral Pro is designed for calculating seismic synthetic gathers using finite-difference wave equation 

approximations, such as acoustic, elastic, anisotropic, visco-elastic and 2D ray- tracing (approximation 

by Eikonal equation). In the Tesseral Pro, the depth velocity models can be built from well data, 

geological surface maps or 2D/3D grids. 

Also, Tesseral Pro allows building a 3D observation system and performing 3D Ray tracing. 

  



8 

© Tesseral Technologies -User Documentation- 

1.1 System Requirements 

 

Minimum Recommended 

Windows /7/8/10/11 

1.5 GHz CPU 

Commodity or integrated GPU 

4 GB RAM 

2 GB free space on HDD 

Windows /10/11 

3.0 GHz CPU,  

power GPU 

16 GB RAM 

10 GB free space on HDD Network 

Card (access corporate database) 
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NOTE: If you have purchased the Tesseral Pro USB-key license, please do not insert your 

USB key before finishing the installation. The drivers for USB key will be set up during the 

installation. 

1.2 Tesseral Pro package download and Installation 

The latest versions of the Tesseral products can be downloaded from the following links: 

http://www.tesseral-geo.com/download.en.php 

To start the installation process, please unzip the file and then run the setup executable. 

 

After successful installation, a Welcome dialog (below) will appear. 

 

In the User Information dialogue box you may enter your name and specify if other users can 

use Tesseral Pro on this computer (the current user only or all the users of this computer). 

 

After installing Tesseral Pro, just click “Tesseral Pro” in the start menu to start Tesseral 

Pro: 

http://www.tesseral-geo.com/download.en.php
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When Tesseral Pro is started for the first time, you need to enter your registration information or insert 

your USB key (see Licensing Policy at Section 18). After registration, the program is ready for use. 

 

Without a license, in the demo mode, the functions of synthetic gathers modeling and gathers processing 

are unavailable for the users. 
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2 Introduction 

After launching the Tesseral Pro, a Welcome dialogue box with several options appears. 

 

• The CREATE NEW MODEL button launches the Wizard to create a new model (Section 3.1). 

• The LOAD MODEL button is for loading a model in TAM format used in the Tesseral 2D 

program, WGC format, GXII format or loading a model from a text file in various formats 
(Section 3.1.9). 

• The LOAD SEISMIC FILE button enables the visualization of gathers in standard SEG-Y, 

internal TGR and SDS-PC formats (Section 13.1). 

• The OPEN PROJECT and OPEN LAST PROJECT buttons are for loading the files of 

Tesseral Pro projects. 

If you click Done, the standard empty window of the Tesseral Pro project will appear. 
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Modeling Wizard 

Pane for building models, visualizing 

synthetic gathers, maps or other graphic 

data 

Project and 

database pane 

2.1 Layout of Tesseral Pro window 

 

In the left panel the database tree (please see description in the Section 17) and the project tree (please 

see details in the Section 11.8) are displayed. The right panel is for building the model and visualizing 

gathers, maps or 3D images. All the objects in the right pane are displayed in rectangular frames (please 

see details in the Section 11). 

At the bottom of the main Tesseral Pro window is the Modelling Wizard, which initiates one of the 

3 main steps in a modeling process (Section 2.3). 
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2.2 Menu overview 

• Menu File consists of the options for creating, saving or importing a project (TPA 
format), loading models, gathers or surfaces, printing document and exporting the 
project into standard raster-type or vector formats. 

• Menu Database is for managing the database in Tesseral Pro, such as 
creating/selecting database, or importing/editing a well log data (see Section 17). 

• Menu Edit is for manipulating Frames. 

• Menu View is for general commands for working with Frames. 

• Menu Model is for creating and modifying velocity models and acquisition geometry 
(Section 12). 

• Menu Map is for creating/loading a surface map and different ways of displaying the 
surface map (Section 14). 

• Menu Seismic is for loading seismic gathers in SEG-Y, SDS-PC or TGR formats 
(Section 13) and changing the visualization modes. 

• Menu 3D View is for viewing 3D images (Section 15). 

• Menu Run is for launching computation of synthetic gathers for one particular model 
or to process these synthetic gathers using available processing modules such as 
stacking and 2D migration (Section 5, 11). 
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2.3 General steps for synthetic modeling 

At the bottom of the Tesseral Pro window, the 3 sequential steps for creating synthetic gathers are 

shown: 

STEP 1. Creation of the 2D velocity model. The velocity model can be created by using well data, maps 

of horizons or 2D/3D layered model (SEG-Y format) or LAS file). 1D/2D vector models in various 

formats from other packages are also supported (Section 3.1). 

STEP 2. Creation of the acquisition geometry (source and receiver distribution, section 

4) 

STEP 3. Set up of the modeling parameters and start a modeling job which launches one 

of the following computational engines (Section 5): 

1. 2D/3DVertical Incidence 

2. 2D Scalar 

3. 2D/3D Acoustic 

4. Acoustic without multiples 

5. 2D/3D Elastic 

6. 2D/3D Elastic Anisotropic 

7. 2D/3D Visco-Elastic 

8. 2D Eikonal Ray Tracing 

9. 2.5D Elastic 

10. 2.5D Elastic Anisotropic 

11. Haskell-Thomson 

The procedures for processing gathers (Section 11) and the module for ray tracing (Section 6) are 

integrated into Tesseral Pro. 
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3 Depth model building 

To create a depth-domain velocity model in Tesseral Pro, a Model Frame is to be used. 

All the objects in the Tesseral Pro are comprised in Frames; see Section 11 for details related to different 

types and options for manipulating frames. 

In the Model Frame users can build arbitrarily complex velocity models for any geological structure, 

add anisotropic or fracturing parameters into the background model and design the acquisition geometry. 

The geological model is built by overlapping a set of polygons. Within each polygon, the rock physical 

parameters could be homogeneous or complicated (with a linear gradient along depth). For model 

creation, users can use the reflection horizons, velocity, density, anisotropy and other parameters from 

acoustic well logging, grids of layer data in SEG- Y format, as well as 1D/2D vector models from other 

packages. 
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3.1 Building a new model 

The first stage of model building is to specify the basic parameters: size of the model (width and depth), 

geographical reference of the coordinates, and the main source of data used for building models (grids 

in SEG-Y format, grids or isolines of reflection maps, well data, underlying image and etc). The menu 

Model > Create Velocity Model (New Frame) is used. After that, the Wizard for new 

model creation will appear. 

 

In this dialogue box, users can select one of the main data sources for creation of a depth model. In the 

next chapters, various options for model building will be described one by one. 
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NOTE: The distance units in the model may be meters or feet. Select the measurement 

units in the project as described in the Section 16. 

3.1.1 Creation of a simple 2D model 

Firstly, click the menu Model > Create Velocity Model (New Frame). 

Then, select SIMPLE model > in the Create new Model pop-up dialogue box. 

In the Section dialogue box, specify the model‟s length and the top and bottom of the depth model. 

 

 

After specifying model‟s size, click Next. You will see the Base Polygon dialogue box where the 

constant or linearly-increasing compressional velocity of the background model (base of the other 

polygons) can be specified. 
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After clicking Finish, the Frame Model will be created, and you will be asked to design the 

acquisition geometry used for modeling, as shown below: 

 

This message will always pop up after creating a new model. Please see more details about designing 

related source/receiver distribution in the Section 4. 

After the “empty” Frame Model is created, it has to be overlapped with polygons with various velocities, 

density and other rock physical parameters. Please see more details about how to build a model using 

polygons in Section 5. 
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3D model 

Examples of SEG-Y files of depth velocity model 

2D model 

NOTE: In Tesseral Pro, SEG-Y files can be visualized by using the menu Seismic > 

Load Seismic File (New Frame) (please see the Section 13 for details) 

3.1.2 Creation of a model from a SEISMIC file 

If you have a 2D or 3D velocity depth model in SEG-Y format, you can use it as an underlying image 

for the model. 

For example: 

 

This means that, instead of drawing polygons and adjusting their parameters, users have the option of 

using SEG-Y files directly. Users only need to select the size and location of the model. If the SEG-Y 

files contain only compressional velocity, then the other parameters (shear velocity, density) will be 

calculated automatically by using some empirical formulae. Importing density, shear velocity and 

anisotropy from SEG-Y files is also supported. 

The time-domain model in SEG-Y format may also be used. But it needs to be transformed into depth 

model in advance; the Run > Velocity Model > Time to Depth Transformation menu is used for this 

purpose. Please see more details in the Section 10.2.2. 

 

After clicking the Model > Create Velocity Model (New Frame) menu, you will see the Create new 

Model dialogue box. Then click the From SEISMIC file > button to build the model from the seismic 

file. 

STEP 1. Selection of a SEG-Y file with velocities 

In the File dialogue, please select the 2D or 3D seismic file in one of the SEG-Y or TGR formats. 
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Apart from the compressional velocity data, you may also have depth-domain seismic files with density, 

shear-wave velocity or anisotropy data. These files may be also used as the underlying image for the 

corresponding components. Click the Add other component files button to select the files of 

other components in the Model from seismic files pop-up dialogue box. 

 

When the seismic file is selected, press the Next > button. 

STEP 2. Selection of coordinates and the Model profile 

In the next dialogue box Profile, if the seismic file is 3D, users need to enter the coordinates of the 

model profile, or draw the profile manually in the plan by pressing-dragging and releasing the left mouse 

button. 
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STEP 3. Size of the model 

In the next dialogue box Section, please specify the top and the bottom of the model: 

 

The model with the underlying seismic file is ready. Then, the users will be asked to design an 

acquisition geometry for the model (please see the Section 4 for details). 
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Users may add polygons above the underlying image to finalize the model building. In Section 3.1.8, 

see details about how to adjust the model‟s parameters, which have an underlying SEG-Y image. 
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Surface 

Section 

3.1.3 Creation of a model from Maps 

The grids or isolines of the reflection horizons may be used for the automatic creation of model‟s 

polygons. In this case, the 2D model is built as a vertical section in the 3D cube of surfaces (see figure 

below). As a result, the top and the bottom of each polygon have the same shape as the surfaces for the 

given section. 

 

 

To use this function, first click Model > Create Velocity Model (New Frame), and then 

in the dialogue box Create new Model click the button From Mapsmaps >. 

In the opened dialogue box Maps click the button Add File > if a surface is going to be loaded 

from the file into the Tesseral Pro project (see figure below). 
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NOTE: You may select several surfaces at a time in the Add File >. 

 

After you have selected the files with surfaces, the dialogue box Choose mapping method will 

appear, and then the dialogue box Calculate Isolines will appear for adjusting the parameters 

of the isoline image. Repeat these steps to add more layers. When all the needed surfaces are loaded, 

press the button Next >. 

 

In Tesseral Pro, the surfaces may be loaded directly from files that have major text formats, or may be 

calculated from stratigraphic well data. Please see Section 17 about loading stratigraphic data into the 

database. Section 14.2 describes the functions for computing surfaces from well data. 

In the next dialogue box Profile please specify the profile coordinates manually or draw the profile 

using the mouse (press-drag-release). 
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In the figure above, the Max. no. of nodes on profile parameter determines the number of 

nodes at the top and bottom of each polygon created from the surfaces. 

Press the button Next > to navigate to the dialogue box Section. 

 

In the dialogue box Section please specify the range of the model. In this dialogue 
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box, the lines of the polygons are shown. By default, velocities and other parameters of the polygons are 

not present, so the polygons are displayed in grey color. To specify the parameters for each polygon, 

select it by mouse and then click Model > Edit Polygon (Section 3.2.5). 
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3.1.4 Creation of a model from database WELLS 

The well data (acoustic logging and/or density logging) are mainly used for creation of thin-layered 

models. 

 

Steps for creating a model from the well data: 

1. Click Model > Create Velocity Model (New Frame). 

2. In the dialogue box Create new Model, click the button From database 

WELLS >. 

3. In the dialogue box Select Wells, select the wells to be loaded from the list of 

Wells. You may mark one or several Fields, and then in the box Wells only wells 

from these Fields will be shown. 

 

After selecting the wells, press button OK and go to the dialogue box Wells. 

In the dialogue box Wells, the geographical location of the selected wells is shown, and you may add 

or remove wells from the profile using the buttons Add > and Delete <. 

NOTE: To create a model by using well data, the following data need to be loaded into the 

database: 

1) Coordinates of the wells; 

2) Survey directionality (if the survey has no directionality, vertical wells with provided 

altitudes is sufficient); 

3) Depths of layer intersections; 

4) Acoustic (density) logging data for creating thin-layer models. 

Please see Section 17.5 for more details. If users wish to create a simple horizontally- 

layered model from one LAS-file which ignores the directionality of the survey data, please 

see the next Section 3.1.5. 
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When all the needed wells are loaded into the model, press the button Next >. In the next dialogue box 

Profile, specify the coordinates of the model‟s profile or draw the profile manually by using mouse 

(press-drag-release): 

 

In the next dialogue box Section please set the top and the bottom of the model: 
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In the next dialogue box Base Polygon, please specify the velocity of the basic polygon: 

 

In the next dialogue box Well data, you may select the stratigraphic arrangements and the logging 

data will be shown near the wells. 
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NOTE: If Log is checked, then the acoustic logging curves will appear to the right of the 

well, and the parameters for re-calculating these curves are set automatically. If the logging 

curves do not appear, it is recommended to go to the dialogue box Log by clicking the 

corresponding button Properties. 

 

Check Layers for automatic creation of polygons by stratigraphic correspondences. Check Log for 

automatically filling the polygons with the parameters from well logging (creation of thin-layered 

model). 

Preparation for creating a thin-layered model 

The preparation includes selecting curves for the model and adjusting the re-calculation parameters and 

the well logging data to characterize the polygons (velocity, density, fracturing, anisotropy). 

 

In the dialogue Log, please select the acoustic logging curves (DT or acoustic logging) from the list of 

the curves for the model‟s wells. For further filling-in of the polygon parameters from the logging data, 

for the selected curves, please set Specification to Compressional Velocity or dT and 

also Measure unit to usec/m in order to re- calculate the parameters of the polygons from the 

curves‟ values correctly. 
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Then press OK and the Log dialogue box will close. As the result, in the Well data dialogue, the 

logging curves should appear near the wells. Press the Next > button to go to the next dialogue box 

Add polygons. 

 

In the dialogue box Add Polygons, from the drop-down list Create Polygons from 

Layers, the following options are available for the creation of polygons: 

3. Set the scale and the 

lines for the curve 

2. Set the type of the curve 

and the measurement units 

1. Add logging curves 

to the wells 
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Model Form of the thin-layered grid 

used for modeling 

• No – do not create the polygons automatically 

• All layers – to create the polygons for all the layers which exist at least in one of 

the selected wells. It means that, if the layer exists in any of the selected wells, it will be 
used for the creation of polygons. 

• For all wells – create polygons for the layers which exist in all the selected wells. 

As a special case, if a layer is not present at least in one of the selected wells, it will not 
be used for creation of polygons. 

• Selected – select the layers manually from the list of the layers in the database. 

Check Create Polygons from Horizon to create the polygons using the 

previously loaded surfaces. In this dialogue box, users can load the surfaces by 
clicking thebutton Load. 

As a result, the model will be created in which the velocities (and/or) other parameters will be obtained 

automatically from well logging data. However, as mentioned above, users need to load in advance the 

databases: coordinates of the wells, coordinates of layers‟ intersections and the logging curves (please 

see the Section 17.5 for more details). 

The parameters interpolated by logging data (thin-layering) are not shown in the polygons. The 

interpolation is done automatically before the modeling job is launched. You may QC the quality of the 

final model by using Model > Export to Seismic Format (SEG-Y, TGR menu item to 

export the velocity model to a grid file. 

 

 

In the Tesseral Pro, some special tools are implemented for creating and adjusting polygons whose 

properties are derived from well data. Please see Section 3.2.9 for more details. By building polygons 

from well data, thin-layer models are created. 

NOTE: This grid file is not used in actual calculations. It is used only for QC/visualizing 

the final model to be used in modeling. 
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Acoustic logging (DT) curve 

3.1.5 Creation of a simple flat layered model from LAS file 

In this section, a simple method is described for creating a model from acoustic logging data and/or 

density measurement data without loading the data in advance into database. 

 

To start this functionality, first click Model > Create Velocity Model (New Frame), then 

in the dialogue box Create new Model click the button From LAS-file 

>. In the dialogue box LAS-file, select the LAS-file containing the velocity and/or density. 

In the dialogue box LAS-file, select the curve corresponding to the component of the model 

Compressional Velocity or dT, Density, Shear Velocity or dT, and then select the units of measurement 

for each component. 
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It is also recommended to set the well altitude (Elevation) correctly. The directionality of log data is 

not used for creating horizontally-layered models. However, it will not be enough to have only altitudes 

for conventionally vertical wells. 

In the next dialogue box Section, specify the length and the model‟s depth range: 

 

Then specify the velocity for the basic polygon. 
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In the last dialogue box Create polygons from LAS-file, specify the parameters which will 

be used for building a thin-layered model. These parameters determine the number and the thickness of 

the polygons created automatically from the LAS-file. 

Clearance is the maximally allowed velocity variation within a polygon. 

Min. Sampling rate by Depth is the minimum thickness of a polygon. 

 

For models built from well data, the polygons are filled by the interpolated parameters from the wells. If 

only LAS-file is used for model building, numerous thin polygons are created. To check the quality of 

the specified parameters, press the button Create polygons. Feel free to play with the parameters if 

you do not like the results. 
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NOTE: The SPS-files may be also used only for reproducing the acquisition geometry in a 

created model. Please see details in the Section 4.7. 

3.1.6 Creation of a model from SPS-file 

If you want to reproduce a field acquisition geometry while creating synthetic gathers and design the 

model surface using the real altitudes of sources and receivers, it is recommended to use an SPS-file to 

create the new model. 

 

To use this feature, click Model > Create Velocity Model (New Frame). 

Then, in the dialogue box Create new Model press the button From SPS-file >. 

Then in the dialogue box Load SPS files, select the files of sources, receivers and their acquisition 

geometry. 

Also, please note that SPS scripts of all types are supported, as well as SEG scripts, KML (KMZ), and 

TXT file (with the following simple format: SrcX, SrcY, SrcZ, RcvX, RcvY ,RcvZ) 

 

 

After specifying and loading the correct SPS file type, click Next and in the dialogue box 

Profile, specify the model profile: 
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In the figure above, the red rectangles indicate the sources, and the blue dots indicate the receivers. 

Please note that it is only possible to build 2D models in the Tesseral Pro, and so only the sources and 

the receivers close to the selected profile will be included. 

To select the profile coordinates more accurately, please use the button Zoom map. 

In the next dialogue box Sources and receivers selection, specify the parameters used for 

selecting the sources and receivers and binning the selected sources/receivers. This dialogue box is 

needed for proper extraction of needed sources and receivers from the loaded 3D acquisition geometry. 
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Then in the next dialogue box Section, specify the depth range of the model and how to use the 

altitudes of the sources and receivers saved in the SPS-files (the parameter Sources and 

receivers elevation): 

• set SPS elevations: the top of the basic polygon that is to be built by the 

altitudes of sources and receivers. 

• move under model top: the sources and the receivers are moved to the 

models‟ top 

• ignore: the basic polygon of the model and the altitudes of the sources and the 

receivers are assigned independently. 
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As in other model creation methods, users need to fill in the obtained model with polygons 

(please see details in the Section 5). 
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3.1.7 Creation of a model from PICTURE 

This method is used for drawing model polygons manually from the underlying picture. 

To use this option, click Model > Create Velocity Model (New Frame). In the dialogue box Create new 

Model, press the button From Picture >. 

Then in the next dialogue box, select the underlying picture in a BMP, JPEG, TIFF, GEO-TIFF, GEO-

JPEG format pictures with coordinates in TFW, JGW files, by clicking the button Property. 

 

In the dialogue box Picture for Model, select the file of the picture and the area (part) of the 

picture, which will be used as an underlying image in the Frame Model. 
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 Then in the next dialogue box Section, specify the depth range and the length of the 

model. 

 

After that, the Frame Model with the underlying picture will be created, as shown below. 

Select the area using the mouse 
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This underlying picture cannot be used for modeling, but the polygons may be drawn manually by 

following the visible boundaries, and then velocity and other parameters for the created polygons need 

to be specified. 
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To ensure that the underlying pad image is always visible, the hand-created polygons are partially 

transparent. 
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3.1.8 Hybrid method for model creation 

You may create a model by using a SPS file, surfaces, a gather for the velocity model and well data 

simultaneously. At first, users need to create an initial model using any of the methods. Then choose the 

model creation command Model > Create Velocity Model (New Frame) again. You will 

be asked whether you would like to change the existing model or create a new one.  

 

Select Yes to use the other model creation method in order to change the model. 
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3.1.9 Load model in other formats 

Use the command Model > Create Velocity Model (New Frame), and then in the popup 

dialogue box Create new Model, click the button Load model from other format 

file… . 

The supported formats include TAM (model format from the Tesseral 2D package), WGC, GXII and 

table text files. Surely, users can also load a model from another project (TPA format). 
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3.1.10 3D Model building from Maps 

 

Load all surfaces you want to use for 3D model building by going Map > Create Map (New 
Frame) > Load TXT or GRD- surface files 

For instructions on how to load or create surfaces from XYZ text files, please follow the instructions 

from Section 14 

Select the surfaces you want to use as horizons: 

 

The topmost surface is shown here:
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You can manage and view all surfaces individually by going Map > Manage/Delete surfaces. 

Next, it is advisable to order Order Horizons by Depth. 

 

Once all surfaces have been loaded, values must be introduced for all layers created by these surfaces. In 

order to do that, a 2D cross-section needs to be generated first. This is done by accessing Map > 

Section Mode and drawing the profile on the surface, by pressing- dragging-releasing the left mouse 

button. 
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In order to see the cross section you need to bring down the (encircled) lower header: 

 

This is done by left clicking on the lower header and then dragging it down with the left mouse button. 
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A two-dimensional section will appear in the stretched field: 

 

To assign a value (i.e. compressional velocity, shear velocity, density etc.) to a particular layer click on 
Map > Manage/Delete Maps > 3D-model Properties. 

 

 

Depending on whether you want to fill the upper part or the lower part of the surface, you specify 

Surface type bottom, or Surface type top respectively. 

Repeat this step for all loaded surfaces. Once completed, void (i.e. unfilled) space will 

remain in the map frame, since all surfaces can be either Type: top or Type: bottom and not 

both. 
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Finally to create a 3D SEG-Y file go Run > Map Frame > Create 3D SEG-Y… 

 

Specify the X, Y, Z dimensions you want for your 3D model, the grid sampling, as well as the 

Filling cells value with which you want to fill the remaining blank layer(s). Also, specify 
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the pathway and name of the Output seg-y file, with .sgy extension. 

If you want to fill the remaining blank layer(s) from a base seismogram (i.e. from 3D SGY cube), then 

load it in the Use base seismogram. 

 

 

Also, it is possible to fill multiple layers from different base seismograms. In this case these base 

seismograms are loaded for each surface individually, in the Map > Manage/ Delete Maps > 
3D-model Properties>Filling Empty cells(as default)>Use base 

seismogram. 
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Important note: If a single or several base seismograms were used for building a 3D cube, then the 

user will notice that after clicking OK in the Run > Map Frame > Create 3D SEG-Y, the 

generated 3D SGY cube will NOT contain the assigned base seismogram. 

Instead, the 3D seismogram will appear in the map frame for the assigned surface. Below you 

can see the layer extracted from the 3D base cube appearing in the map frame after the generation of the 

SGY cube: 
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Once you repeat Run > Map Frame > Create 3D SEG-Y the second time, the correct cube 

will be generated. So you can always use the map frame as QC, before generating the cube. 
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3.1.11 Introducing vertical gradients in 3D cubes 

 

In addition, the user can also introduce horizontal and vertical gradients to any surfaces. To introduce a 

vertical gradient assign Map type: Top and Map type: bottom for the upper and lower 

surfaces respectively, which make up the layer where the gradient is supposed to be introduced. This is 

done in Map > Manage/Delete Maps > Properties 

 

 

Once Map type has been defined, assign the gradient value for both: the upper and lower surface (i.e. 

to the Map type: top and Map type: bottom), in the Map > Manage/ Delete Maps > 

Properties, which this will produce the vertical gradient. 
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3.1.12 Introducing horizontal gradients in 3D cubes 

A horizontal gradient can only be introduced from surfaces. Such surfaces can be easily created by 

introducing the X Y V coordinates in a text file (having the .xyz extension). These velocity surfaces are 

loaded like any other regular surfaces File> Load Map file and should be assigned Map 

type: Parameter in the Map > Manage/Delete Maps > Properties. 

 

 

Afterwards, the horizontal gradient (or the velocity surface) can be assigned to the appropriate surface in 

the Map > Manage/ Delete Maps > 3D-model Properties > > Get value from 
map. 

 

  

 

Please note that a VALUE must be introduced as well, in case there are any “holes” in the velocity map in places 

of faulting, wedging or other complex geologic features. If there are no holes in the velocity map, then the 

specified VALUE will be ignored. 
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3.1.13 Introducing cylindrical bodies and tetrahedrons in 3D SGY cubes 

The user can also introduce cylinders and tetrahedrons in any given 3D SGY cube. To introduce a 

cylinder, first of all load the SGY cube in the seismic frame File> Load Seismic file 

 

The cube in 3D (optional view): 

 

Then click Run> Velocity Model Insert cylinder in Model Cube 

 

Specify the extension of the cylinder across X , Y and Z axes, as well as its Radius and 
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Internal value. Insert cylinder     upon completion. 

Please bear in mind that X scale ≠ Z scale in the figure above. 

To introduce a tetrahedron, likewise load the SGY cube in the seismic frame File> Load Seismic 

file, then Run> Insert Tetrahedron in Model Cube. Now you will specify the 

coordinates of the 4 vertices, as well as the Internal value of this tetrahedron. 
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3.1.14 3D model building from well data 

In order to build a 3D model from interpolated mapping of well logs, the user first needs to select the 

desired oil field from the Database (in the left window of Tesseral Pro). This is done by right clicking 

the field name and selecting Select field for the project. 

 

Afterwards, the user needs to create a map with all the wells by clicking Map > Create Map (New 
Frame)>Show database WELLS. 
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The resulting blank map will contain all wells from the chosen oil field. 

Next, go Map > Calculation of horizon from well Tops and select the stratigraphic 

layers that need to mapped. 

 

Automatic select layers provides various selection criteria for choosing these layers. For 

example: Only by all wells automatically selects only the layers that are common to all wells in 

the project. 

Once the layers have been selected the user will have to specify the interpolation method to be used in 

the Choose mapping method window( see Section 14.2.4) 
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Beyond this point the generated stratigraphic surfaces can be examined in Map > Manage/Delete 

Sufaces. Draw a profile line on the map using the right mouse button (press-drag-release). 

 

Followed by assigning values to the void layers created by the stratigraphic surfaces in the Map > 

Manage/ Delete Surfaces > 3D-model Properties. 

 

From this point on, the user should follow the instructions from Section 3.1.10 (i.e. starting with 

drawing a cross section across the surfaces) first using Map>Section Mode.  
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3.1.15 Building a thin layered 3D model 

In order to build a 3D thin layered model from well data, the user will first need to create surfaces from 

the stratigraphic data in the Database wells and this procedure was explained in Section 3.1.14 

For instructions on how to import log data, as well as stratigraphic and inclinometry data, please follow 

the instructions from Section 17.5

 

Once all surfaces have been generated, the user will have to choose the well log data used for thin-

layering by accessing Map> Load Well Logs 

 

If you have not drawn a profile over your map frame already, please do so by going 

Map>Section Mode and draw the profile using the left mouse button. 
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Once the log data has been selected, the user will have to select the wells, which are to be used for 3D 

thin layered model building. In order to select a well, right click on it in the map frame and select Add 

well to profile. Repeat this for all desired wells. 

Now, all your logs should appear in the cross section of the map frame: 

 

 

The thin layering for the surfaces covered by the log data is assigned, as previously, in the Map > 

Manage/Delete Maps > 3D-model Properties tab by checking Use well log 
Values. 

 

If you would like to fill in the all the surfaces from log data checkmark Map > Manage/ Delete 
Maps > 3D-model Properties> Filling Empty Cells(as default)>Use well 

log values (for all horizons). 
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Once all surfaces have been filled select Run > Map Frame > Create 3D SEG-Y.
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Specify the X, Y, Z dimensions you want for your 3D model, the grid sampling, as well as the Filling 

cells value with which you want to fill the remaining blank layer(s). 

If you want to fill the remaining blank layer(s) from a base seismogram (i.e. from 3D 

SGY cube), then load it in the Use base seismogram. 

Here, you can also introduce limitations to the min. and max. values for the thin layering in the Value 
Range. 

Finally, after clicking OK a thin layered cube from log data will be generated. 
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Current section in YZ 

Drag one of the dashed 

section boundaries to select 

either X or Y position for a 

section to be shown in the 

related Model frame 

Current section in XZ 

3.1.16 Building 3D model with complex faults using 3D View frame 

To create from scratch or edit a 3D model use 3D View > 3D Model Edit Mode. If the model is 

created from scratch, the dialog Create 3D Model is appeared. Specify there coordinates of the 

model cube boundaries and the background compressional velocity. The program proposes immediately 

to create a Model frame directly related to the 3D model and shows the dialog Model Properties. 

(The Model frame is used to edit the model vertical sections.) In most cases it is enough to press OK. 

The default model consists of just four vertical sections corresponded to the cube boundaries of min and 

max X, min and max Y. To select one of the sections for editing in the Model frame drag the dashed 

section boundary along Y by mouse in the 3D View frame. The section nearest to the boundary at left 

mouse button release is selected. An alternative is to use the keyboard key combinations CTRL+↑ or 

CTRL+↓ within either the 3D View or the Model frame. 

 

An active (selected) slice of the model cube which is shown in the Model frame can be edited similarly 

to 2D models. The main difference is the requirement for any created polygon to be of type “top”. 

(Other types are disabled.). The program keeps an equal number of polyline vertices in each the polygon 

top boundary. It is supported by automatic inserting of insufficient vertices. Similarly, any polygon 

created in the active section will be similarly created in other sections with interpolation between the 

nearest upper and down polygons. Similarly, deletion of either 
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The vertex (800, 400, -200) 

The intersection line 

of the current XZ 

and YZ slices 

single vertex or a whole polygon is repeated in all other vertical sections of the model. But drugging a 

polygon vertex does not affect vertices of other correspondent polygons in other sections. This is the 

method of drawing complex enough 3D structures. 

Consider editing a 3D model using the next example of a trapezoidal prism. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Moving a vertex in one of the Model frames causes it to move in the associated Model frame if the 

vertex belongs to the intersection line of the current sections XZ and YZ.  

The vertex also moves in the 3D View frame. The vertex can also be moved using the Edit node 

command of the vertex context menu in the Model frame. It allows entering the exact value at the 
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point. Moving the vertex in the XZ section does not affect the Y-coordinate, just as moving in the YZ 

section does not change the X-coordinate of the vertex. You can also move the entire section along one 

of the coordinate axes OX or OY. To do this, drag-n-drop the dashed selection box while holding CTRL. 

Dragging the first and the last sections leads to a change in the boundaries of the model! (In the example 

the boundaries are sections of numbers 0 and 5.) The section can also be moved by the Move command 

of the selected frame context menu, which is accessible by clicking the right mouse button. 

 

For a better understanding of the model grid geometry, hatching is used. Besides, you can hide/show 

mesh cells (using the checkbox Show Mesh). These options can be configured using the 3D View> 

3D Model Properties menu command or the Properties command of the Object Tree 

context menu: 

 

 

There are visual options for better understanding the model grid geometry: grid lines and hatching, 

transparency. They are selected in Model > Wells & Polygons > Polygon Fill Options: 

a) b) c) 
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Uncheck “Palette” here for transparency of the polygons. 

A model layer is compound by plain bounded octagonal grid cells created by the corresponded (with the 

same number) polygons of different sections. The correspondence is expressed via the same polygon ID. 

The 3D model layer properties are specified in the related Model frame as the correspondent polygon 

properties. The properties dialog is also available via the Properties command in the context menu 

of the Object Tree. 

To insert a new horizon into a 3D model, create a new polygon of the "top" type in one of the linked 

Model frames in the usual way. To delete a horizon, select the polygon corresponding to its top in the 

linked Model frame and delete it. Or use the Delete command in the horizon context menu in the 

Object Tree. The menu commands and controls of the Model frame toolbar are used in the same way as 

for 2D models. 3D model editing commands can be undone/repeated using the standard Undo/Redo 

commands. 

 

 

New nodes are transmitted 

to other vertical sections 

automatically 

New polylines are transmitted to 

other vertical sections automatically 

“New polygon” button 
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To insert new vertical section in the model use the dashed section boundary context menu called by right 

mouse button click. Select the context menu command Insert 3D Model Section. New section 

is inserted just in the section boundary position along Y: no “regularization” of the section set is done. 

So be careful. To delete a vertical section, select it either by mouse or by the keyboard key combinations 

CTRL+↑ or CTRL+↓ in the 3D View frame. Select the context menu command Delete 3D Model 

Section. To shift the selected vertical section along either X or Y axis press CTRL and drag the 

dashed section boundary. 

In order to see the model horizons in the 3D View frame, disable the editing mode (the menu 

command 3D View > 3D Model Edit Mode) and thus, activate the view mode. In the editing 

mode, only active (editable) sections are displayed, while in the view mode, all the vertical sections and 

horizons marked with checkmarks in the Object Tree are displayed. The checkboxes at the vertices of 

the Horizons, XZ Section and YZ Section Object Tree allow you to hide / show all the 

horizons, XZ sections or YZ sections, respectively, in both modes. Using the checkmark at the Model 

node, you can also hide / show the entire model. 

 

Position of the 3D model new section 
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3D model cube 

Grid size 

Horizon maps 

from Map frame 

3D Model can be also initiated from the horizon maps stored in Map frame of the project. To do it call 

the menu command 3D View > Create 3D Model from Maps and specify parameters in the appeared 

dialog. The list of horizon maps is editable: the maps deleted from the list by the below button are 

excluded from the 3D model but left untouched in the Map frame. Min and Max parameters of the 

dialog specify the model boundaries. There is a button to automatically fit the values by the list of 

horizon maps. Additional parameters Step and Size specify the model grid sampling. 

 

Ready model is stored as a regular grid in SEG-Y cube format by the menu command 3D View > Export 

3D Model to SEG-Y. The resulting seismic cube can then be used to build a new 3D model. Such way, 

objects of complex shape can be inserted into a horizontally layered model. For example, so an 

additional horizon can be inserted above the trapezoidal prism in the considered model. Then one can 

specify its velocities, density and other properties using the previously exported SEG-Y cube as the 

background. This is done as usually in the polygon (horizon) properties dialog (see chapter 3.2.5). 
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Another command 3D View > Export 3D Model to Text Files exports separate 

model horizons in a text grid format. 
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3.2 Polygon creation and editing 

After an empty model (Model Frame) is created, it has to be filled with geological objects of various 

rock physical properties. In the Tesseral Pro, polygons are used to represent geological objects. In model 

building, a polygon is characterized by a set of parameters, such as compressional- and shear-wave 

velocity, density, anisotropic parameters and fracturing. In such manner, any area of the model can be 

filled with polygons with determined properties. 

During the setup of the modeling job (synthetic gathers calculation), a grid with the given step along the 

section direction and depth direction is created from the polygonal model. The parameters for each node 

of this grid are obtained from the polygon in which the node is located. If the location of a node is 

overlapped by several polygons, then its parameters are obtained from the upper-most polygon. 
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The polygon type to be 

created 

Bottom of the polygon 

Top of the polygon 
Polygon Type – top&bottom 

3.2.1 Create a polygon manually 

Please select the menu Model using the mouse, and then select the command New Polygon. 

 

 

In the dialogue box New Polygon, please select or specify the polygon name (Polygon Name), and 

select the type of polygon to be created (Polygon Type). The following polygon types are supported: 

 

• Polygon Type: top&bottom – the user needs to draw the top and bottom of 

the polygon. The right and left sides will match to the corresponding boundaries of 
background model (base polygon). 
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The bottom always 

matches to the lower 

boundary of the model 

Top of the polygon 
Polygon Type – top 

• Polygon Type: top – the user needs to draw only the top of the polygon. And 

then the other 3 boundaries will match the corresponding boundaries of 
background model (base polygon) automatically. 

 

 

• Polygon Type: bottom – the user needs to draw only the bottom of the 

polygon. And then the other 3 boundaries will match the corresponding boundaries 
of background model (base polygon) automatically. Please note, if the top of the 
background model is located above the zero depth, the top of polygon will be set 
to the level of zero-depth. 
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• Polygon Type: closed loop (object) – a closed boundary need to be drawn 

 

 

• Polygon Type: line (deep break) – only a line is drawn, its thickness 

can be specified by the parameter width of line (m or ft) in the 

dialogue box New Polygon when this type of polygon is selected. 

Polygo

n 

Polygon Type – closed loop 

(object) 

Bottom of the polygon 

Polygon Type – bottom 

Top of the polygon 

with depth of 0 meter 
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Polygon with thickness of 50 meters 

Polygon Type – line (deep break) 

 

Once the polygon has been created please right-click the mouse or double click the left mouse button 

(must be done within the Model Frame). Then, a new extended dialogue box will appear for users to 

edit the polygon‟s properties. After exiting from the dialogue box Polygon Properties, users can 

add more nodes to the boundaries of the created polygon by clicking the mouse on its boundary. 
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3.2.2 Change polygon’s shape 

Users can select a polygon either using the mouse or from the list of all polygons in the toolbar. The 

boundaries of the selected polygon are shown in green color. If you want to add a node to a polygon 

boundary, press the left mouse button on the boundary of the polygon. If you want to remove an existing 

node, click it with the right mouse button. If you want to move a node, press-drag-release it with the left 

mouse button. 



© Tesseral Technologies -User Documentation- 82 

3.2.3 Move/copy a polygon 

Select a polygon using the mouse by left-clicking on it or from the list in the toolbar, and then choose 

Model > Drag polygon menu to move the selected polygon or Model > Copy Polygon to 

copy it. After that, click the left mouse button inside the Model Frame to finish moving or copying. 
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NOTE: To undo the previous action, please use the Undo command. 

3.2.4 Delete a polygon 

Please use the menu command Model > Delete polygon to delete the selected polygon. 
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3.2.5 Edit polygon’s properties 

Please select a polygon with the mouse or from the list of polygons in the toolbar. The boundary of the 

selected polygon will be highlighted with a bold green line. Then, use the menu command Model > 

Edit polygon to edit the polygon‟s properties. 

 

Polygon Name is the actual name of the polygon. If a polygon reflects a layer in the well, it is 

recommended give it the name of that layer. In the Polygon Name drop-down list, the complete list 

of layers' names from the database is shown. 

The group Component is for editing the velocity, density and other parameters for the polygon. If the 

Manually checkbox is not checked, the corresponding values will be calculated automatically from 

the other parameters using empirical formulae. 

From Log – if checked, the polygon‟s properties will be obtained by interpolating the logging data. 

The Select Well-logs button is for selecting the curves in the Model Frame and specifying 

their type (velocity or density) and measurement units. 

From Seismogram – if checked, the polygon‟s properties will be obtained from the data of the 

underlying seismic file. The Property seismogram button is for selecting the underlying seismic 

file in the Model Frame and specifying their type (velocity or density) and measurement units. 

The By default button is for saving the user-specified values as the default values for future use 

when a new polygon with the same name is created. 

The Smoothing border checkbox is for smoothing the polygon‟s boundaries automatically. In 

case when the Polygon Type is top&bottom, the top and the bottom boundaries will be smoothed 

independently. 
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The Drawing Properties button is for setting the color filling of the polygon and the attributes of 

its boundaries. It is only for the visualization, not affecting the calculation of synthetic gathers. 

Smoothed boundary Non-smoothed boundary 
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3.2.6 Anisotropic/fracture/absorption p a r a m e t e r s  

To specify the anisotropy and/or fracturing parameters, press the Anisotropy & Other 

Properties button. Then, in the dialogue box Anisotropy & Other Properties, 

specify the value for each parameter shown in the pop-up dialogue box (shown below). 

By default, each polygon is isotropic. 

Thompsen‟s Parameters: ε (Epsilon), δ (Delta), γ (Gamma) and the inclination angle φ (Phi) of the 

symmetry axis of the transversal-isotropic (TI) background medium can be specified. The coefficients ε 

and δ determine the relative difference of the qP and qSV wave velocity in different propagation 

directions with respect to velocity along the symmetry axis of the background medium, and they are 

used only in the Elastic Anisotropy mode. The parameter γ determines the velocity variation of the qSH 

waves along different propagation direction, and it does not affect wavefield of a 2D modeling (it is 

added to make the description more complete and for future upgrade). 

Fracture describes intensity of fracturing in the background medium, and is characterized by parameters 

δn (Dn), δt (Dt) and the fracturing inclination angle α (Alpha) with respect to the vertical direction. Each 

layer may have 0-3 different fracturing systems. The parameters δn (Dn), δt (Dt) should be within the 

limit of [0,…,1]. The inclination angle α (Alpha) is within the limit of [-90°,…,90°]. The parameters δn 

(Dn), δt (Dt) depend on the density of fractures, Poisson coefficient of the background medium and the 

type of materials filling in the fractures. These parameters affect both propagation velocities of all types 

of waves along different directions, as well as their dynamic properties (amplitude). 

Q-factor is for specifying the parameters about the seismic energy absorption in visco- elastic medium. 

This parameter measures the attenuation of the wave amplitude for a wavelength. The Quality of 

Compressional and Shear waves can be specified separately. 

Sources type: Reflector, the option Muted is for suppressing the wavefront generated by 
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the boundaries of all polygons when the source type is Reflector. Selection of the source type is 

described in the Section 5.1. 
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3.2.7 Order of polygon overlapping 

All the polygons in the model are displayed in the same order as they appear in the polygon‟s list (the 

list in the main editing toolbar). Please use the menu command Model > Bring Polygon 

Forward to move a polygon upward, and use the menu command Model> Bring Polygon 

Backward to move a polygon downward. These commands move the polygon up/down one level, i.e. 

exchange the chosen polygon and the previous or next one. To set the correct order of overlapping 

polygons, users may need to repeat this command several times. 
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The Base Points 

3.2.8 Base points 

The base points are used to specify the components with linear gradient within the polygon. Firstly, 

select the polygon where you would like to add some base points. To add a base point to an active 

(selected) polygon, please choose the command Add Base Point in the context menu by clicking 

the right mouse button, or select the command in the menu Model > Base Points > Add Base 

Point. 

Please specify the coordinates of the base points and the values of each component in the dialogue box 

Base Point. The gradient will be calculated automatically for any 2 adjacent base points: 

 

To edit the parameters at a base point, please use the Edit Base Point command in 
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context menu by right-clicking the base point or use the menu command Model > Base Points > 

Edit Base Point for the active base point marked by square with red edge. The base points may 

be relocated by the mouse (press-drag-release) or deleted by using the command Delete Base 

Point in the context menu or Model > Base Points > Delete Base Point in the to-

level menu. 

Also, it is possible to interpolate between base points while following the geometry of the 

polygon (i.e. like in well logs). To do that right click on the polygon and select Polygon 

Properties > Interpolate like well-logs. 
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The upper base point assigns the velocity at the very top of the polygon, while the lower base point - at 

the very bottom of the polygon and the generated gradient is uniform with respect to the geometry of the 

polygon (as shown above). The right panel is the Model Frame with a coarser illustration of the gradient 

(generated by the two base points-displayed as white squares), while the left panel is the corresponding 

SGY file with a finer illustration of the gradient. 
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3.2.9 Build polygons from well’s intersection data 

This feature is supported only for models built using wells with layers. Please see Section 

3.1.4 for details about building models using well data. 

Select the Model Frame and then select the command Create polygon. In the dialogue box New 

Polygon, specify the Polygon Name from the list of layer‟s codes in the database. These polygons 

need to have been created in advance using Top and Bottom Markers and be saved in the Database. 

 

If the name of a polygon matches at least one of layer names for the wells loaded into the model, you 

will be asked to build the polygon automatically from the layer intersection data. 

 

Please see the results: 
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The automatic creation of a polygon group from several selected layers is supported, for which the 

menu command Model > Wells & Polygons > Create Polygons from Well 

Strata Marks is used. 

 

From the list of layers, select the ones you would like to see enclosed with polygons. The result will be a 

depth model created automatically. 

Automatically created polygon 
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NOTE: To build a thin-layered model from well log data, it is recommended to start the 

process using the Wizard for model creation From database WELLS. Please see 

details in the Section 3.1.4. 

3. Set the scale and the 

lines for the curve 

2. Set the type of the curve 

and the measurement units 

1. Add logging curves 

to the wells 

3.2.10 Build polygons from well logs (thin layering) 

Tesseral Pro has the capability of building a thin-layered velocity model from well log data 

(particularly using acoustic log). 

 

STEP 1. Select the acoustic logs. Please select the acoustic logs (DT or AK) in the dialogue box 

Model Properties for the Model created by well data. To do this, check the checkbox near the 

Log button on the right hand side of the Well data group to the left or right of the well. Then click 

the Log button, and in the pop-up dialogue box Log, select the needed acoustic logs from the list of all 

well logs loaded into this model. To specify the polygon parameters from well log data correctly, please 

select Compressional Velocity or dT in the Specification parameter list, and usec/m 

as Measurement unit parameter for the selected logs. 

 

After that, the well logs will be shown near the wells in the model. 

STEP 2. Build polygon. The common “thick” polygons are used for the thin-layered models. These 

polygons may be built either manually (see Section 3.2.1) or by any of the automatic methods (see the 

Section 3.2.9 and the Section 14.2.7). 

STEP 3. Set polygon components from logs (From Log). Please select a polygon and then choose 

the menu command Model > Edit Polygon. If the acoustic logs are selected correctly (see STEP 

1), the From Log checkbox should be enabled for the Compressional velocity component. 

Check this checkbox (From Log). 
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NOTE: If the selection From Log is not enabled (is grayed), click Select Well- 

logs to select the correct acoustic logs into the model. 

NOTE: After checking the From Log checkbox and clicking OK, the interpolation 

calculation for the components won‟t start immediately. And the From Log component 

value will overwrite the default value when the calculation starts. 

 

 

If the steps above are done correctly, you will see the result similar to the figures below. 

To get the second picture you need to delete the upper polygon using “Delete Polygon” button. 

 
 

 

 

Delete Polygon 

Filling the component 

from logging data 
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Modes of well log data interpolation in polygons 

Well bore 

Layer Top 

(polygon) 

Interpolation 

along the 

top and bottom 

Data 

interpolation 

Layer Bottom 

(polygon) 
Well log curve 

Polygon specifics while using well logs 

The parameters of polygons built from well logs are calculated by interpolating the well log data along 

the layer. There are 3 modes of interpolation: 

 

 

• Stratification: uniform compression. Stretching is proportional to the layer‟s 

thickness. 

• Interpolation parallel to the Top (Down lap): The data 

interpolation will be “parallel” to the “Top” boundary of polygon. 
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Top Lap Down Lap 

Stratification Model 

 

 

• Interpolation parallel to the Bottom (Top lap): The data 

interpolation will be “parallel” to the “Bottom” boundary of polygon. 

 

 

 

To display the parameters of the polygons that were obtained using logs, please use the menu 

command Model > Wells & Polygons > Well-Log Based Polygon. 

 

Well bore 

Layer Top 

(polygon) 

Interpolation 

only along the 

top 

Data 

Interpolation 

Layer Bottom 

(polygon) 
Well log curve 
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Fill Options. 

 

 



© Tesseral Technologies -User Documentation- 100 

NOTE: To build a model by gathers, it is recommended first to prepare it by the Wizard for 

building a model From SEISMIC file. Please see details in the Section 3.1.2. 

Palette transparency 

3.3 Build model from 2D/3D gathers 

Tesseral Pro allows building a model by importing velocity models having the following formats: SEG-

Y, SDS-PC, and TGR. A seismic model can be used during building of polygons as underlay or as a 

filling source for the polygons created by velocities. 

 

While building the polygons, please use the seismic underlying image as a background “picture”; it is 

also recommended to adjust the model transparency using the command Edit > Palette. 
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The component value in the gather 

3.3.1 Specify the polygon’s components by underlying gather 

In the dialogue box with polygon parameters (the menu command Model > Edit Polygon), 

please define the option From Seismogram for any component. The From Seismogram button 

will be disabled (gray) if an underlying gather is not defined or if a component is not selected for the 

gather (please see details in the Section 3.1.2). 
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3.3.2 Thomson- Tsvankin’s Anisotropy Parameters 

It also now possible to run 2.5D Elastic Modelling for mediums with orthorhombic anisotropy. An 

orthorhombic medium can be described by 7 dimensionless Thomson-Tsvankin parameters. They can be 

accessed in Polygon Properties > Anisotropy & Other Properties >Thomson’s 
Tsvankin parameters 

 

 

In the Advanced Polygon Anisotropy Parameters window the user can either specify the 

Thomson-Tsvankin’s Anisotropy Parameters and calculate the Elastic Stiffness 

Coefficients or directly specify the Stiffness Tensor for the chosen polygon. 
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3.3.3 Porous Medium Parameters 

The user can now specify the porous medium parameters for any polygon in the model. In order to 

access these parameters- right click on the polygon of interest and select Edit Polygon > Porous 

 

Once the Porosity is specified, along with the elastic wave velocities and density for the Mineral, 

Dry Rock and Fluid, the saturated rock velocities and bulk density in Polygon properties 

window will change accordingly( i.e. based on Gassman‟s equation). 
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Recevers. The receivers associated 

with the active (gray-filled) source 
are shown in black 

Sources 

NOTE: The dialogue box Acquisition Geometry Wizard is always launched at the 

very beginning of model creation. 

4 Acquisition geometry for 2D 

 

 

 

Sources are shown as triangles. To make a source active (selected) in the Model Frame, click it with 

the left mouse button. The active source will be filled in grey color. The receivers associated with the 

active source are shown as black squares. The other receivers are shown as grey squares. To move 

sources or receivers manually, use the mouse by pressing-dragging- releasing. 

The spread of sources (shot points) and receivers (receiving points) are designed by choosing Model > 

Acquisition Geometry menu command. In the dialogue box, the number of sources/receivers, 

their intervals and positions can be specified, and every source can be associated with a group of 

receivers. The users will be offered to arrange the sources/receivers geometry using a Wizard. 

 

Since it is quite complicated to adjust the spread manually, it is recommended to use the Wizard. 

 

In the Tesseral Pro, several acquisition design schemes can be implemented. Depending on the selected 

scheme, the Wizard may have 1~4 dialogue boxes. 
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Select acquisition geometry 

Select the parameters to set 

Number of sources 

4.1 Receivers move with source 

The receivers are positioned in relation to one of the sources, and then they are repeated for other 

sources of the model. 

STEP 1. Acquisition geometry 

 

In the dialogue box Observation scheme, please select Move receivers with source. 

When this mode is chosen, you should first provide the source layout, followed by the layout of receives 

relative to the same source. As a result the receiver spread will have the same distribution for every 

single source. 

STEP 2. Sources – In the dialogue box Sources, please select the set of parameters to be set from the 

list, and then enter the values for each empty parameter cell. The sources will be automatically placed 

uniformly along the acquisition surface (above the top edge of the model polygons). 

 

From – is the starting position of the source line along the model section (profile)  

To – is the ending position of the source line along the model section (profile)  

Step – source interval 



© Tesseral Technologies -User Documentation- 107 

NOTE: These parameters are related with each other by a simple relation: Number = To –

From / Step + 1. Therefore, changing one of these parameters leads to recalculation of 

others. 

Number – number of sources 

 

STEP 3. Receivers (for the acquisition geometry “Move receivers with source”) 

 

Specify the receiver distribution in the dialogue box Receivers (geophones). The parameters 

From and To do not represent the absolute distance relative to the profile origin, but the relative shift 

with respect to its corresponding source (negative value means placement to the left of its respective 

source). 
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4.2 Receivers at fixed position 

The receivers and the sources are positioned independently. Thus, for each source, a group of receivers 

have to be selected. 

STEP 1. Acquisition geometry 

In the dialogue box Observation scheme, please select Fixed receiver position. In the 

following dialogue box, you should specify the source line independently, and then specify the group of 

receivers for each source. 

STEP 2. Sources (for the acquisition geometry “Fixed receiver position”) – The dialogue box 

Sources is the same for all types of acquisition geometries. More detailed information is given above. 

STEP 3. Receivers (for the acquisition geometry “Fixed receiver position”) 

 

 

For the scheme “Fixed receiver position”, the dialogue box Receivers (geophones) is similar to 

the dialogue box Sources. The parameters From and To specify distance along the profile line of the 

model. Please see the detailed description (for the dialogue box Sources) above. 

Please specify the number of receivers (from the whole receiver line) used both to the left and to the 

right of the source. 
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4.3 Zero offset 

In this scheme, each source has only one receiver with the same coordinates. It is mainly used for ray 

tracing. 

STEP 1. Acquisition geometry 

In the dialogue box Observation scheme, please select the option Zero-offset shooting. 

In the next dialogue box, you should specify the source line. Receivers will be positioned automatically 
in a way that only one receiver is assigned to each source and the coordinates of each receiver will be 

identical to its corresponding source. 

STEP 2. Sources (for the acquisition geometry “Zero-offset shooting”)  

The dialogue box Sources is the same for all the acquisition geometries. The more detailed 

description can be found in the Section 4.1. 
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Receivers of the 

selected source 
Receivers of the 

selected source 

4.4 VSP and VSP with ascending receivers 

It is used for designing VSP acquisition geometry for the case when all sources are located on the 

surface. The receiver line can be fixed or ascending inside the well. 

 

 

STEP 1. Acquisition scheme – In the dialogue box Observation scheme, select 

VSP(moving source). 

 

 

STEP 2. Sources – The dialogue box Sources is similar to other acquisition schemes. 
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The detailed description is in the Section 4.1. 

STEP 3. Receivers 

 

 

In the dialogue box Receivers (geophones), the receivers spread is specified for the first source. 

STEP 4. Receivers (Additional parameters) 

 

 

 

Specify the way receivers should be positioned: along the vertical line or along the well. The well may 

be selected from the list of wells, which are used in the model (in the Section 12.1, it is described how to 

add a well into the model). 

Below is an example of receiver spread along a well: 
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The Move receivers for every source on parameter is used in the observation scheme 

when receivers are raised in the borehole during seismic observations.

Receivers along the well 
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4.5 VSP dipole 

Both sources and receivers are located inside the well. 

STEP 1. Acquisition scheme 

In the dialogue box Observation scheme select Dipole VSP. 

STEP 2. Sources – The dialogue box Sources is the same as other acquisition schemes. The only 

difference is that the sources are located along a vertical line or along the well. 

STEP 3. Receivers – In the dialogue box Receivers (geophones), like in the acquisition 

scheme 4.1, the layout of receivers for the first source needs to be specified. 

STEP 4. Receivers (Additional parameters) 

Select one of the 2 options how the receivers are located: along a vertical line or along the well. 

The parameter Move receivers for every source by is used for the acquisition 

scheme when the receivers are moving up along the well during the seismic observations. 
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4.6 Load acquisition geometry from gathers 

If you have field gathers then the information on sources and receivers coordinates from the trace 

headers may be used to assign the acquisition scheme for a model. 

STEP 1. Acquisition scheme 

In the Observation scheme dialogue box, select Load from seismogram. In the next 

standard File open dialogue box, select the seismic file. All the sources and receivers will be loaded 

from the trace‟s header of the selected gather. 
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4.7 Load acquisition scheme from SPS files 

STEP 1. Acquisition scheme 

In the dialogue box Observation scheme, select Load from SPS-file.  

In the next dialogue box SPS-files load, select the SPS files. If you use the SPS file of a 3D 

spread, then in the group Sources and receivers selection, adjust the criteria for selecting 

sources and receivers to be loaded into the model and the binning size. 

 

In the next dialogue box Map, select the model section along the receiver line. 

 

If the model length is smaller than the length of the selected profile in the Map dialogue, 
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you will be asked to correct (enlarge) the model. Tesseral Pro has the capability of creating a model 

using only SPS files (see Section 3.1.6 for more details). 
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4.8 Standard dialogue box for acquisition geometry 

In addition to using Wizard for the sources and receivers layout, the integrated dialogue box can be used, 

which is activated by Model > Acquisition Geometry. Then select No when asked to run 

Acquisition Geometry Wizard. 

 

The group Sources is for specifying the source layout, and the group Receivers(geophones) 

is to specify the receiver layout. The group of Sources Allocation or Receivers 

Allocation is to specify the line along which the sources or receivers will be positioned. If you 

select the option Well and a well from the list, then the sources (receivers) will be positioned along the 

selected well, as shown in the figure below. 

Specify the sources and 

receivers arrangement 

Launch the Wizard directly 

from the dialog 
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If you select the option Free in the group Sources Allocation or Receivers 

Allocation, then each source (receiver) can be positioned in the model independently from each 

other. For the other options, all sources and receivers will be positioned as a group along a specific line. 

Sources along the well 
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5 Modeling: synthetic gather calculation 

Before launching the job of computing synthetic gather, a velocity model (Section 3) and the 

corresponding acquisition geometry (Section 4) needs to be designed firstly and then the project has to 

be saved by using the command File > Save Project. 

Please use the menu command Run > Run 2D Modeling or Run > Run 3D Modeling to 

open the modeling parameter specification dialogue. 
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5.1 Modeling method selections 

The Modeling Procedure parameter is for selecting the method used for solving the wave 

equation. The available modeling methods include:  

 

• 2D Vertical Incidence is to simulate the vertical propagation of waves for 

horizontal boundaries. It allows quick evaluation of the arrival time and the amplitudes 
of the reflected waves in the time section under the condition of strict 1D propagation of 
seismic energy. 

• 2D Scalar is for the scalar model of the medium (i.e., liquid approximation without 

considering variation of density). It only takes into account the variation of 
compressional velocity and it is the quickest method for the modeling of 2D wave 
propagation. 

• 2D Acoustic is for the acoustic model of the medium, which takes into account the 

variation of compressional velocity and density. 

• Acoustic without multiples is for quickly obtaining the time section of the 

acoustic model of the medium. As a whole, it corresponds to the exploding interface 
mode of other methods, but it does not take into account the multiples and the image 
contains fewer noises. It enables users to intuitively understand the influence of multiples 
on the gather and seismic image by comparing with standard acoustic method. 

• 2D Elastic is for an isotropic elastic model. This is the main modeling method, 

which can simulate the 2D propagation of seismic energy in solid media by taking into 
account the effects of wave-mode conversion and the shear waves, as well as the effect 
of quasi- anisotropy caused by a stack of inter-bedded thin layers. 

• 2D Elastic Anisotropic is for a 2D-anisotropic elastic model and takes into 

account the variation of physical properties in horizontal and vertical direction. The input 
model can have up to 3 systems of 2D-oriented fracturing. This modeling method can 
simulate the seismic energy propagation in anisotropic medium. The anisotropic 
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parameters and/or fracturing parameters have to be specified by the user. If these 
parameters are not specified, the algorithm is equivalent to the isotropic elastic method. 

• 2D Visco-Elastic is for a visco-elastic model and can be used to evaluate the 

effects of seismic energy absorption. It also takes into account the velocity dispersion. 
The quality factor needs to be specified by the user. If this parameter is not specified, this 
algorithm is equivalent to Elastic Modeling. This modeling method allows users to 
examine the influence of fluid on wave propagation. 

• 2D Eikonal Ray Tracing is the ray-tracing method for isotropic and anisotropic 

medium and is based on the high-frequency (optical) approximation of wave-equation 
modeling. It does not calculate the multiples but may take into account converted waves 
at the reflector. The method is not suitable for a thin-layered model. This method enables 
users to evaluate horizons‟ illumination taking into account reflection waves. (Other 
methods can only show incident wave energy instead of the illumination). 

• 2.5D Elastic/Elastic Anisotropic + Visco-Elastic* is for 3D

 isotropic or anisotropic elastic model with arbitrarily-oriented fracturing sets in 3D 
space. It is assumed that the variation of the rock properties goes along the model‟s 
profile, while the variation perpendicular to the model‟s plane (along the Y axis) is 
negligible. This method can generate not only 2D/3C gathers but also 3D/3C ones, and in 
case of a vector source even 3D/9C gathers can be generated. The parameters of 
anisotropy and fracturing have to be specified. The azimuth is relative to the profile line 
of the model. Additionally modeling of frequency dependent attenuation (Visco-Elastic) 
is also an option. 2D 3D 

• 3D Vertical Incidence is to simulate the vertical propagation of waves for 

horizontal boundaries. It allows quick evaluation of the arrival time and the amplitudes 
of the reflected waves in the time section under the condition of strict 1D propagation of 
seismic energy. To access this method please first create a 3D observation system (See 7) 
then Run> Run 3D modeling 
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Note*: 2.5-3D-3C Full-wave (finite-difference) modelling, due to its 

computational intensity, is based on Parallel Options including multi-core, -

node, -GPU solutions allowing to run such simulations in a feasible 

turnaround time 

 

• 3D-3C Acoustic, Elastic* allows approximating wave propagation in 

conditions of realistically heterogeneous (in all 3 directions X, Y and Z) medium. This 
modelling can be applied to the objects like reefs, salt domes, different kinds of 
collapse/breakthrough chimneys or steeply inclined faults etc. in the areas where an 
accurate 3D reservoir characterization is required. 

 

To access this method please first create a 3D observation system (See 7) then Run> Run 3D 
modeling. 

• 3D-3C elastic TTI Anisotropic method. For this method the anisotropic 

parameters Epsilon, Delta and Gamma of the medium needs to be assigned. Either 

constant values or seismic cubes are assigned for Thomsen‟s parameters in the 3D 

Anisotropic Modeling window. The angle Phi (i.e. the angle from the vertical), 

as well as the Azimuth of the TTI axis needs to be specified. 
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For the Orthorhombic (VTI/HTI) as written, both Phi and Azimuth can be either 0 or 90 

degrees. 
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To access this method please, create a 3D observation system first (see 7), then Run> Run 3D 

modeling. 

• Haskell-Thomson is a 2D/3D modelling method that is strictly designed for VTI 

mediums. This method, in fact, is the 3D-method for a horizontally layered medium, but 
it is using for 2D-models also. If this method is applied to the medium with the curved 
boundaries, it implicitly builds a horizontally layered medium, based on the velocities 
just below the source. The main advantage of this method is the possibility to calculate 
various types of wave fields (P, SV, SH) separately. This method is not very appropriate 
to the thin-layered modelx, because the calculation time is in proportion to the number 
of boundaries. With this method it is possible to simulate point sources only, and the 
sources and receivers are assumed to be located on a common horizontal surface. 

This method implements spectral decomposition along X, Y and also time and as a result the wave field 

propagates in 1D along the Z axis. The method essentially allows the user to generate partial wave fields 

by allowing the user to choose the type of propagating (i.e. Down Wave) and receiving (i.e. 

Generate wave type) waves, while allowing full wave mode conversion in inter-bedded layers. 
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The Slowness Coefficient by x and Slowness Coefficient by y (1200 in this 

case), implies that the range of slowness is limited by 1200/Vs where Vs is the minimum shear wave 

velocity in the model. The Number parameter determines the number of used harmonics, (i.e. 

slowness). With these two variables all possible reflected and surface waves can be modeled, provided 

that a large Number of slowness is used (i.e. 601). A smaller number of slowness would result in 

modeling of reflected waves only, while supressing the surface ones (e.g. Rayleigh Waves). 

 

• 3D-3C visco elastic method is used to evaluate the effects of seismic energy 

absorption in a 3D medium with or without any VTI/HTI anisotropy. For this method 
the Quality Cube file (i.e. Q factor cube) needs to be loaded in the 3D 

Modeling General Properties tab for the 3D Elastic or 3D 

Elastic Anisotropic modelling procedure. 
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To access this method this method please first create a 3D observation system (See 0) then access Run> 
Run 3D modeling. 

 

Also, in order for velocity dispersion (i.e. frequency dependency) to be taken into account, the Number 

of relaxation mechanisms must be specified in the 3D Modeling Calculation 

Properties. Use Apparent Velocities ties the assigned velocity of the medium to the 

assigned frequency. Consequently, as the bandwidth of the signal is reduced (due to Qs and Qp), so is 

the velocity. This is absolutely consistent with applied geophysics. Whereas Use Intrinsic 

Velocities ties the assigned velocity to zero frequency and as a result the velocity of the propagating 

waves is greater than the assigned velocity in the model. The 3D viscoelastic method is most generally 

used to examine the effect of fluid on full 3D wave propagation. For more details see: 

http://petrowiki.org/Acoustic_velocity_dispersion_and_attenuation 

http://petrowiki.org/Acoustic_velocity_dispersion_and_attenuation
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The following applies to 2D modeling only. 

 

If the Source is specified as shot points, the synthetic gathers are generated successively from 

each source for the group of receivers associated with this source. Once the modeling job for all sources 

is completed, a single merged shot gather is obtained. It has the flexibility of generating the synthetic 

gathers for only a part of the sources by using the parameters From # and To #. 

If the Source is specified as reflector (exploding reflector), it is assumed that the visible part of 

the boundary of each of polygons may represent a line source oriented upwards to the surface of the 

model. Users can specify the parameter Max angle (deg) to limit the maximum angle of the 

boundary to be used as exploding reflector (by default it is limited by a 30 degree angle). 
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NOTE: It is possible to switch off the wave generation from all the boundaries of any 

polygon. To do it, select the polygon, call dialog box Polygon Properties by menu 

command Model > Edit Polygon, click the button Anisotropy & Other 

Properties in the dialogue box, and select Muted in Sources type: 

Reflector group. 

The exploding surface is shown 

in form of small sources long it 

Exploding surface mode 

 

And the method of the acquisition system in the Frame Model is changed: the sources are not shown and 

the parts of the boundaries emitting the wave are shown as bold dotted lines. 

 

If the Source is specified as surface (exploding surface), the whole ground surface is excited at the 

same time. It can enable the modeling of plane-wave propagation. 

 

These parts of interface are 

not exploding (Angle > 30°) 

Exploding reflector mode 
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In the group of Shotgather Record, duration of recording and the sample interval are specified in 

unit of ms (Start, Stop, Step). 

NOTE: After the gather is calculated using the method of exploding surface or exploding 

reflector mode, If you like to recover the acquisition geometry for shot points 

sources, call dialogue box Model > Acquisition Geometry and then select shot 

points for the parameter Source. 
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5.2 Source wavelet 

 

Select the dominant frequency of the source signal by the parameter Frequency. This parameter has 

considerable influence on quality of computed gathers and on time step needed for stable wave 

continuation. Generally, the higher the frequency, the longer the computation time. 

• Parameter Wavelet is used for the selection of the signal‟s form. In addition to 

these standard wavelet types, you may load any kind of signal from a text file by 
pressing the button Load from File. 

• Parameter Source Mode is used to specify the signal‟s directionality. 

• Parameter Surface Mode – If invisible is selected, the free-surface related 

reflection will not appear in the seismic wave field. If free is selected, the free-

surface related reflection is taken into account in the wavefield. 

• The option Use minimal-phase signal – If the option is checked, the 

amplitude spectrum of the signal will be kept unchanged, but its phase spectrum will 
be changed to obtain the minimum-phase signal. 

• The option Suppress Source SV is for suppressing shear waves. When the 

source is located closely to the free surface, checking this option can reduce strong 
surface waves in the shot gather, when Elastic Modeling or Elastic Anisotropic 
Modeling is used. 
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5.3 Additional parameters 

Some specific parameters associated with various modeling procedures are to be specified. Therefore, 

the available parameters in the dialogue box Addition differ depending on the selected modeling 

procedure in the previous step (see Section 5.1). 

For the finite difference solution of the wave equation, e.g., Vertical Incidence Modeling, Scalar 

Modeling, Acoustic Modeling, Elastic Modeling and Elastic Anisotropic Modeling, the dialogue box 

Addition consists of the following parameters: 

 

• Computation Grid Properties are the parameters of the grid size and time 

step for finite-difference modeling. It is recommended to use default values by having 
the buttons auto pressed down) 

• Generate snapshots – during numerical modeling, a special file Snap.tgr 

is created, which contains the snapshots of the wavefield. The parameter Start is 

the time when generation of snapshots starts. The parameter Step (step of 

discretization) is the time interval between two successive snapshots. 

• Generate by every … source to specify the source interval with which the 

snapshot is generated. 
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• The option Use attenuation determines whether to take into account the 

Quality factor during computation if it was specified for a polygon (please see details 
in the Section 3.2.6) 

• Margin is for widening the computation area outside the acquisition aperture. 

• Threads per process – Determines the number of cores used during 

modeling. Max means that all the processor cores are used. 

• Produce time field – During the computation of the wavefield, the time field 

of the incident waves can be generated: First Arrivals for the first arrivals of 

the incident wave and Maximum Energy for the arrival of the most-energetic 

incident wave. 

• Components: value range – When the model is built by well database 

(please see details in the Section 3.2.10), the parameters limit the values of velocity 
and density of the polygons which are obtained from the well logging data by 
interpolation. 

NOTE: The snapshots file (…Snap.tgr) for each source uses lots of computer memory. 

Additionally, merging of the snapshots for each source into one single file (this is the last 

phase of synthetic gather computation) requires significant time. Thus, it is recommended 

not to generate snapshots if you do not need them or specify larger time interval for 

generation of snapshots (parameter Step) and omit some sources by parameter 

Generate by every … source. 
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5.3.1 Eikonal Ray Tracing Modeling 

For eikonal ray tracing modeling method, the parameter Max. Dip of reflector is added, 

which limits the slope angle of the reflector. The feature of Snapshot is not supported in case of 

eikonal ray tracing. 

 

 



© Tesseral Technologies -User Documentation- 135 

5.3.2     2.5D Elastic Anisotropic Modeling 

For 2.5D modeling, the Receiver Lines for Shotgathers group is added in the first 

General dialogue box, which allows specifying the range and interval of the receiver line in the 

direction of the crossing line. 

 

If a 2D VSP acquisition geometry was built, then the user can replicate it to a circular VSP survey by 

selecting VSP radial allocation scheme of sources. 
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In the dialogue box Addition, the group Y Fourier Transform Spatial Frequency 

Range (K2) is added. It is specific for implementation of 2.5D modeling which use the spectral 

decomposition technique in the Y direction where variation of the rock parameters is assumed to be 

invariant. 
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A B C 

x x x 

y 

 = 0.2,  = −0.1, 

 = 0.03,  = 45 , 

 = 30 , VP = 2500 

y 

y 

y 

y 

y 

t t t 

Vp=4000 

 

The gathers in the A column are noisy due to insufficient range of spatial frequency (From, To). 

The gathers in the B column contain the signal from virtual sources due to insufficient 

number of spatial frequencies (Number of K2 values per shot). 

The gathers in the C column are correct. 

 

 

It is recommended to adjust these spectral decomposition parameters automatically by pressing the 

button Calculate in the lower part of the same group. 

In any case, the 2.5D modeling requires huge amount of computations, just like a 
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complete 3D case. It is accelerated by effective parallelization, especially by using GPU (NVIDIA 

CUDA). To decrease the computation time, users can specify shorter time for the parameter Stop in the 

dialogue box General. 
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Press to terminate the computation 

Log file of computation 

Snapshot for current modeling time Gather 

Percentage of computation done for 

the whole job 

Percentage of computation done for 

the current gather 

5.4 Gather Calculation rocess 

After the modeling method and the relevant parameters are specified, please press the button finish 

to launch the job and then the Modeling in Progress window should appear to allow users to 

monitor the job progress. 

 

 

In the upper part of the Modeling in Progress window, the percentage of computation done for 

the current source is shown, and the percentage of computation done for the whole job is also shown. On 

the left, the part of the gather being computed is shown, and on the right, the corresponding wavefield is 

shown. In the bottom, the log file is echoed as job is running. 

If you want to terminate computation, press the Terminate button. 

If an error occurs during the computation, the message will be shown in the lower part of the 

Modeling in Progress window. To check the log messages of a finished job, choose Run > 

Show Progress Dialog menu command. 

After the modeling job is done successfully, the Modeling in Progress window will be closed 

automatically and then the computed gathers will be displayed in the Tesseral Pro window. 
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The output files of the modeling will be created in the same folder with the project. In case of elastic 

isotropic modeling (Elastic Modeling), if the project is ModelOne.tpa, the following output files will be 

generated: 

odelOne+GathEP.sgy Gather 

ModelOne+GathEP.tgr 3-component gather TGR: 

Vertical particle velocity, Horizontal 

particle velocity, Normal stress 

ModelOne+SnapEP.tgr Wavefield snapshots 

ModelOne+TimeEP.tgr Traveltime from the source 

ModelOne+WaveEP-1.tgr Wavelet 

 

Please see the Section 13 for details about outputted gathers in the Tesseral Pro. 

Gather 

Model Snapshot 

The created files. Click the file to 

display it in the right window 
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5.5 Modeling using cluster and windows network 

To use the finite difference methods (except the 2.5D Elastic Anisotropic Modeling) available in the 

Tesseral Pro to compute the synthetic gathers, it is enough to have a modern PC. For the 2.5D Elastic 

Anisotropic Modeling, the runtime can vary from several hours to several days, depending on the model 

size and the selected computation parameters. Due to this fact, it is recommended to use a cluster or a 

network of PCs to launch the 2.5D Elastic Anisotropic Modeling. 
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5.5.1 Modeling using a cluster 

In Tesseral Pro, the model can be prepared within Tesseral Pro and the job for computation of synthetic 

gathers can be launched on a cluster. The cluster may work under Windows or Linux (UNIX). The 

Tesseral Pro package does not work directly with the cluster. It is assumed that the users copy the job 

and the model to the cluster explicitly, launch the job and copy the computation results back to Tesseral 

Pro for visualization. 

To prepare the job for a cluster, call Run > CLUSTER: Create task. The dialogue box for job 

preparation is similar to the dialogue box for setting up jobs in the Tesseral Pro (see Section 5). For 

example, for the project ModelOne.tpa with 3 sources, the following files will be generated: 

runtask.ini 

ModelOne1.tam 

ModelOne2.tam 

ModelOne3.tam 

 

Here ModelOne1.tam, ModelOne2.tam…, are the model files associated with each source. 

“runtask.ini” is the main file where the modeling parameters for the job are saved. 

It is recommended to create an empty folder where this job will be created and saved. In this case, the 

benefit is that users will not need to check whether a file is related to this job or not. The 2.5D 

computation engine for a cluster may be downloaded from the website http://www.tesseral-geo.com 

under page “DOWNLOADS”. The needed user documentation is in the archive with each program. 

http://www.tesseral-geo.com/
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Computers available 

in the network 

Distributions of sources among 

computers in the network 

 
 

 

 

 
 

 

 
 

Percentage of computation done in each of computers 

5.5.2 Modeling using Windows network 

For large computation tasks, Tesseral Pro provides a special utility TesseralFarm. TesseralFarm is a 

utility complementary to the Tesseral Pro and it is designed to implement cluster functionality in the 

Windows networks. Compared to the cluster under Linux architecture, the cluster created with 

TesseralFarm requires far less efforts for preparation and has more flexible topology and sufficient 

potential for enhancement. After computers are connected to a local network and the program is tuned, 

the computation tasks can be broken down and allocated to each computer. TesseralFarm gives the 

possibility to manage computations in separate nodes and to obtain (merge) the common result. 

Please see details about the installation and tuning of the TesseralFarm in separate document. 

Job launch and job distribution in a Windows network is done in Tesseral Pro by calling 

Run > NET: Run modeling. 

It is possible to get all computers available in the network by using Actions > Add All 

Available Servers. 

 

Distribution of the job among the nodes (computers) is shown in the column Queue. For modeling, the 

sources allocated to each node are shown. You may change the number of sources for each node by 

double-clicking in the list. 

When you have selected the nodes, please press START and the program will start copying the files to 

the nodes (this may happen instantaneously or may take some time, depending on the sizes of files and 

network speed). Once the copy of files to the nodes will be completed the computations in the nodes will 

begin. You can monitor the computation in each node by the messages under the column % done. 

 

 

If you like to terminate the computations in one of the nodes, please right-click that node and select 

Break calculation. 

If you like to terminate computations in all nodes, click STOP. 

Once the computations in all the nodes are completed, the computation results are located in the folder, 

from which the job was launched. 
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The modeling is finished. 

The results are merged 
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Set the main 

parameters to their 

default values 

Select sources 

for ray tracing 

Type of reflection 

Set the step 

of the grid 

Select the reflecting 

boundary 

Select the reflecting 

polygon 

6 2D Ray tracing 

STEP 1. Create a new or select an existing model (the command Model > Create Velocity 

Model (New Frame) or Edit > New Frame > Model). The model must have sources and 

receivers (Model > Acquisition Geometry). 

STEP 2. Select the polygon, for which you would like to run the ray tracing. 

STEP 3. Launch the job by the command Run > 2D Model: Ray Tracing 

 

More information about the ray tracing parameters can be found in the section 6.3. 

Here is the result of this method: 
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In Tesseral Pro, the ray tracing calculations can be accumulated by repeating the command Run > 2D 

Model: Ray Tracing. If the calculation is recalled with the same parameters for the same layer, its 

results will automatically replace the existing results. By default, the Model Frame shows the result of 

the last calculation. The ray paths displayed in the Model Frame for the current calculation can be 

changed by using the command Model > Raypath Data and Visualization 

Properties. In the same dialogue box, you may see the parameters of the current calculation, 

change the mode of displaying the rays and delete some of the past calculations. 
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Delete all ray tracing 

calculations 

Delete current 

ray path 

Show actual (curved) ray traces. If unchecked 

– source, reflection and receiving points are 

connected by straight lines 

Parameters of the 

current calculation 

Selection of particular 

calculation for drawing 

Rays drawing 

modes 

 

 

 

NOTE: All ray-tracing calculations are saved in the project file (“.tpa” file). Please ensure 

that ray calculation results will not overwhelm the document. Delete the unnecessary 

calculations by the dialogue box Model > Raypath Data and Visualization 

Properties. 
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6.1 Ray-path display in Frame Model 

 

• Show all rays – The ray paths from the current calculation are shown. 

• Show Raypath for active source only – The ray paths from the 

active source are shown. The ray paths from non-active sources are marked in grey 
color. 

 

• Show rays of region – Display the ray paths from the current calculation 

whose source, receiver and reflection point are within the selected area. To define 
the region, in the dialogue box Model > Raypath Data Visualization 

Properties, please select Show rays of region and then check Select 

region by mouse. Then select the region of the model for displaying rays by 

pressing dragging and releasing the left mouse button. The mode of the region 
selection will be cancelled automatically after the left mouse button is released. 
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6.2 Ray-path display in gathers 

Please load the field gather or the synthetic gathers calculated by the eikonal ray tracing method or 

finite-difference methods into the Seismic Frame. It is implicitly assumed that this is the gather 

corresponding to the model, for which the ray-tracing was done. Please use the command Seismic > 

Highlight Traced Ray Reflections to show the ray paths in the gather. 

 

The command Seismic > Connect Ray Reflection Points changes the mode of 

displaying reflection times in a gather (lines with captions or dots). 
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6.3 Ray-tracing parameters 

Ray tracing parameters are specified in the Ray Tracing dialogue box, after selecting the command 

Run > 2D Ray Tracing. 

 

Main Parameters 

• Reflecting boundary (polygon) is for selecting a polygon and a 

reflector (top or bottom). 

• Grid Cell size is for specifying the grid size. The bigger is the value, the 

faster is the calculations and the lower is the accuracy of the raypath. 

• Margin is the maximum deflection angle. 

• Hade err, angle of is the allowed deviation of the reflection angle from the 

incidence angle (i.e. allowed deviation of the law of reflection). 
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Without Trace real raypaths With Trace real raypaths 

 

• Trace real raypaths is for calculating the actual raypath from the source to 

the reflector and then back to the receivers. 

 

• Separator (account the boundary overlapping) – If the boundary is 

fragmented by the overlapping polygons, the calculations for each piece of the 
boundary are done separately for all receivers and sources. and they ray paths for 
each compartment will be colored differently. 

• Loop – Up to 3 reflection raypaths are calculated for each pair of source and 

receiver. 

Margin Margin 
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NOTE: The anisotropy parameters are specified in the dialogue box for specifying the 

parameters of the model layers. Please select the command Model > Edit Polygon, 

and then in the dialogue box Polygon Properties, click the button Anisotropy & 

Other Properties. 

 

• Group Sources – Please select the sources for which you would like to run the 

ray tracing. The parameter Every (receiver) determines the step in receivers 

for each source. 

• Group Time: P-time file, S-time file – For the ray tracing, you can 

use the files of travel time that were previously calculated by any finite-difference 
modeling method (the command Run > Run modeling). 

• Use Anisotropy – Please check it if you want to take into account the 

anisotropy during the ray tracing. 

 

• Group Model – By default, the option Generate before ray tracing is 

checked because calculation of the model may be long (if the velocity for the model 
polygons is calculated by well log curves). If the model has not been changed since 
the last ray tracing or modeling, the new model calculation is not required and you 
may leave the checkbox Generate before ray tracing unchecked. 

• The button Default is to set the default parameters and file names automatically. 

Two reflection points for each pair of source-receiver 
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7 3D Seismic Survey Design and Planning 

3D survey design in Tesseral Pro can be done manually or a survey can be loaded from standard SPS-

file. 
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7.1 3D survey 

 

First of all you need to create a frame Map with topographic background taken from picture (see 7.1.1). 

If you create a 3D survey design manually, you should use the option Map/Acquisition 

geometry to choose the pattern and basic parameters for 3D survey (see 7.1.2). Use Map/3D 

survey modes menu command to adjust your design parameters and layout to match the real 

topographic map (see 7.1.3). 
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7.1.1 Load Map using backgroud picture. 

Command: Map/Create Map (new frame). 

 

In the dialog Create new Map, press Select background PICTURE or Load TXT or 

GRD-surface files (see section 14 for the latter). Choose the picture file with the desired 

topographic map. Tesseral Pro supports the following picture formats: BMP, JPEG, TIFF, GEO-TIFF, 

GEO-JPEG with coordinates in TFW, JGW files. 
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You need to input coordinates for two base points in the Background Picture dialog to align this 

picture with the real topographic map. You can move these points manually in the lower part of this 

dialog using the mouse. For example, when you click mouse and choose Point “2”, the 

Horizontal and Vertical edit boxes become enabled for inputting applicable coordinates. The 

same will be true for Point “1”. 

If the picture coorditate system is different from the project one, specify it using the dialog called by the 

button Convert COORD. 

 

The result: 

Point “1” Point “2” 
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NOTE:  Please  remember  that  map  axis’s  orientation  can  be  specified  in  

the File/Project Properties dialog: 
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To add more background pictures and/or specify their coordinates select a frame Map by left mouse 

button click and call the command Map/Edit Frame Properties. In the Map Properties 

dialog press the Background Picture button in the Background group: 

 

 

In the appeared dialog one can select and setup one or several background pictures: 

In Tesseral Pro the background picture for the map cannot be rotated to 90°, but it can be 

mirrored in relation to vertical/horizontal axis (flipped). Because of that, you put 

coordinates of base points in Background Picture dialog not as X and Y values, but 

as a distance along vertical and horizontal axis. 
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Multiple pictures (usually either 2 or 4) are used at the junction of cards or photos. 

 

If you want to hide the background picture and not show it in frame Map, you should use 

Frame Map Properties, and uncheck Show Picture. 

To remove background picture press Background Picture and then click either 

Remove or Remove All. 

 

Now you can use the created Map frame for the 3D survey design. 
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7.1.2 Choose 3D survey design. 

 

Select the Map/Acquisition Geometry menu command. 

 

 

 

Tesseral Pro can support different types of 3D survey design. 

 

1) Orthogonal 

 

2) Shot in crankshaft pattern 
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3) Diagonal 

 

4) Load survey from SPS-files (see 7.1.8) 

5) Load from SGY-files (see 7.1.8 ) 

6) VSP azimuthal 

7) VSP radial 

 

8) VSP orthogonal 

9) Marine flank (see 7.1.3) 
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NOTE: the additional parameters right from the first column of increments depend 

on the survey type. 

 

including the “flip-flop” type: 

  

…and several other. 

 

In the 3D Survey Layout tab you can specify the increment between Shot and Receiver Lines 

and their stations. 

 

 

 

In the Recording Patch tab you can specify the number of receivers engaged with every shot. In 

Inline receivers group and Crossline receivers group you can specify the number 

of receivers nearest to a shot which fall into this group. If you choose the By Distance group you 

need specify the Radius of the circle which will enclose all receivers around the shot point. 
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NOTE: You can design recording patch of any shape using options Remove 

Receivers from Shot and Add Receivers to Shot. These options can 

assign receivers to a recording patch. In this case the Recording Patch dialog of the 

Acquisition Geometry you can click Use mask, and Inline receivers 

group and Crossline receivers group will be ignored and a newly designed 

recording patch will be used for the whole survey. 

 

 

In Survey bearings you can specify the dimensions and direction of 3D survey. 
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NOTE: The coordinates of the 3D survey‟s Origin Point (X beg., Y beg.), 

INLINE/CROSSLINE Length and Azimuth can be assigned “visually” in the Map 

frame using Map/Section Mode command. Draw a profile line using left mouse 

button (click- draw-release) and open the Map/Acquisition Geometry dialog. If 

you are creating a 3D survey for the first time the direction of this survey will coincide with 

the direction of the line which you have just drawn. If you want to change the dimension or 

direction of an already created survey then using the mouse you need to select the 

command Map/3D survey Modes/Moving with rotation. See the 

instructions below... 

Result: 
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7.1.3 Marine surveys 

For marine surveys the configuration of the source-receiver geometry can be specified in the Seismic 
system deployed from the vessel. 

 

 

The parameter Distance between shots is used to specify the distance between the two sources 

(water guns) of the “flip-flop” marine surveys. If the only water gun is used, set the distance to 0. 
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The Free Cable option allows the user to maintain the recording patch stationary for all sources 

along the Inline direction. The Frequency of Moving specifies the frequency of the recording 

patch displacement along the Crossline direction. For instance a frequency of 2 means that the recording 

patch would be displaced for every second source in the Crossline direction. The Moving Step is the 

displacement step of the recording patch along the Crossline direction for each consecutive source along 

the same direction. So a Moving Step of 200 would mean that the recording patch would be 

displaced 200m for every source (i.e. if the Frequency of Moving =1) along the Crossline 

direction. The Start Position specifies the starting position of the recording patch (i.e. the 

position of its lower left hand corner for a zero azimuth). So for example a Starting Position for 

Inline=0 and Crossline=0 means that the starting position of the recording patch would be at the 

lowermost left hand corner of the 3D survey, as shown below. 
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Drag to increase or decrease 

length of Inline 

If you click inside 3D survey area, 

you can move the whole survey 

layout up-down and left-right 

inside the Map frame. 

Use this point to rotate 

survey (azimuth 

change) 

Drag to increase or decrease 

length of Crossline 

7.1.4 Move and Rotate 3D survey. 

The Map > 3D survey Modes > Moving with rotation command is used to correct the 

3D survey positioning on a map. Use left mouse button (click- drag-release). 

 

 

Another mode of the survey move is its vertical projection on the day surface, a selected horizon or a 

plane of the specified depth. The Map > Set Shot/Receiver Depths command is used to 

implement the operation: 

 

There are two methods of the vertical shift: the station projection preserves horizontal 

coordinates of the stations when the station chaining limits max distance between the neighbor 

single line stations along the target surface and hence may shift the stations along the line. 
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7.1.5 Edit Shot and Receiver Stations. 

Option Map/3D survey Modes/Hide is used to hide not needed shots or/and receivers from a 3D 

survey. 

  

The user has the option to hide shots and receivers by Eraser (where the eraser is in the form of a 

circle with a specified Radius) by pressing the left mouse button, holding it and selecting the area 

which is to be hidden. Hidden shots/receivers will not take part in the following 3D survey design. 

Hidden shots and receivers will be not shown on the Map frame in most the edit modes. In some modes 

they are by default shown grayed and crossed. The icon color, size and form can be fitted in the frame 

parameters dialog. 

For Select Group by Polygon a polygon needs to be drawn and all the shots and receivers 

inside it will be hidden. In order to implement it simply use the left click mouse button to draw a 

polygon around a group of shots and receivers. To start over the drawing click the right mouse button. 

Once the polygon has been drawn, double click the left mouse button and all the shots and receivers in 

the polygon will be hidden. 

Similar options Select outside of… and Select inside of… use predefined 

polygons from the selected static layer. 
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You can also hide shots and receivers by specifying a limit along the X and/or Y axis: 
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Use Select All to hide all shots and receivers. 

 

If you want to bring hidden shots/receivers back into survey you need to use option 

Map/3D survey Modes/Show. The same methods for showing shots/receivers apply. 
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NOTE: If you want to use options Hide/Show separately for shots and receivers (for 

example, to hide a group of shots, but to leave receivers there), you need to check 

Map/Show Shots or Map/Show Receivers respectively. As a result shots or 

receivers will not be shown in the Map frame, and editing will be possible only for shown 

elements (shots or receivers). 

 

 

In order to increase or decrease the editing precision use the scaling option in the 

View/Zoom command. 

Hidden area of survey 

(not used in simulation) 
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By default the icons of sources and receivers (together called stations) are scaled by zoom like other 

graphic elements. For better resolution, however, it is sometimes useful either completely cancel the 

station scaling or significantly decrease its relative speed. It is done in the frame parameter dialog: 
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Here one also can setup the station icons in the dialogs activated by the buttons Source 

and Receiver: 
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The button Save as default remembers the station settings for further projects. 

 

Below is a sample of alternative design created by the described tools. 
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7.1.6 Change Direction for Shot and Receiver Lines 

Using the menu command Map/3D survey Modes/Moving Shot and Receiver lines 

you can change the shape for Shot and Receiver Lines in order to adjust them to real land topography. In 

order to do that 4 types of displacements have been implemented: Cable Move used if you want to 

reposition shot/receiver lines in a cable fashion (such as orienting the shot/receiver line along a different 

azimuth), Point Selection to displace individual shot(s)/receiver(s), Line Selection to 

displace the whole line to a different position while preserving its geometry, and Polygon 

Selection whereby you draw a polygon around a group of shots/receivers and displace the whole 

group to a different position. 

The following example illustrates a Cable, and the same principle applies to selection 

Point and Line modes. 

To show this example without obstacles, the background picture has been hidden (in dialog Frame 

Map Properties we clicked off Show Picture), Receivers were hidden as well (clicked off 

Map/Show Receivers). 
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After the creation of the first 3D survey each Shot/Receiver Line has two “anchor” points which tie a 

line to its plane position. So you can: 

1. Change the “anchor” position using the left mouse button (click-pull-release); 

2. Remove an “anchor” by double clicking of the left mouse button; 

3. Add a new “anchor” - click the left mouse button at any shot point. 

 

The same can be applied for Receiver Lines: 

 

Shot and Receiver Lines can be moved independently or together: 

Moving Shot line 
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For Polygon Selection simply use the left click mouse button to draw a polygon around a group 

of shots and/or receivers. which need to be moved. Right-clicking interrupts the process of drawing a 

polygonal border, and double-clicking completes and saves the border drawn. After double-clicking, 

press the right mouse button and, without releasing it, move the mouse. The program will display the 

moving group as a described rectangle. Move it where you need and release the mouse button. The 

group will move to this place. 

 
 

Station coordinates and numbers 

Use the context menu command Shot/Receiver Coordinates in the Survey Line mode to show 

coordinates of a station selected by a left mouse button click: 
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The dialog does not disappear if you switch to another edit mode such as Zoom mode to 

increase the survey resolution. Yet it stops working until the Survey Line mode is restored 

by Map > 3D Survey Edit Modes > Moving Shot and Receiver 

Lines or the correspondent toolbar button. 

 

The dialog is floating (non-modal) and you don‟t need to close it to see coordinates of another station. 

The coordinates can be changed and remembered by the button Set. The change will result in moving 

the source or receiver in the specified coordinates. 

Position and Line  are formal sequential numbers that do not depend on the location of the station 

and inline/crossline numbers in SPS. The position number is a sequential number for continuous 

numbering of sources or receivers (i.e. without taking the line into account). It is not affected by either 

moving or deleting (or, more precisely, disconnecting) some stations. The same is true for line numbers: 

they are sequential and do not change if some lines are disconnected. Well, the station identification 

(inline/crossline numbers) in SPS is displayed by the Inline ID and XLine ID parameters. The -1 

values of these parameters, which you see in the previous figure, simply mean "not defined". They are 

defined from the very beginning only for layouts loaded from SPS or SEGY files. Otherwise, they are 

set only at the time of exporting the layout to SPS. 
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7.1.7 3D recording patch design. 

First of all you need to specify a recording patch for each shot in Map/Acquisition Geometry 

dialog in the Recording Patch tab (see 7.1.2). Inline receivers group and Crossline 

receivers group parameters identify the number of nearest receivers which will be assigned to the 

current source. 

You can change a shape of recording patch using mask and apply it for the entire survey. First of all you 

need to choose a source in the middle of the survey. In Map/3D survey Modes/View Relation 

menu command click the selected shot point. The chosen Shot will be highlighted with a red dot, the rest 

of shot points will be shown as grey dots. Receiver points associated with the chosen source will be 

colored in blue and the rest receivers will be grey: 

 

You can add or remove receivers around this shot point by using Map/3D survey Modes/Remove 

Receivers from Shot and Map/3D survey Modes/Add Receivers to Shot 

commands. These two commands behave similarly to the Hide/Show command (click- drag-release). 

Example: 
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Now you can pick any source in Map/3D survey Modes/View Relation and the group of 

receivers allocated for that source will have identical shape. At the same time the Acquisition 

Geometry dialog in the Recording Patch tab the “Use mask” checkbox will be automatically 

enabled: 

 

In other words, the receiver patch is specified by the mask which has been shaped manually but not by 

parameters Inline (Crossline) receivers group. 
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7.1.8 Load survey from SPS-files. 

Here is another useful way to create 3D survey using standard SPS-format. You can use the same 

command Map/Acquisition Geometry. 

 

Select Load survey from SPS-file and press the Select SPS-files button. 

In the next dialog load the SPS-files for shots, receivers and their relation file.  
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Check Sea observations if the SPS describes a marine (offshore) survey. 

Press Next> and the next dialog with the 3D survey loaded from these SPS-files will be 

displayed. 
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You need to input coordinates for the ORIGIN point and the INLINE Length and Azimuth in this dialog. 

This line is needed to make it easier to move and rotate the 3D survey which has been loaded from SPS 

files. It is recommended to use mouse to draw the line on the map (click- drag-release). You do not have 

to be precise with line drawing. 

You can zoom in this picture by pressing the Zoom map button to view it at a bigger 

scale. 

There is also an ability to specify the SPS coordinate system different from the project 

one. It is implemented by pressing the button COORD Convert: 

End of the 

profile line 
Start of the 

profile line 
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The dialog is similar to the one used in File / Project Properties to specify the project 

coordinate system. 

As soon as you finish loading the SPS-files, you will be prompted to Acquisition Geometry 

dialog. 

 

The 3D survey Layout and Recording Patch tabs will not be used when you proceed with the 

Load survey from SPS-files option. In the Survey bearings tab the dimension 

parameters will be ignored but the 3D survey geographical parameters are necessary: 

 

Result: 
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Example of hiding Shot Points loaded 

from SPS-file 

 

You can edit survey loaded from SPS-files using the commands Moving with rotation, 

Hide, Show: 
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7.1.9 Load survey from SGY-files. 

There is also the option of loading the seismic survey from synthetic seismogram in SGY 

format. 

  

Select Load survey from SGY-files and press the Select SGY-files> 

button. 
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7.1.10 3D survey export to SPS-files. 

The 3D survey created in the Map frame can be exported into standard SPS format. To do this use the 

Map>Export to SPS menu command. Select a source file name, and the receiver and relation files 

will be created automatically. As the result you will have three SPS files: 

• S01 – source; R01 – receivers; 

• X01 – relation file. 

 

Furthermore, it is possible to assign inline/crossline numbers (different from the standard n=1, 2, 3, 4, 

5…) to the shots and receivers in the exported SPS file. In order to do it, select Apply next 

numbering for sources and/or receivers. Then specify the Line Numbers and the Station 

Numbers separately for sources and receivers. Set the values which correspond to each other, so that if 

a source and a receiver are located in the same position, the shot line number is the same as the receiver 

station number and the shot station number is the same as the receiver line number. 
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7.1.11 3D survey export to KML-file. 

The 3D survey created in the Map frame can be exported into standard KML format, which is the format 

used for displaying objects used by Google Maps. To do this, please use the Map/Export 3D 

Survey to KML menu command. 

 

 

Choose a name for the output KML files, the reference Ellipsoid, as well as the zone number. As the 

result 2 KML files will be generated: 

Sources.kmz  and Receivers.kmz; 
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7.1.12 Manage Static Layers. 

In the map frame it is also possible to import static layers (i.e. spot boundaries) strictly for visual 

purposes. The importation can be done from text file using a simple format: coordinates X and Y, then 

the line number (as shown below). As well static layers are loaded from shapefiles and DXF (Autocad) 

format files. 

 

 

In order upload a Static Layer select Map > Manage Static Layers > From File. The 

program shows dialog which allows one to specify the static layer coordinate system if it is different 

from the one of the project (to do it check Coordinate conversion To system and specify 

other coordinate system parameters of the imported file): 
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After importing the static layer you can select View and edit the properties of the line. 

 

You can also rename it (using Name), add an additional static layer (From File...) 

or delete any of them (by selection in the list and using Delete). 

The button Info shows the area covered by the selected static layer: 
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If before OK one checked Set to Work Area then after exiting the Manage Static Layer dialog the 

map area will be changed by the static layer rectangle. 

 

Once done, press Close and click mouse in the map frame. The new/edited static layers will appear in 

your map. 
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7.2 Coordinate Reference Systems Options 

 

Please note that multiple coordinate reference systems are available in the frame Map, and they are based 

on the following ellipsoids: WGS-84 (GPS), NAD-83 (GRS), NAD-27 (Clarke 1866), ETRS-89, SK-42 

(Krasovsky), PZ-90 (GLONASS), GSK-2011. 

In order for the chosen reference coordinate system to be displayed, it is necessary in the Map> Map 

Frame Properties> Project properties… to set non-zero coordinates for Easting and 

Northing of Point (i.e. upper right hand corner of the map) for the chosen Ellipsoid. And 

also to set a value for the Central Meridian of the Projection (degrees) of the 

ellipsoid, which is conventionally set to zero. 
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7.3 Survey planning 
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7.3.1 Fold Map menu and toolbar. 

The planning can be accessed in one of two ways: 

 

1) In the tab manu Map => Fold Map 

 

2) In the quick access toolbar 

 

 

 

The following attributes can be displayed for any 3D seismic survey: 
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– Fold Calculation Properties 

– Displaying all bins by selecting Show Bins Grid 

 
– Displaying the fold by selecting Show Fold Map 

– Displaying the offset distribution histogram for every bin by 

selecting Show Offset Distribution Map 

– Displaying the azimuth distribution for every bin by selecting 
Show Azimuth Distribution Map 

– Setting the display mode for the map by selecting Fold Display 
Options 

– Displaying the survey bin statistics by selecting Show Bins Grid 
Statistics 

– Displaying the information for a particular bin by selecting Show 
Selected Bin Information 

– Showing graphical statistics for the fold map by selecting Show 
Plot Statistics 
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7.3.2 Fold Calculation Properties 

 

The dialog is divided into four parts: 

First Bin Size, where you can adjust the size of the grid for calculation. There are three ways to do 

it: the first - to set the length (Crossline Bin Size) and the width (Inline Bin Size) of the 

bin, the second - set the number of bins in the X (Inline Bin Count) and Y (Crossline Bin 

Count) direction of the planning area and the third - automatic calculation (Auto Fit). In this case 

the length of the bin is equal to half the distance between the receivers and the width equals half the 

distance between the sources. 

Second, using Extent, you can set the scope of the calculation, i.e. determine which sources and 

receivers will not be included in the calculation. This can be set in three ways: to fill in the appropriate 

fields by clicking (All) - to select the entire field, press the button (Mouse Selection) in order to 

select the area manually, after which the dialog box temporarily closes in order to allow the user to 

select the boundaries with the mouse. 

The image below, shows a selected region by Mouse Selection: 
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The corresponding fields displays the coordinates of the selected area: 

 

 

Below is the calculated Fold Map within the boundaries of the selected area: 
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The third part of the dialog is the Recording Patch. It contains three different types of source-

receiver relationships. The first one is (Relations from SPS-File) –which preserves the 

grouping from the SPS file, provided that the survey was loaded from SPS file. 
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The second method (By Group) - set the number of receivers per line (Stations Count) and the 

number of lines (Line Count). The above 30/10 scheme produces the following image: 

The third method (By Distance) - which assigns receivers for every source within a specified 
Circle Radius 
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The above 500m Circle Radius produces the following image: 

 

The fourth part of the dialogue is the Limits - with which you can limit the Offset and Azimuth 

for source-receiver pairs that are included in the fold calculation. If the box (Make Offset / 

Azimuth Limits Exclusive) is not enabled then only sources/receiver pairs From <= 

Offset / Azimuth <= To will take part in the fold calculation. If enabled, then only 

source/receiver pairs From> Offset / Azimuth> To will be included. 
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7.3.3 Fold Display Options 

 

 

Fold Display Option - Dialog for setting the display mode for the calculated attributes (Fold, 

Offset and Azimuth). 

For Fold Map there are different types of displays: Color and Value – Fills the bins with the 

appropriate colour from the colour bar and also displays their values. 
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Only Color - Just the color is displayed 

 

 

Only Value – Just the value is displayed. 
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For Offset Map the following display options are available: 

No Color – Colorless scale. The x-axis of the histogram corresponds to the inline bin direction. The 

scale ranges from zero offset on the left edge of the bin to max offset on the right edge of the bin. The y-

axis corresponds to the offset (the maximum offset occupies almost the entire height of the bin, and the 

minimum offset has height close to zero). Gaps between the lines represent a discontinuous offset 

distribution. 
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Color - Displays the “Redundancy”, i.e. the number of times each offset falls into the same bin. A 

single offset has a colour corresponding to redundancy of zero. For more than 1 offset a color is assigned 

to it according to the redundancy colour bar. 

 

Min Offset – Fill the bins with the colour corresponding to the minimum offset. Max Offset – 

Fill the bins with the colour corresponding to the maximum offset Mean Offset – Fill the bins with 

the colour corresponding to the mean offset. 

Median Offset – Fill the bins with the colour corresponding to the median offset. 

Offset Range – Fill in the bins with the colour corresponding to the difference between the largest 

and smallest offset. 

Largest Gap – This option displays a color plot of the largest offset difference between any 

consecutive offsets in each bin. 

 

Offset Variability (Coefficient of Variation): This plot calculation is a relative dispersion 

measurement in each bin. This will calculate the standard deviation of the gaps in the offset range and 

divides the answer by the mean gap. This calculation can only produce a value for bins with at least 3 

fold. Normalization is no longer performed. The lower the values in the color scale, the better the offset 

variability The formula for the calculation is as follows. 

 

s= standard deviation of the offset gaps, formula shown below. x=offset gap (difference between 

consecutive offsets in a single bin) n=number of offset gaps (15 fold bins have 14 gaps) 
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The offset variability is then calculated as: 

Offset Variability = s / mean of x (per bin) 

For Azimuth Map the following display options are available: 

 

No Color – Colorless scale. Showing "spiders", i.e. the distribution of azimuth directions of source-

receiver pairs that fall in each bin. “Spider limb” length depends on the offset. 

 

Color - Displays the «Redundancy», i.e. the number of times each azimuth falls into the same bin. A 

single azimuth has a colour corresponding to a redundancy of zero. For more than 1 azimuth a color is 

assigned to the “spider limb” according to the redundancy colour bar. 
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Circle Plot - Concentric circles correspond to offset ranges, and the offset increases with 

increasing radius. To change the distance between circles use the - Line Increment in the field - in 

the Offset tab. 

 

Offset to Azimuth – The midpoint locations for every bin are shown across an Offset vs Azimuth 

grid. The offset is plotted on the axis X axis (ranging from min to max across each individual bin), while 

the azimuth is plotted on Y-axis ranging from 0˚ to 360˚, across each individual bin. To change the 

offset increments change the Line Increments parameters in the Fold Display Option 

window. Each midpoint is indicated by an asterisk at its corresponding position across the Offset vs 

Azimuth grid. 
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Trace Azimuth – Filling the bins with color corresponding to azimuth colour bar, meeting the 

criteria restrictions specified in the - Line Increment tab for Offset. In other words, the Azimuth 

is displayed as a function of the first trace greater than or equal to the specified Offset. 
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7.3.4 Bin Grid Statistic 

 

Bins Grid Statistics - contains statistical information on sources/receivers, surface area and 

bins. It is possible to calculate the area for a particular region of interest in two ways: 

1) Specify the fold range in Min Fold and Max Fold, and the total area for the bins 

within the Min-Max fold interval will be calculated. Reset button resets the value 

for the Min Fold and Max Fold. 

 

 

2) Draw the contours of the polygon using the mouse by clicking on Mouse Selection. 

In the meantime the Survey Statistics dialog is minimized and the left mouse 

button is used to draw a polygon. Once finished, click the right mouse button, after which 
the Survey Statistics will reappear and the corresponding Area will be 

calculated. 
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The result: 
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7.3.5 Selected Bin Informartion 

 

After activating the option Selected Bin Information, click on any bin and this will bring up 

the Selected Bin Statistics dialogue with contains statistical information for that particular 

bin. While in this mode you can switch between the bins and the Selected Bin Statistics 

dialogue will change accordingly. 

 

The dialogue consists of three parts: the first one Bin: its serial number according to the origin and the 

coordinates of the seismic survey; second Attributes contains the statistics for that bin; and the 

third part – the graphic statistics for the offset and azimuth corresponding to the No Color display 

for both Offset and Azimuth. 

Also there is a button Show Spider - to display all source-receiver pairs whose midpoints fall in a 

selected bin, in the form of a spider. To turn off the spider display press the Hide Spider button. 
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To exit this mode, you need to deactivate the Selected Bin Information. 
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7.3.6 Plot Statistics 

Plot Statistics - a dialogue that displays the statistics for the calculated Fold Map using the 

following graphs and diagrams: 

 

 

- Graph displaying the distribution of the Number of Bins with respect to the 

Fold 

 

- Graph displaying the distribution of the Number of Traces with respect to 

the Offset. 

 

- Graph displaying the distribution of the Number of Traces with respect to 

the Azimuth. 

 

 

 

 

 

The X-axis, depending on the graph, shows the Fold, Offset, Azimuth, and on the Y-axis the 

Number of Bins or the Number of Traces. 

 

- Radial diagram which shows the distribution of traces according to Azimuth and Offset. 
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In this radial diagram - each circle corresponds to a particular offset. The scale of offsets is marked on 

the axes X and Y. The radial lines represent the azimuth and each cell in the pie chart is colored 

according to the number of traces that fall in each particular range of offset and azimuth. 

 

- Radial diagram which shows the distribution of the Number of Bins according 
to Azimuth and Offset. 

 

 

In this diagram, the X axis represents the Offset and the Y axis – the Redundancy (i.e. each cell is 

colored according to the number of bins that have the same). 
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- Display Options - Display options for graphs and charts 

 

 

This button opens a dialog for optional display settings, where you can set the Increments for Fold, 

Offset, Azimuth, as well as change the display from line graphs (As Line Graph) to histograms 

(As Bar Graph). 
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7.4 Manipulation with Acquisition Geometry 
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7.4.1 Changing position of Inline/Crossline axes 

If, for some reason, the program does not correctly determine the Inline / Crossline coordinate system 

when loading the observation scheme from the SPS-file, it is possible to change the location of the axes, 

for example, as in the figure below. To do this, you need to activate the mode  –(Shots / 

Receivers: Moving with rotation), hold down the ctrl button and perform manipulation 

(move, rotate, change the length of one of the axes). 

Before After 

 

This function works only when the observation schemes are loaded from the SPS file; for schemes built 

in another way, the function is disabled.
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7.4.2 Changing coordinates of the Shot/Receiver 

To move the Shot/Receiver to the exact coordinates, you need to activate the mode  

- (Moving Shot and Receiver Lines) and then point to Shot / Receiver and click 

the left mouse button. 

  

Then in context menu you need to select the Shot/Receiver Coordinates. A dialog will appear 

with the current coordinates Shot / Receiver Map - coordinates of the map, and SPS - location in the 

Inline / Crossline observation scheme, Z - current depth of the Shot / Receiver. 

 

If you need to get the coordinates of another Shot / Receiver, you can repeat the procedure without 

closing the dialog. After changing one of the coordinates, you must press Set, then Shot/Receiver 

position will change its location or depth. After receiving the desired result you have to close the dialog. 
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7.4.3 Changing the depth of Shots/Receivers 

The button  - (Set Shots / Receivers Depth) opens a dialog, where you can set the 

depth for all Shots / Receivers. There are two ways to get the depth value: the first is to set the depth 

manually, the second one is relative to the selected surface from the list loaded into the project. 

 

After selecting the depth setting method, you need to determine what the depth of Shots or Receivers 

will be assigned to, or both, and activate the corresponding flags. After selecting the settings, click OK. 
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7.4.4 Placement of Shots/Receivers in Well 

 

To change the initial placement of receivers in a well or to place sources in a well, use the menu 

command Map/3D Survey Edit Modes/Moving Shot and Receiver Lines. Then, in 

the appeared dialog select a well (from the list of database wells which belong to the selected fields and 

include trajectory specification in the inclinometry table): 

 

Start from selection of a station type in the Point list: either Receiver or Source. 

Then use the list Action to select an operation: either Add or Remove. 



© Tesseral Technologies -User Documentation- 
222 

 

 

 

Then select a desired type of object in the list Type: 

 

 

The action Add supports the next objects: 

1) Interval requires entering the first depth along well in the field From, the last depth of 

the interval in the field To, and the depth increment from station to the next station in the 

field Step: 
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The result: 

2) Above requires entering the last depth along well in the field To, and the depth 

increment from station to the next station in the field Step: 

 

The result: 

 

3) Below requires entering the first depth along well in the field From, and the depth 

increment from station to the next station in the field Step: 
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The result: 

4) Depth along the well is entered in Z: 

 

The result: 

 

The action Remove supports the next objects: 

1) Interval requires entering the first depth along well in the field From, and the last 

depth of the interval in the field To: 

The result: 

 

2) Above requires entering the last depth along well in the field To: 
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The result: 

3) Below requires entering the first depth along well in the field From: 

 

The result: 

 

4) All means removal of all stations in the survey and does not need additional parameters. 

Using the listed operations and objects one can form the combined surveys not covered by the basic set 

of acquisition geometries (such as VSP with varying step, inter-well sounding, “inverse” VSP with 

sources in the wells, combinations of surface observations with VSP, etc.). 
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8 3D Ray-tracing 

To perform 3D Ray-tracing in Tesseral Pro it is necessary to have a 3D Velocity Model in SEG-Y 

format (see 13.4), reflecting surface in one of standard formats (see 14.1) and 3D survey layout (see 7). 

You can see explanations on how to create a job and run 3D Ray-tracing in Chapter 8. 

You can find some specifics of viewing modeling results in Chapter 15. 
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8.1 3D Ray Tracing Modeling 

 

To simulate 3D Ray tracing in Tesseral Pro, you need to create a 3D model consisting of a 3D velocity 

Model in Seg-Y format (see 13.4), a reflecting surface in one of the standard grid formats (see 14.1) and 

create a 3D survey layout (see 7). 
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8.1.1 Previewing 3D Velocity Model 

In order to preview the 3D velocity model as a SEG-Y file, the user can load it into the Seismic Frame 

(see Section 13) and then display it in 3D View Frame (see Section 15). 

To load the 3D SEG-Y file, choose one of the File > Load Seismic File or Seismic > 

Load Seismic File (New Frame) menu commands. Select the file in the standard File Open 

dialog box, and in the dialog 

 

choose „Model or Migrated gather‟. Your choice is remembered and next time you load the same file, 

you will not be asked. 

The file will open in the new Seismic Frame. 

 

More details on managing and displaying 3D Model files can be found in Section 73.4 

You can also display the same 3D Model file in 3D view. To do this, create a new 3D View Frame by 

the 3D View > View Data Cube (New Frame) menu command. In the Add Items dialog 

box, select the file you want to view: 
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NOTE: It is not necessary for 3D ray tracing procedure to have the 3D velocity file loaded 

into the interface. But this step is useful for previewing the file and making sure you choose 

the right file for the simulation. 

 

Then the 3D Velocity model is displayed in the 3D View: 

 

See Section 15 for details on 3D View options. 
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8.1.2 Loading the Reflecting Surface 

The reflecting surface can be in any of the standard grid formats (see 14.1). To load it, choose the File 

> Load Map File menu command. If a Map Frame is not created, it will be created and the file 

loaded. Alternatively, you can use the menu Map > Create Map (New Frame) and in the dialog 

box select “Load TXT or GRD-surface files”. 

When loading surface, you will be asked about creating isolines. This is only for display 

and is optional. After that, you will be presented with the Surface properties dialog: 

 

More details on the options in this dialog and on working with the Map Frame can be found in 

Section 14. After you click OK, the surface is loaded into the Map Frame 
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8.1.3 3D Ray Tracing simulation 

Before you start the simulation, you need to create the 3D survey layout (see Section 7). 

Here is an example of a reflection surface and a 3D survey layout. 

 

To start the 3D Ray Tracing simulation, choose the Run > 3D Ray Tracing Modeling… menu 

command. If you have not saved the project, you will be prompted to do so. After that, the 3D Ray 

Tracing dialog box opens: 
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You can change the following options: 

• Output Folder Specifies the folder where the input files and the computation results are 
stored. 

• Velocity Cubes Specifies the 3D velocity SEG-Y file used for the 3D Model (see 
8.1.1). The Shear Wave Velocity cube is specified in case of PS wave ray tracing, 
otherwise the Vs values are generated automatically according to Castagna’s equation 
(i.e. the mudrock line). 

• Horizon File. Specifies the reflection surface file (see 8.1.2) 

• Horizon File Type. Specifies the file type used for the reflection surface. See details in 
14.1 

• Sources to compute group. Specify the range of sources to compute. Input the range into 
the edit fields or click the button All to compute all sources, or Active to compute only 
the active selected source in the 3D survey layout (see 7) 
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NOTE: Do not set unnecessarily small values into the step boxes; doing so will 

significantly increase the computation time. 

• Region Cube group. Specify the 3D Model region for computation or use the button 
From Velocity File or From Surface to set the region based on the corresponding 
ranges in the files. 

Also in this group, specify the computation steps. The X step and Y step determine the spatial density 

of rays during the computation, while the Z step determines the internally used time step and 

influences the number of links each ray contains. 

 

• Illumination File Name specifies the name of the surface file where the illumination 
map will be saved after the computation. 

• Rays File Name specifies the name of the file (or group of files) where the rays from 
the sources reaching the receiver will be saved after the computation. The file name 
will be automatically amended with the source index, and one file will be created for 
each source in the 3D survey layout. 

• The user can also choose to take into account the Attenuation due to Ray 

divergence and select between 2 modes of computation Fast and Precise. For 

the Precise mode Snell’s Law of reflection and refraction will be taken into account 

and the rays will bend according to the elastic properties of Velocity Cube File. 

In the Fast Mode the incident and the reflected waves will remain perfectly straight. 

 

Click RUN, and the simulation will start. The usual Computation dialog is displayed. 
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8.1.4 Viewing the Illumination map 

After the computation finishes, the resulting illumination file is loaded into the Map Frame. (You are 

prompted to generate isolines, this is optional). 

 

You can load the illumination map at a later time using the File > Load Map file menu 

command. The file is located in the folder specified in the 3D Ray Tracing dialog (see 8.1.3). 

Now you can display the reflection surface filled with the illumination map in the 3D View Frame. To 

do this, choose the menu command 3D View > View Data Cube (New Frame). The Add 

items dialog box appears: 
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2 

1 

 

Cancel out of this dialog at this time (do not click OK). 

The empty 3D View Frame is created. Now choose 3D View > Add Map > From Project. 

The Add Surface From Project dialog appears: 

 

In the left list (All Layers) select the reflection surface and click „>‟. The Surface name will be moved 

to the next list, Layers to be added. 
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Click OK. In the Surface Properties dialog 

 

 

Check the “Filling by another surface” check box, and then click “…”. In the Filling by Surface dialog 

box select “From project” radio button, and then select the illumination map surface from the list below. 

Click OK in both dialogs and the surfaces are loaded into the 3D View Frame. 
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Please refer to Section 15 for instructions on how to adjust the 3D View display options (rotation, 

zooming, etc.) 
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8.1.5 Viewing the rays 

Choose the 3D View > Add/Remove Rays… menu command. In the Open File dialog select the 

file with the „.bin‟ extension, having the name specified in the Ray Tracing dialog (see 8.1.3). By 

default, this file is named “OutputRays.bin”. This file contains the catalog of all calculated rays during 

the simulation. 

The Add Rays dialog opens: 

 

 

On the left, you can choose how you want to select the rays: by sources, receivers, or reflection 

points. 
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Then select the rays you want to display in the 3D View. Depending on your choice in the left of the 

dialog, you can select rays by sources, receivers or reflection points. Drag your mouse with the left 

button pressed to select the sources, receivers or reflection points; if you want to exclude certain 

sources, receivers or reflection points from the selection, deselect them with the same procedure but 

using the right mouse button. 

When you click OK, the rays from the selected sources, to the selected receivers, or with the selected 

reflection points will be shown: 

Draw rectangle with 

mouse to select points 



© Tesseral Technologies -User Documentation- 242 
 

 

 

The project data tree allows to hide/restore visualization of the selected rays by the checkbox 

Rays in the tree folder 3D View. 

 

If you want to change the color palette, choose the 3D View → 3D View Frame 

Properties… menu command and in the General dialog click the Rays Palette button. 
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Use the list set by of the Rays Palette group to select an attribute to be presented by the ray 

colors. Each of the attributes luminance, offset, angle of incidence is scaled from min to 

max value among the selected rays and projected to the palette. (A ray has only one color according to 

the relative value of the selected attribute.) The attribute reflection point is presented 

differently: the ray parts from source to reflection and the ray parts from reflection to receiver are 

presented by two different colors (the extreme colors of the selected palette). 

The next dialog Palette (called by the button ... in the dialog Rays Palette) is used to change 

colors and (optionally) to limit the correspondent value interval.  
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8.2 Source grouping for 3D modelling 

 

The user can also implement source grouping (i.e. simultaneous shooting from multiple sources) for any 

3D modelling method. In order to implement it, the user will first need to load a surface (see Section 14 

) and build a 3D observation system (see Section 7). Afterwards select Run>Run 3D Modelling 

and follow the instructions in Section 5. After specifying all modelling settings click Finish and Run 
modelling. 
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Click Terminate, as soon as at least 1% of the job has been completed. Once the job has been 

terminated, locate the survey3d.txt file in recently created job folder and open it in Microsoft Excel. 

The survey3d.txt contains the XYZ coordinates of every source-receiver pair of the designed 3D survey 

(i.e. the coordinates of every trace) and the user will have to fill the entire Inline and Crossline 

columns with zeros. Afterwards, an identical Source Number needs to be assigned for the sources 

that need to be grouped. For example if out of 100 sources in the 3D survey, the user wants to group just 

5, then a Source Number of 1 (in actuality it can be any number) needs to be assigned to all traces 

pertaining to those 5 sources. In other words, every row that carries the SrcX; SrcY; SrcZ 

coordinates of the respective 5 sources need to be filled with the same number. The remaining 95 sources 

(that are of no interest to us), have to be assigned a different number (even though we do not care about 

them), for example 2, so that the whole SrcNum column is filled. The same methodology applies if 3 or 

more sets of sources, have to be grouped per modelling job. 
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Once the SrcNum column has all been filled, save and overwrite the existing survey3d.txt file with the 

updated one (make sure to also save it in TXT format). Afterwards, go back your map frame which 

contains the previously built 3D survey and click Run>Run 3D Modelling>Yes. 
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Once the computation is complete, the total number of seismograms produced will equal the total 

number of shot groupings. For the example above, you will end up with a total of 2 shot gathers, (one for 

the 5 grouped sources and another one for the remaining 95 grouped sources). 
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8.3 Double couple sources in 3D modelling 

It is now possible to simulate arbitrary oriented double couple sources, expressed by stress matrices (or 

moment tensors) in survey3d.txt. 

This functionality can be implemented for any 3D modelling method (except for the 3D acoustic). 

 

In order to implement it, the user will first need to load a surface (see Section 14 ) and build a 3D 

observation system (see Section 7). Afterwards click Run>Run 3D Modelling and follow the 

instruction in Section 5. After specifying all modelling settings click Finish and Run modelling. 
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Click Terminate, as soon as at least 1% of the job has been completed. 

 

Once the job has been terminated, locate the survey3d.txt file from the recently created job folder and 

open it in Microsoft Excel. The survey3d.txt contains the XYZ coordinates of every source-receiver pair 

of the designed 3D survey (i.e. the coordinates of every trace) and the user will have to fill the entire 

Inline , Crossline columns with zeros and the SrcNum with -1, which simply disables it 

during computation! 
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Introduce the moment tensor for KTau11, KTau22, KTau33, KTau12, KTau13, KTau23, for all 

relevant sources. 

 

Please make sure to assign identical moment tensors to all traces, pertaining to a unique source. In other 

words, the moment tensor needs to remain constant for every source-receiver pair in the table. 

 

Once the KTau columns have been filled, save and overwrite the existing survey3d.txt 

file with the updated one (make sure to also save it in TXT format). 

 

Now open the runtask.ini file, located in the same modelling folder as survey3d.txt 

and change 

[Source] 

Type=0; Omnidirectional 

To 

[Source] 

Type=10; Double Couple 

 

Afterwards, save the runtask.ini file (File>Save) in the exact same location. 

 

Then, go back your map frame which contains the previously build 3D survey and click 

Run>Run 3D Modelling>Yes. 
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8.3.1 Using the same moment tensor for all sources 

 

If the user would like to use the same moment tensor for all sources in the 3D survey, then it is sufficient 

to ONLY modify the runtask.ini file as follows (leaving the survey3d.txt intact): 

Remove 

[Source] 

Type=0; Omnidirectional 

And replace it with: 

[Source]  

Type=8;  

K11=…;  

K22=…;  

K33=…;  

K12=…;  

K13=…;  

K23=…; 

 

Once the moment tensor has been specified, save the runtask.ini, go back to your map frame which 

contains the previously build 3D survey and click Run>Run 3D Modelling>Yes. 
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8.3.2 Using 2D douple couple sources for 3D modeling 

 

It is also possible to have all double couple source propagate in 2D only (i.e. in XZ, YZ or XY 

direction). For that you will have to modify the runtask.ini file as follows: 

 

Remove: 

[Source] 

Type=0; Omnidirectional 

 

And replace it with: 

[Source]  

Type=8; 

DoubleCoupleAxis=XZ 

 

Or 

Type=8  

DoubleCoupleAxis=XY 

 

Or 

Type=8  

DoubleCoupleAxis=YZ 

 

Afterwards, save the runtask.ini, go back your map frame which contains the previously build 3D 

survey and click Run>Run 3D Modelling>Yes. 
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9 3D Full-Wave Modeling 

To run 3D Acoustic and Elastic full-wave modeling you‟ll need to: 

1. Build a 3D model as a seismic cube SEG-Y file (.sgy) 

2. Setup 3D survey geometry 

3. Setup modeling parameters 
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9.1 3D model as a seismic cube 

Using command Map > Create Map create new frame Map with the surfaces form DB or GRD-

files 

 

 

Use command Map > Section mode to draw the section (profile) line on Map frame. The section 

with the layers should appear in top title. 
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If you can’t see the section, please expand the heading area by the mouse. 

The highlighted by red color layer is the currently active one (it is shown in the frame). Right-click on 

top title and select the command «Select Layer» to choose another active layer. Then right-click on 

button «… 3D model». 
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This command can also be accessed by menu Map > Active Map > 3D model properties. 

In the dialog 3D model properties option Map type: select top to assign velocity values 

beneath the surface, or bottom – above the surface. 
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Then right-click on section and use command Select Layer “…” and “…” 3D 

model Properties to specify velocities in all layers. 
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For adjusting palette of the section’s velocities (not map) use the button «Edit Bottom Title» in 

the Map > Map Frame Properties dialog, then «Show Section Palette». 

 

 

To create 3D SGY file use command Run > Map Frame > Create 3D Seg-Y 

and adjust grid parameters: 

 

 

 



© Tesseral Technologies -User Documentation- 260 
 

  

If there is no velocities data in the model, the program will use the default values. 
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Result: 

 

When you have 3D model as seismic SGY file with the cube of velocities, open it: 
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Then, right click on the 
seismic cube and select 
“Edit Frame Properties…” 

Open a seismic 

cube file (.sgy) 
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It is handful to change seismic view mode to “Contour” in the Seismic Frame‟s properties 
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9.2 Design 3D acquisition geometry 

Next step is creating of a Map Frame to build 3D acquisition geometry 

 

 

Use the Acquisition Geometry Wizard to design the survey. These steps are skipped here. For 

detailed description of 3D survey design please see section 7 of this manual. 

 

It is important, however, to specify inline and crossline lengths of the observation zone. 
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Click on “Edit Frame Properties” 

After the acquisition geometry is built now let’s place the 3D seismic cube into the map and combine it 

together. Click on Edit Frame Properties button as shown below: 

 

Enable “Draw Seismic frames plan” to combine the model with acquisition geometry on the map: 
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Click on “Zoom Out” several times so the seismic cube’s area became visible on the map. 

Switch to “Move and Rotate” mode and drag the acquisition geometry into the model area. 
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Now, click on “Unzoom” and “Arrange Frames” to see the model with the acquisition 

survey. 

2. Click on “Move and 
Rotate” button 

3. Drag the acquisition 
geometry into 3d seismic 
cube 

1. Click on “Zoom Out” button 
several times to see both the 
seismic cube and the 
acquisition geometry 
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You can continue to design the survey by moving and rotating inline and crossline positions on the map. 

2D profile drawn on the surface of the model seismic cube will be visible also on the map. 

Click on “Unzoom” and then 
“Arrange Frames” buttons to see 
both frames together 
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Use “Move and Rotate” 
mode to setup the 3D 
survey 

2D profile specified on 
the cube also will be 

shown on the map 
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Select 
“Run 3D Modeling…” to run 
on PC or 
“CLUSTER: 3D Modeling…” to run on a 
Linux cluster 

9.3 Setup modeling procedure and boundaries 

 

After the seismic cube velocity model is loaded and the survey had been set up use either “Run > Run 

3D Modeling …” to setup and run the full-wave modeling or “Run > CLUSTER: 3D 

Modeling …” to create modeling job for Linux cluster. 

 

To run acoustic or elastic simulation a P-velocity cube must be provided. Density can be calculated 

automatically based on built-in correlation tables. The elastic simulation of the S- velocity cube may also 

be provided or calculated automatically. 

Simulation of the special boundaries is automatically configured using P-velocity cube. 

These boundaries could be adjusted manually if needed. 
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Specify signal form, frequency and direction in the dialog window Wavelet:

Specify a 
velocity 
cube 

Select Shot 
Points to 
simulate 

Model boundary will be 
determined by the velocity 
cube, but also it can be 
specified manually (to 

decrease depth for 
example) 

You can specify a folder 
in which the task will be 
saved. 
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Memory estimation (per 
node) is available to 
evaluate resources 
required to run the 

simulation 

Margin also affects 
required memory 

     Signal frequency could be changed to see  
how it affects the required memory 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can use „auto‟ buttons to  
set the special and temporal  
simulation steps 
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9.3.1 Run 3D simulation on Windows PC 

The 3D modeling process is monitored in a dialog box 3D Modeling in progress.  

 

After the calculation is completed gathers of the X, Y, Z particle velocity and the pressure will be 

generated. 
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3D Model 
Cube 

Acquisition 
geometry 

Modeling task 
settings 

9.3.2 Run 3D simulation on Linux Cluster 

The task contains: 

1. The model seismic velocity cube 

2. Acquisition geometry (survey32.txt) 

3. Task settings (runtask.ini) 

You can put this folder to a Linux cluster to run the faster parallel computation. Also the cluster engine 

will use all available memory to handle very large computation jobs. 
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10 Processing of seismic gather 

Some of the commands in the Run menu are for processing generated synthetic gathers. 

IMPORTANT NOTE! 

All processing history and user defined settings are saved in the computation.log 
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Limitations for values 

of parameters (in case 

thin-layering is formed 

from logging curves) 

Create files with grids 

of anisotropy 

Grid step in the 

output file 

Create a standard name 

for the output file 

10.1 General Purpose Procedures 

In the Model Frame, the model consists of polygons (model in vector format). In some other programs 

such as ray tracing, migration and other processing procedures in Tesseral Pro, the input model is 

assumed to be in form of grid. To export Model Frame to a grid file, use the command Run/General 

Purpose Procedures/Export Model to Seismic Format (SEG-Y, TGR). 

 

 

The output file may be in SEG-Y format. For isotropic model, 3 output files are created for the 

compressional velocity, shear velocity (<name of the output file>–PQR_R.SGY) and density (<name 

of the output file>–PQR_Q.SGY) components respectively. 

The output grid files may be in TGR format (i.e. the internal Tesseral format). Separate output files are 

created for all 3 components of the depth model (compressional, shear velocity and density), as well as 

anisotropy parameters if the checkbox Export Medium Anisotropic Properties was 

checked. 
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10.1.1 Copy Gather to SEG-Y Format 

The command Run > General Purpose Procedures > Copy Seismogram to SEG-Y 

Format is used to transform files from the internal TGR or SDC PC formats into the standard SEG-Y 

format. 

 

The TGR format does not contain the geographical coordinates of the traces and the altitudes of the 

receivers. Check the box Write coordinate from model to obtain this information from the 

Model Frame and then write it into the trace header of the output SEG-Y file. 
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10.1.2 Split Seismogram by Shotgathers 

The command Run > General Purpose Procedures > Split Seismogram by 

Shotgathers is for splitting merged synthetic gathers into separate files in terms of the number of 

shot points (one file for each shot gather). 
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10.1.3 Split SEG-Y File into Pieces of Limited Size 

The command Run > General Purpose Procedures > Split SEG-Y File by 

Limited Size Pieces is to split the SEG-Y files into separate files, each file not exceeding the 

size specified in the Output file Size (MB) parameter. 
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Delete file(s) from the group 

Add file(s) to the group 

10.1.4 Merge Seismograms 

The command Run > General Purpose Procedures > Merge Seismograms is for 

merging the selected files into one (the output file will have all the traces of the input files in the same 

order as they were entered in the list). If the coordinates of the selected files match each other exactly, 

the procedure will work differently (it will stack the traces and the output file will have the same number 

of traces as the input one). This procedure can be used to sum the different cubes after migration. 
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The condition for 

selecting traces 

Only traces inside this 

rectangle will be in the 

output file. 

10.1.5 Cut Out Cube/Section traces (by coordinates bounded by a rectangle) 

The command Run > General Purpose Procedures > Cut Out Cube/Section is 

mainly used for preparing field gathers for duplex wave migration or for extracting part of the traces 

falling into a user-defined rectangle. It can speed up DWM processing for a huge dataset. 
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NOTE: Input File is a depth velocity model or gathers of a single shot line (grid in 

SEG-Y or TGR format). To obtain depth velocity model in SEG-Y or TGR format, the 

command Model > Export to Seismic Format (SEG-Y, TGR) is used. 

10.1.6 3D Replication (create 3D grid by reproducing 2D cross-section) 

The command Run > General Purpose Procedures > 3D Replication 

is used for: 

• Creating the 3D acquisition data (multiple shot lines) from a single shot line (with 
multiple receiver lines) generated by 2.5D modeling to create a true 3D dataset from 2D 
acquisition. 

• Creating a 3D velocity model from a 2D velocity model. 

 

 

 

The lines in the 

output 3D file 

Initial coordinates and 

azimuth of the profile 
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Coordinates of the 

profile‟s start point 

Output 3D file Input 2D file 
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10.1.7 SEG-Y File Resampling 

Choose the command Run > General Purpose Procedures > SEG-Y File Resampling. 
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Is Minus 

10.1.8 Difference of 2 Seismograms 

 

The command Run > General Purpose Procedures > Difference of 2 

Seismograms is used to calculate the difference between 2 synthetic gathers created by similar 

models. It may be used, for example, to evaluate how the perturbations of the model‟s parameters 

influences the output gather. It can also be used to obtain the differences between migrated cubes or 

sections. 
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10.1.9 Import/Export Traces Coordinates 

The coordinates of sources and receivers in the headers of the traces can be exported into a text file 

using Run > Seismic Frame > Export Traces Coordinates. 

The coordinates of sources and receivers in the text file can be imported by using Run > Seismic 

Frame > Import Traces Coordinates. 
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10.1.10 Write Visible Coordinates to Trace Headers 

To write the modified coordinates of traces to the headers of seismic files, the command Run > 

Seismic Frame > Write Visible Coordinates to Trace Headers is used. 

In Tesseral Pro, the seismic files can be displayed with transformed/rotated coordinates using the 

following commands: 

• Seismic > Rotate to Align X Axis along Section Profile 

• Run > General Purpose Procedures > Import Traces Coordinates (load coordinates of 
traces from text files) 

• View > Raw Trace View Window (in this dialogue box, the trace coordinates 

can be assigned from non-conventional cells of the trace headers). 

Please see Section 13 for more details. 

After using the ways mentioned above to change the trace coordinates, the headers of the seismic files 

are not changed and the information on trace coordinates is written into an additional file <gather 

name>.inf for further use in the Tesseral Pro. 
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10.1.11 Cut Profile from 3D seismogram 

This function is used for the extraction of shot gather traces along a straight line or a polyline from a 3D 

seismogram. 

To access this function please load the 3D seismograms (File>Load Seismic file), followed by 

Run>General Purpose Procedures>Cut Profile from 3D seismogram. 
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If you would like to extract the coordinates by line, then either specify the X from , X to, Y from, Y 

to and Step or draw the profile in the seismic frame Seismic>Edit Mode>Draw Profile 

before accessing the Cut Profile from 3D seismogram 



© Tesseral Technologies -User Documentation- 291 
 

function (for additional information on profiles please see 13.5). 

 

The traces can be also extracted according to the target survey geometry- Survey from SPS file 

(see Section 3.1.6), or from a text file of traces coordinates - Profile from Seismic File 

coordinates( see section 10.1.9). 
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10.1.12 Export Profile to 2D Seismic File 

To export a 2D profile from seismic cube, first of all load the 3D cube (File>Load Seismic 

file), draw the profile in the seismic frame (see 13.5) followed Run > Seismic Frame > 

Export Map to 2D Seismic file. 
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10.1.13 Band-pass filter 

 

The user can also multiply any signal spectrum in the frequency domain (equivalent to convolution in 

time domain) with a filter spectrum, by specifying the F1, F2, F3, F4 corner frequencies of the 

trapezoidal frequency band-pass filter, as well as the Length of the filter in time domain. 
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10.2 Velocity model 

These procedures process the velocity model. 
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10.2.1 Average Velocities from Model 

This is done by the command Run > Velocity Model > Average Velocities from Model 

 

 

The Input file is the layered velocity model, which may be obtained from the Model Frame by the 

command Model > Export to Seismic Format (SEG-Y, TGR). 
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Velocity Model 

NOTE: Velocity seismic file is the layered velocity model, which may have 

been obtained from the Model Frame by the command Model > Export to 

Seismic Format (SEG-Y, TGR) (please see Section 12.3.1 for details). 

NOTE: Velocity seismic file is the file of layered model grid in time domain. It 

may have been created from the depth model by using the transformation Depth to 

Time Transformation. It means that, in the procedure Depth to Time 

Transformation, if the Input file and Velocity seismic file represent 

the velocity model, the Output file will be the same model but in time domain. 

10.2.2 Depth-to-Time/Time-to-Depth co n v e rs io n  

The command Run > Velocity Model > Depth to time 

transformation transforms migrated sections (cubes) from depth domain to time domain. 

 

 

The command Run > Velocity Model > Time to Depth 

Transformation transforms the velocity model from time domain to the depth domain. 
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10.2.3 3D Interpolation 

With the help of Run>Velocity Model> Interpolation, the user can resample the grid step 

for any 3D SGY cube by interpolating between adjacent grids. 

To implement this this function, first of all you will need to load the 3D SGY: 

File>Load Seismic File followed by Run>Velocity Model>Interpolation. 

 

Reassign a new grid Step along X, Y, Z, as well as their Min and Max in Turn OFF and click OK. 

By default, the X, Y, Z coordinates for the whole cube are elected. The Output model file will 

have the newly reassigned grid step, as you can see in its trace headers. 
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10.3 Pre-Processing 

These procedures are for preliminary processing. 
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10.3.1 Gathering 

The procedure is intended for extracting gathers by the criteria of common shot point, common midpoint 

or common receiver point or obtaining gathers with common offsets. The procedure applies for both 2D 

and 3D gathers. Use the command Run > Pre-Processing > Gathering (GATHER). 
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10.4 Stack (Time domain) 

The procedure is for time-domain stacking. 
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10.4.1 Kinematic corrections (Normal Moveout) 

The Normal Moveout procedure applies kinematic corrections to gathers of various type, e.g., 

common midpoint gathers, common receiver gathers (Gathering program) and common shot gathers. 

The result is the time domain gathers after NMO correction. Use the command Run > Stack 

(Time domain) > Normal Moveout (NMO). 

 

 

 

The average velocity model (parameter Velocity file) may be created from layered depth velocity 

model by the command Run > Velocity Model > Average Velocities from Model. 

To obtain a time slice of the subsurface image after Normal Moveout correction, use the Stacking 

procedure. 
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10.4.2 Stacking 

The procedure Stacking is meant for stacking traces with a common coordinate after the Normal 

Moveout. 

Before applying the Staking procedure, the kinematic correction needs to be applied using the 

Normal Moveout procedure. The command Run > Stack (Time domain)> Stacking 
(STACK) is used 

 

Accuracy is the bin size used for stacking common depth point traces. 
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10.4.3 CMP Stack 

This is used for direct creation of time section by common midpoints (midpoint stacks) without applying 

the procedures Normal Moveout and Stacking. The CMP Stack procedure uses the medium‟s 

average velocity (parameter Velocity file). The command Run > Stack (Time domain) 

> CMP Stack (SUM) is used. 

 

The average velocity model may be created from layered depth velocity model by the command Run > 

Velocity Model > Average Velocities from Model. The Gradient parameter is for 

NMO stretch mute. 
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10.4.4 Dip Moveout Stack 

The user can also implement a Dip Moveout Stack (which implements NMO correction first, 

followed by DMO correction and stacking, i.e. 3 in 1). 

It is well known that conventional normal moveout correction (NMO) introduces mispositioning of data, 

and hence mis-stacking when a dip is present. Dip Moveout correction (DMO) is a technique that 

converts non-zero-offset seismic data after NMO to true zero-offset locations and reflection times, 

irrespective of dip. The combination of NMO and DMO followed by post-stack time migration is 

equivalent to, but can be implemented much more efficiently than full time migration before stack 

(JAKUBOWICZ, H. (1990), A SIMPLE EFFICIENT METHOD OF DIP-MOVEOUT 

CORRECTION1. Geophysical Prospecting, 38: 221–245. doi:10.1111/j.1365-2478.1990.tb01843.x) 

The DMO Stack procedure uses the medium’s average velocity (parameter Velocity file). Step 

describes the sampling (i.e. binning) for stacking across X and Y-axes (in case of 3D seismic). 

 

http://onlinelibrary.wiley.com/doi/10.1111/j.1365-2478.1990.tb01843.x/full#fn1
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10.5     2D/3D Migration 

Procedures for the migration of time-domain 2D gathers 
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10.5.1 Time Pre-Stack Kirchhoff Migration 

The procedure is for creating migration image directly from gathers without creating CMP time section 

or post-stack migration. The command Run > 2D Migration (Time domain) > Time 

Pre-Stack Kirchhoff Migration (PSM) is used. 

 

This migration needs the time-domain average velocity model as input, which may be obtained by using 

the commands Model > Export to Seismic Format (SEG-Y, TGR) and then Run > 

Velocity Model > Average Velocities from Model. Users can specify velocity 

measurement units in the model (m/s or ft/s). 

If the migration aperture is not specified, the program may use the default values. To 

specify the apertures explicitly, the buttons in the Apertures group are used: Add , Delete, 

Delete All, Load (from a file), and Save (to a file). 

The migrated section is specified by the parameter Profile Coordinates (whose direction is 

specified by the Adjust button) and Output Section (size and step along the profile). These are 

mandatory parameters to be input by the user. 

The signal stretching is limited by Gradient, whose default value is 0.5. If the gradient is too small, 

the images will be too “spread”; if the gradient is too big, some objects may disappear. 

The result may be normalized (in this case, the noise and the low signals will be amplified). Usually 

normalization is not applied (the Just sum option). 

The migrated time section is saved to the Output file. To transform it from time scale to the depth 

domain, use the command Run > Velocity Model > Time to Depth 

Transformation. 
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10.5.2 Depth Pre-Stack Kirchhoff Migration 

The command Run > 2D Migration (Depth domain) > Depth Pre- Stack Kirchhoff Migration (DPSKM) 

performs the Depth Pre-Stack Kirchhoff Migration. The result is in depth domain. To transform it to 

time domain, use the command Run > Velocity Model > Depth to time Transformation. 

 

For migration, the layered velocity model has to be in depth domain, which may be obtained by using 

the menu command Model > Export to Seismic Format (SEG- Y, TGR). The velocity 

measurement units in the model can be specified (m/s or ft/s). 

If the migration aperture is not specified, the program uses the default values. To specify 

the apertures explicitly, the buttons in the Apertures group are used: Add, Delete, Delete All, 

Load (from a file), and Save (to a file), each of which invoke a simple dialogue box. 

The migrated section is based on the 2D data. The size of the processing area and the corresponding step 

along the profile (in X direction) is assigned in Coordinates along X- axis. 

The signal stretching is limited by the Gradient, whose default value is 0.5. If the gradient is too 

small, the images will be too “spread”; if the gradient is too big, some intervals may disappear. 
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This program uses the eikonal solver to compute time fields. Discretization of the computation grid is 

specified by STEP X/Z in the Time estimation settings group. The additional frame 

(Margin) gives the option of removing the influence of the edge effects. It is recommended to set it to 

5 – 10 grid steps. 

Min time shift from direct wave is used for supressing shot gathers by a particular time 

interval after the direct wave arrival ( if necessary!), in order eliminate unecessary migration noise. 

Also, by specifying Vp/Vs of the medium directly below the observation system, the user esentially 

mutes the direct compressional and shear wave on the shotgaters, and therefore eliminates unnecessary 

migration noise asociated with these waves. 
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10.5.3      2D Duplex Wave Migration 

Duplex Wave Migration (DWM) is a newly developed technology capable of imaging events with 

dips 60 ˚ to 90 ˚. Duplex waves are strong enough to be used for geological purposes. 

Duplex waves get reflected twice: from a sub-horizontal surface followed by reflection from the sub-

vertical surface or vice versa. 2D DWM supports only PPP type reflections. 

 

Before running 2D DWM, the user first of all needs to import the 2D synthetic seismograms in SGY 

format, as well as the 2D model which generated these seismograms. This is done by clicking on File> 

Open in the upper menu. 

Once the model and its respective seismograms have been loaded the user can then 

proceed to the DWM settings tab by clicking Run>2D Migration (Depth domain)>Duplex 

Wave Migration. 
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In the Duplex Wave Migration tab, the user will need to double check that the Input file is 

the correct SGY file, containing the appropriate synthetic seismograms and also specify the name as well 

as the location of the Output File (i.e. the migrated seismic section). 

The DWM algorithm is designed to image the DW energy that will arrive at a time greater than that of 

the primary base boundary. A beam tube construction eliminates the migration noise that would result 

from the base boundary primary reflections in the migration summation. For this reason in the Model 

P file, the user needs to upload the SGY P wave velocity model (in depth domain), that contains just 

the horizontal and the sub-horizontal geological structures, without the vertical heterogeneities, that will 

ultimately be imaged by this method. The depth model can easily be generated by going 

Model>Export to Seismic Format (SGY) in the upper menu. 

The user will also need to select the Reflecting boundary (polygon) or base boundary for 

duplex waves reflection. For exactly this reason the imported 2D model MUST at the very least have the 

base boundary as a polygon (see section 3.2). The base boundary should of course be below the sub-

vertical heterogeneities that need to be imaged by DWM. 

The migrated section is specified by the parameters Start X and Stop X as well as Start Y and 

Stop Y in the Profile Coordinates tab (whose direction can also be specified by the 

Adjust button). The parameter Step is recommended to be identical to the grid step that was used 

for forward modeling. 
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This program uses the eikonal solver to compute time fields. Discretization of the computation grid 

along the X and Z axis is specified by Step in the Time estimation settings group. 

In the Aperture tab the migration aperture for duplex waves is assigned. The user can specify a left 

aperture by specifying the distance to the left of the source receiver group or a 

right aperture to the to the right of the source receiver group. Also, a symmetric 

aperture can be assigned by specifying both. The left aperture is to the left of the leftmost 

source/receiver in the observation system, while the right aperture is to the right of the rightmost 

source/receiver. 

The signal stretching is limited by Gradient, whose default value is 0. If the gradient is too small, the 

images will be too “spread”; if the gradient is too big, some objects may disappear. There are two 

possible orders of reflections- HV and VH (i.e. reflection from the horizontal boundary followed by the 

reflection from the sub vertical boundary (HV) and vice versa (VH). 

For offset restrictions use min (Xr-Xs) and max(Xr-Xs) . Only the specified traces will be 

processed by DWM, the rest will be omitted. Please note that the specified values can be negative for 

traces to the left of the source and positive for traces to the right of the source. 

The Threshold is used for suppressing the shot gathers by a particular time interval after the 

compressional direct wave arrival (if necessary!), in order eliminate unnecessary migration noise. 
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10.5.4    2D Converted Duplex Wave Migration (CDWM) 

Converted Duplex Wave Migration can be applied to PPS, PSS and PSP type duplex wave, as you can 

see in the CDWM window. And depending on the type of converted duplex waves, you may be required 

to use the X component (i.e. horizontal particle velocity) of the synthetic seismograms and also load the 

S Model File. 

 

The user also the option of specifying internal apertures (i.e. between source and receiver). 

This option should be used for the imaging of transmitted converted waves. 
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10.5.5    2D Duplex Wave Migration from Scattered Waves 

Application of DWM for scattered waves is most suitable for targets below the last strong reflecting 

horizon, such as faults, salt domes and other steep structure flanks. 

 

Unlike for DWM for PPP and converted waves, no base boundary is specified for this method. Instead, 

the Depth interval or the base boundary depth step for scattered duplex waves relative to the 

bottom off the model is specified. The automatically generated base boundaries are perfectly horizontal 

and they are computed for the entire model depth. 
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10.5.6 Depth 2D VSP Migration 

To run 2D depth VSP migration choose Run > VSP procedures (Depth domain) > 2D 

Depth Kirchhoff VSP Migration (PSDM) from the menu. The next dialog will appear. 

 

The dialog automatically picks up a shotgather for migration from the current Seismic frame. (If the 

shotgather is not selected or does not fit, select another one using the button ...). The output file will 

contain the migrated section. Its name is also automatically generated if the name of the input shotgather 

file is selected by adding the suffix “+ PSDM” to its name. If a file with the same name already exists, 

an additional version number is added (a digit from 0 to 9). 

Min time shift from direct wave is used in order not to exclude the trace fragment of T0 

times from t-s to t+s, where t is the first arrival time of the wave incoming from the source to the 

receiver, and s is the value of this parameter in seconds. (The value of t is automatically calculated for 

each trace according to the velocity model during the migration process.) 
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The checkboxes Waves reflected from horizontal boundary and Waves reflected 

from vertical boundary determine which borders to build in migration: (horizontal, or 

vertical); in our case, the borders are only horizontal, so select the top flag. 

The Start, Stop, Step of the migrated section grid in depth (Output Section) are automatically 

determined from the velocity model (Model frame). 

The spatial Step of the section grid (both in length and depth) in the Time estimation 

settings section may be different from the corresponding output section sampling (Step from the 

Output Section). The former is used internally for calculation of wave propagation times by 

eikonal algorithm. Its default value is estimated by a heuristic rule. A smaller step provides greater 

accuracy of the calculated times for the cost of quadratic deceleration. (I.e., the deceleration coefficient 

is of the power of 2 relative to the scale factor of the change in step). The Margin next to the Step is 

needed to weaken the influence of the edges of the model. 

Each sample of the input seismogram trace is “smashed” within a cone (a triangle in 2D) which is 

defined by the migration apertures. For each trace, the triangle is plotted from the midpoint between the 

x-coordinate of the source (xs) and the x-coordinate of the receiver (xr). 

 

The migration apertures can both vary along the recording time axis in the vertical direction T0 and 

depending on the position of the source. The default aperture values are selected so that the angle at the 

apex of the alpha cone is about 15 degrees. The ellipse arc shows at which points of the output section 

the trace value of the input seismogram will be summed over time t=ts+tr (= 1.715 in the next figures), 

where ts is the first arrival time of the down going wave from the source to media cell, and tr is the first 

arrival time of the upcoming wave from the media cell to the receiver. 



© Tesseral Technologies -User Documentation- 318 
 

 

The migration apertures can be different for different shotpoints. If there is just one aperture X-

coordinate, the aperture is used for all traces (and so its X is ignored). 

Having completed entering the migration parameters, click OK to start the migration calculation and get 

the result. 
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10.5.7 Depth 3D VSP Migration 

To run 3D depth VSP migration choose Run > VSP procedures (Depth domain) > 3D 

Depth Kirchhoff VSP Migration (3D PSDM) from the menu. 

Please note that only migration of P waves reflected from horizontal boundaries has been implemented 

for this method. 

 

Input file – 3D seismogram file. If the file type is TGR (as opposed to SGY) it is necessary to 

specify the Component of the data file that is to be processed. 

Next you must load the depth Model P file and specify the size of the output migrated cube. 

The output (imaging) area is rectangular. And there are two ways to define this rectangle: 

– In general case the output rectangle is defined manually by coordinates of 3 sequential 
corner points: Xx0, Yx0, X00, Y00, X0y, and Y0y in the Rotated Axes 

group. Approximate values may be used. The program adjusts the coordinates to 
form a true rectangle. 
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– If the output rectangle boundaries are parallel to coordinate axes it can be 
alternatively defined by the parameters: StartX, StopX, StartY, and StopY. 

The program supports output of vertical sections, so combinations like 
StartX=StopX and StartY=StopY are enabled. 

StartZ, StopZ is depth interval of the output array. StopZ must be below (bigger) then boundary 

depths of the model file. 

StepX, StepY, StepZ are the grid steps for the output array. 

To specify the circular aperture explicitly enter directly the T(s) and Radius(m) in the 

Apertures group. If the migration aperture is not specified, the program uses default values. 

 

Min. time shift from direct wave(s) is used for muting VSP gathers by a particular 

time interval in order to eliminate the migration noise associated with the direct wave arrival. 

The rest of the parameters in Depth VSP Migration window are exactly the same as for 2D 

Time/Depth Pre-Stack Kirchoff Migration (Please see section 10.5). 
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10.6   Post-Processing 

Procedures for post-processing of seismic data: 
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10.6.1 Trace-wise Procedures 

 

Check a box to apply the function to all the traces. 

• Zero Balancing for balancing the traces to zero average value. 

• Linear Gain is for increasing the amplitude of the top (top gain) or bottom 

(bottom gain) parts of the traces. 

• Normalization is to normalize a trace using one of selected criteria. 

• Auto Gain is to smooth the trace automatically. The parameters of such smoothing may 

be: window length is the time (or depth, metrical) interval for which the smoothing is 

carried out, noise is a threshold (noise threshold in percent of the maximal amplitude) 

and outside this threshold smoothing is suppressed. 

• Add White Noise (in percent of the maximal amplitude) is to add white noise to the 

traces. 

• Random shift is to add a random shift to the traces. 

• Smoothing is to cut out the high frequency noises, if they are in the image. 

• Shift is to shift the whole trace up or down along the time direction. 

• Final Scaling (in percent of the maximal amplitude) is to change the absolute value 

of the amplitudes. 
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10.6.2 Zeroing of the seismic cube above surface 

With the help of this function the user can mute any given 3D seismic cube above the specified horizon. 

To implement this function first of all load the SGY cube File>Load seismic file… 

 

…followed by Run>Post processing>Zero Seismic Cube above a surface. 

 

Make sure the correct cube has been loaded in the Seismic cube dialogue, then load the Surface 

map (i.e. the horizon) and specify the Layer height, which is the distance above the horizon of the 

specified Seismic cube that should be preserved. 
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800m 
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10.6.3 Zeroing of the seismic cube under surface 

 

With this function the user can mute any given 3D seismic cube below the specified horizon. To 

implement this function first of all load the SGY cube File>Load seismic file… 

 

 

…followed by Run>Post processing>Zero Seismic Cube under a surface. 

 

 

 

Make sure the correct cube has been loaded in the Seismic cube dialogue, then load the Surface 

map (i.e. the horizon) and specify the Layer height, which is the distance 
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above the horizon of the specified Seismic cube that should be eliminated. 

 

300m 
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11 Working with Frames 

In this section, the general guidelines for manipulating different Frames are presented. 

Tesseral Pro supports 4 types of Frames – model, surface, gather and 3D-view. The parameters for a 

Frames' display can be customized in the dialogue box and with the help of the options in the 

corresponding menu. Frames can be deleted, moved and duplicated. Operations with one or more 

Frames are supported as well. A Frame can be printed or exported to an exact vector (raster-type) picture 

(WYSIWYG technology). There are the two main modes to display Frames: Document view and 

Tablet view. More information can be found below. 
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3DView Frame Seismic Frame 

Map Frame Model Frame 

11.1 Frame types 

The Tesseral Pro program supports 4 types of Frames: 

 

• Model Frame (Model) is the Frame in depth. Model is always created in depth. The 

velocity model is formed by polygons based on the well logging and/or seismic data. 
The polygons are created by the user manually or automatically from the map of 
stratigraphic horizons (see Section 14.2.7). Information related to velocity, density and 
anisotropy or fracturing can be entered in each polygon. The polygon parameters are set 
manually in the dialogue box or may be loaded from the well logging data for selected 
wells (thin layering). Information about shot and receiver points is also entered into the 
model. The built velocity models with shot-receiver layouts are used for calculation of 
the synthetic gathers. For more details about the Model Frame, please see Section 3, 4, 
and 12. 

• Surface Frame (Map) is the Frame where the map of the wells location within the 

field and the map of the surface calculated by the well data or imported from external 
text files are displayed. The information needed for calculation of the surfaces, namely 
the coordinates of the layers and the wells intersections, should be loaded to the 
database in advance. Tesseral Pro has 9 methods for map generation, such as spline-
approximation, Kriging and multiple regression. The cross-section model (Model 
Frame) for any section traced in the map is built automatically on the basis of the 
calculated (loaded) surfaces. More details about the Map Frame can be found in the 
Section 14. 

• Seismic Frame (Seismic) displays gathers in SEG-Y, SDS-PC, and TGR formats. 

3D gathers display also is supported. Please see Section 13 for details about the Frame 
Seismic. 
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lo w e r h e a d e r 

r ig h t 

b o u n d a ry 

le f t 

b o u n d a ry 

v e r t ic a l 

s c a le 

B o t to m 

d a ta a re a 

T o p 

u p p e r h e a d e r 

NOTE: Double click on the header of any frame to “expand” this frame to the whole 

window size (equivalent to the command View > Frame Full Screen). The 

repeated double click on a frame header arranges frames in form of “grid” inside the 

window (equivalent to the command View > Arrange Frames). 

• 3D View Frame is for visualization of 3D images. Please see Section 15 for details 

about the 3D View Frame. 

To create a new frame, use the command File > New Frame. After that, in the dialogue box of the 

frame parameters, the default values may be changed. 

Each type of frame has its own 2 headers (the upper and the lower one). In the upper header, any text is 

displayed (by default, the upper header looks like the header of a pane in Windows), and the lower 

header contains special information specific for each type of Frame. 
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11.2 Frame Selection 

Please use the left mouse button to select a Frame from the document field. The selected Frame will be 

shown inside a dotted rectangle. To cancel the selection, click outside the Frame boundaries using the 

left mouse button. The selection or de-selection of several Frames is implemented by the standard 

method for Windows. To select several Frames, please use the left mouse button together with the Ctrl 

or Shift key. 

Also in the Document View Mode, you can select a group of Frames by pressing the left mouse 

button outside the Frames on the blank field of the document and then dragging it (while pressing the 

left mouse button) to create a rectangular area. All Frames that fall inside this area will be selected. 

The last Frame selected is assumed to be the main Frame, and all the individual (non- group) commands 

will be applied to it. To change the selection of a Frame, click on it with the left mouse button while 

holding the Shift key. To select a Frame as the main one, please click on it with the left mouse button 

while holding the Ctrl key. 

To select all Frames at once, please use the command View > Select All Frames, and to 

de-select all the Frames, use the command View > Deselect All Frames. 
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NOTE: Please use the command View > Arrange Frames to sort the Frames 

automatically according to the sizes of their windows. For an easier way to work with 

selected Frame, please use the command View > Frame Full Screen. 

11.3   Frame layout 

In order to move a Frame within the Tesseral Pro main window, please press and hold the left mouse 

button on the upper headline of the Frame and just drag it. There are two modes of Frame layout. 

1. View > Document View Mode – Frames are freely distributed in the document. 

 

In this mode, the Frames can overlap each other, therefore the commands View > Bring Frame 

Forward and View > Bring Frame Backward are used to set the right visualization order. 

2. View > Tablet View Mode – Frames are only distributed in table cells. To change 

the size of any cell, please drag it with the mouse (while holding the left mouse button) 
from any Frame side, or change the size of the column (row) of the table in the internal 
axis of the Frame window. 

If you drag a Frame into a cell used by another Frame, the old Frame will be moved to the nearest free 

cell. 
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NOTE: It is possible to change the top and the bottom of any Frame with the scale by 

dragging the top or the bottom with the Ctrl key pressed. 

 
All actions are performed by using the left 
mouse button 

Move up/down 

Move to the left/right Upper headline Change the height of 
the upper headline 

Lower headline Change the height of 
the lower headline 

+ Ctrl 
Change the 
content‟s top 

Change the width 

+ Ctrl 
Change the 
content‟s bottom 

Change the height 

NOTE: While changing the Frames' sizes in the Tablet View Mode, the sizes of all 

Frames in the same table row and column are also changed. 

11.4 Frame size 

The width and the height of the Frames are adjusted in the dialogue box Edit > Edit Frame 

Properties. The height of the upper and the lower headers is defined in the dialogue boxes of the 

upper and the lower headers, respectively. For the Frames displayed in depth or time scale (Model and 

Seismic), the height and the width are calculated automatically from the top, bottom and scale 

information. The sizes of the Frames may be changed by the mouse, which can be done by dragging the 

Frame's borders while pressing the left mouse button. While several Frames are selected, the changes 

will be only applied to the main (last) selected Frame. The size of the remaining Frames will be the 

same. The height and the width of the upper and the lower headers will be changed by pressing and 

dragging the lower headline border. 

 

The next picture shows the different ways to change the Frame parameters 
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11.5 Undo/Redo 

Working with Frames, you may undo any action (or sequence of actions) using Edit > Undo. To 

redo the action that you‟ve undone, please use Edit > Redo. Commands Undo and Redo are not 

supported while working with files (menu File), database (menu Database) and calculating and 

editing seismic surfaces (Map > Add New Horizon from Well Tops, Map > 

Manage/Delete Maps, Map > Active Map). 
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Buttons for zoom 

11.6  Scale of display 

To scale the document (zoom in/out), please use the command View > Zoom or the scaling 

buttons in the main toolbar. 
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11.7 Print and export 

Documents are created on the principle of WYSIWYG by using Frames. For more details, please 

see section 11.3. 

Please use the command File > Print to print a document. 

Apart from printing, documents can be exported as a picture in any of the following formats 

(TIFF, EMF, WMF and BMP) by using the command File > Save as Picture. 
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11.8   Project tree and the database 

 

After the new project is saved (command File > Save Project), or after loading of an old 

project, in the left window of Tesseral Pro, the tree of the opened project is shown. This tree helps to 

systemize all loaded and created files.  

 

The point is that, during the modeling of synthetic gathers, several files are created and they are all 

located within the same folder (please see details in the Section 5.4). Additionally, after launching 

several jobs for the same model using different modeling techniques, more sets of output files are 

created. All these files are located in the same folder, and it may be complicated to find the needed one:  
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The project tree will simplify this task. The branches in the tree have the same names as the 

corresponding modeling method (Acoustic, Elastic, etc.). The remaining seismic files, which are 

created, for instance, by procedures of gather processing, are located in the branch Seismic files 

of the project tree. A double mouse click on a file in the project tree will create a Seismic Frame for 

this file in the right window of Tesseral Pro. 

The last nodes of the project tree are frame nodes (Model, Map, Seismic). 

The branch «Database» connects to the Tesseral Pro database (please see details in the Section 17). 

Double click these items to maximize the corresponding size in the window on the right. 

An example of a folder 

with results of Acoustic 

and Elastic modeling 
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12 Model Frame 

The Model Frame is used for creating depth velocity models using polygons, well data, underlying 

seismic images (2D or 3D models). After that, the velocity depth model is used for calculating synthetic 

gathers. 

Please see: 

• Section 3 for details about model creation 

• Section 3.2.9 and 17.5 for using well data 

• Section 3.1.10 about filling of a model with polygons, Section 4 about creation of the 
acquisition geometry 

• Section 5 about launching job of modeling a synthetic gather 

• Section 13 about displaying computed gathers, seismic models and field gathers 
Please see below for some additional features about using the Model Frame. 
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Adjust seismic underlay 

Select a section 

Set depth interval 

Select well(s) 

Select well data to be used 

12.1 Properties of the Model Frame 

To invoke the dialogue box with properties for an existing Model Frame, please select the command 

Model > Model Frame Properties. 

 

 

All the parameters input via the model building Wizard, may be changed manually in the dialogue box 

Model Properties. 

To select wells for the model – Please click the button Add >. 
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To select a section line – along which the model section will be created. After checking the option 

Draw section manually, in the lower left corner of the Model Properties dialogue box, 

you can draw the section line by using the mouse by pressing-dragging-releasing. To define the section 

line more precisely, you can: A) Select the origin coordinates, the azimuth and the length of the line in 

the Section interval group; or B) Click the Zoom map button to load the map for visual input. 

 

To set depth interval – In the Depth interval group, please specify the top and the 

bottom of the model. 

To select the data to be displayed for the well – In the Well data group, 
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Left side – The data to be displayed on the left side of the well bores Right side – The data to 

be displayed on the right side of the well bores Please select the type of well data you want to display. 

Log – The well log data. From the dialogue box of the well log parameters, please select the logs you 

want to display. For more details, see the Section 3.2.10. 

Well bore 
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NOTE: If you like to change the measurement units for the whole project (ft to m or m 

to ft), it is recommended to use the command File > Project Properties 

(please see details in the Section 16). 

12.2   Model re-size 

The command Model > Scale is used. 

 

 

Using this command, you may change the size of the model by stretching or compressing all polygons 

and location of sources and receivers consistently, which is done by specifying the parameter Re-size 

model by Scale. 

 

If the parameter Length, Top or Bottom is changed, the polygons of the model will not be stretched 

nor shifted. 
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12.3 Model export 

It is possible to export a model to any of the 3 seismic formats (TGR, SDS-PC or SEG- Y), and to a 

TAM format used by Tesseral 2D. 
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NOTE: If the TGR file contains multiple components or if you export a model in SDS- 

PC or SEG-Y formats, then 3 files will be generated (one file for each component). File with the 

selected name will contain the data of Compressional velocity (<file name>– 

PQR.sgy), Density (<file name>–PQR_Q.SGY) and Shear velocity (<file name>– 

PQR_R.SGY). 

12.3.1 Model export to a seismic format 

Please use the command Model > Export to Seismic Format (SEG-Y, TGR). 

 

 

 

 

In this dialogue box, please specify the cell size, the name of the output file. The minimum and 

maximum values of each component in the Components: value range window are to limit the 

possible spikes after interpolating the well log data. 

 

After creating these files, a Seismic Frame should appear in the Tesseral Pro window to display the 

gathers created from the model. 

Please see results 
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NOTE: The acquisition parameters data are not exported when model is exported to any 

seismic format. 
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12.3.2 Model export to Tesseral 2D (TAM format) 

Please use the command Model > Export to Tesseral 2D Format (TAM). 

 

While the model is being exported to TAM file, the thin layering data is not exported, but the acquisition 

geometry data is exported. 
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13 Frame Seismic 

This is the frame to display files in SEG-Y, SDS-PC or TGR formats. The frame is to support displaying 

2D/3D field and synthetic gathers, models, migrated slices/cubes, VSP gathers, multi-component files, 

snapshots of wave field propagation, etc. 
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Trace wiggle 

X Axis 

Trace to be shown Profile 

Y Axis 

Receivers 

Current shot 

13.1 Load seismic files 

The seismic files are loaded by using the command Seismic > Load Seismic File (New 

Frame) ( ). If several files are loaded at once, then they will be displayed in the joint coordinate 

space. 

If a seismic file is opened for the first time, it is proposed to select its type to apply the appropriate 

display mode, as shown below. 

 

Your selection will determine the displaying mode (please see Section 13.2), which can be changed at 

any time by using the View Mode command on the Seismic menu or the button from the toolbar. 

After that, your seismic file will be read. If a file is opened for the first time, it may take a long time to 

create the index files of the trace coordinates, which will be used later for optimizing the display. 

The Frame Seismic represents a rectangular graphic object which includes the images of the 

source/receiver spread (above) and the traces (below). On the edge of the frame, the scale for the X/Y/Z 

axis is displayed. On the top, the color palette of the trace values is shown: 
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In the source/receiver spread, the positions of sources (small squares) and the coordinates of traces 

(small crosses) are shown. The current source is marked in red and its coordinates are shown in a 

balloon. The trace view may include the wiggle of the trace and the images corresponding to the palette. 

The coordinates of the sources and receivers in the spread may be displayed differently. These settings 

can be changed in the Frame Properties dialog, which is called by the button ( ) (please see the 

Section 13.8). 

While moving the mouse cursor in the sections area (the vertical or the horizontal slice), the mouse 

cursor‟s coordinates and the corresponding trace value are displayed in the status bar. 
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Black crosses 
(Best for small 
seismograms) 

Gray dots 
(best for large 
seismograms) 

Contour 
(best for 3D cubes) 

13.1.1 Plan view 

 

The positions of the sources are always displayed as small squares, but the way of displaying the 

receiver‟s position depends on the display mode. For the seismic data with a small number of traces, the 

receiver‟s position is shown as crosses. For large gathers, the receiver‟s position is shown as grey dots. 

For very big gathers or cubes, the receiver‟s position is shown as contours. 
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View as VSP 

View all 
receivers 

View receivers of 
only current shot 

Note. In VSP mode 
receivers are shown 
vertically. 

13.2 Trace display 

In Tesseral Pro, there are several modes to display traces, and each of the modes is suitable for a specific 

task and type of seismic data. To preview gathers, 3 modes are commonly used, as illustrated in the 

figure below (from left to right: “Show All Receivers”, “Show Current Shotgather” and 

“Show as VSP”). 

 

 (1)  (2) (3) 

1. In the Show All Receivers mode, the spread of all the sources and 

receivers is shown in the top view. This mode is used if you want to have an overview 
of the whole field under study, and also get the sections of trace profiles belonging to 
several different sources. 

2. The Show Current Shotgather mode is for displaying shot gathers. Only the 

traces of the current source are shown. It can also be used to show the traces of the 
chosen receivers along any profile. 

3. The VSP mode is used for visualization of the VSP traces. The sources are located 

vertically (usually inside a well) and the traces are shown from left to right. 
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13.3   Operations with Seismic Frame 

While working with the Seismic Frame, 4 Edit Modes can be used: Select Source Mode ( ), Draw 

Profile Mode ( ), Zoom Mode ( ) and Move Mode (   ). 

The Select Source Mode allows selecting an active source and this source will be marked in red on the 

acquisition surface and its coordinates will be shown in a balloon. The Draw Profile Mode allows 

selecting the vertical section by drawing a line on the top view. In this case, the receivers will fall into 

the section if their distance to the profile is less than the given one (this distance is computed 

automatically during the opening of the seismic file, but it may be changed in the settings). In the Zoom 

Mode and the Move Mode, it is possible to zoom in and drag both the acquisition surface and the 

vertical section. 

Let's describe each of the modes for displaying seismic files. 

• “Select Source Mode” ( ) enables to show the current source and its 

corresponding traces. 

• “Draw Profile Mode” (  ) enables to draw a profile manually in the top view. 

Please see Section 13.5 for more details. Additionally, in this mode, a horizontal section 
can be shown. 

•  “Zoom Mode” ( ) enables to enlarge the image for the given area. 

• “Zoom In” ( ) enables to enlarge image. 

•  “Zoom Out” ( ) enables to reduce image. 

• “Zoom 100%” ( ) enables to zoom out the image fully. 

• “Zoom To” opens a dialogue box to set the zoom parameters. 

• Move ( ) allows you to move the image within the frame. 

•  “Rescale to Make X Scale = Y Scale” (  ) changes the Frame sizes so 

that the proportions of the geographic coordinates in the top view correspond to the 
visual ones. 

•  “Rescale to Make X Scale = Z Scale” ( ) changes the Frame sizes so 

that the proportions of the geographic coordinates of the traces correspond to the visual 
ones. 

•  “Normalize Palette by Visible Data” (  ) fixes the maximum and the 

minimum in the color palette to match the minimal and maximal values in the data 
currently visible in the Frame. 

• “Normalize Palette by All Data” (  ) fixes the maximum and the 

minimum in the color palette to match the minimal and maximal values in the seismic 
files currently loaded in the Frame. 

•  “Show Component” enables to select the components to be displayed (for the TGR 

format). 

• “Next/Previous Shotpoint” ( /   ) enables to set next/previous source as 

the current source. 

• “Export Traces Coordinates” enables to export the trace coordinates to a text 

file. 
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• “Import Traces Coordinates” enables to import the trace coordinates from a 

text file. 

• “Refresh” ( ) re-load the data in the Frame (re-read all the data from the seismic 

files). 

• “Apply Settings to all Seismic Frames” ( ) enables to apply the settings of the current 
Frame to other Frames. 

Furthermore, the user can display the amplitude spectrum for any area of the seismogram by clicking on 

Spectrum Mode  and selecting the region for which the amplitude spectrum is to be calculated. 

To select the region simply hold the left mouse button, move the mouse to draw the region and release 

the left mouse button. To obtain the amplitude spectrum for a different region simply select a different 

region using the same procedure.  
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13.4   Preview of 3D seismic models or 3D migration results 

Users can preview the 3D raster cubes in the Seismic Frame using the mode Show as Model (  

) and forming horizontal and vertical slices along any user-defined profile. As such cubes are in the 
format of seismic data, the cube's content is in form of traces. In this case, to describe the X and Y 

coordinates, the coordinates of the trace's receiver are used, and the Z coordinate is determined from the 

trace itself. In the general case, the coordinates of the source are ignored, but for compatibility with the 

seismic data preview tools, it is more suitable either to suppose that the source coordinates are equal to 

the receiver coordinates, or to create one source for the receivers having Y=const (this is implemented in 

Tesseral Pro), for which the X coordinate will be equal to the minimal X coordinate of receivers. 
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13.5 Profiles 

The easiest way to create a profile is to switch to “Draw Profile Mode” (  ), then draw the line 

manually on the top view, only those traces whose distance to the profile is within the pre-defined value 

specified in the object‟s properties will be included into the section. If the pre-defined distance is too 

large, the traces outside the profile will be displayed. If the pre- defined distance is too small, fewer or 

no traces will be included into the section. 

Section properties 

The detailed properties of the profile are specified by choosing the menu Seismic > Section 

Properties. 

 

In this box, the profile coordinates, its length and azimuth may be defined, as well as the maximum 

distance between profile and a trace. 

A vertical section may be exported to a separate seismic file, which may be then used as an underlying 

image for a model. The menu Run > Seismic Frame > Export Section to 2D 

Seismic File is used. 

The seismic data loaded into a Frame may be rotated along the profile, by using the menu 

Seismic > Rotate to Align X Axis along Section Profile. But the content of 

the actual seismic files will not be modified as the rotation will only modify the corresponding auxiliary 

files with suffix “.cr0”. 
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Rotate coordinates along the 
profile. 
Note. Actual seismic files do not 
change! 
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13.6   Overlay surfaces on seismic cubes 

You may load a surface and obtain the intersection line between this surface and a 3D cube. To do this, 

please specify the Seismic Frame‟s properties and specify the name of the file containing the surface. 

 

Tesseral Pro supports loading surfaces in the following formats: XYV, CSV, DAT, Surfer, 

Schlumberger, Triple TXT, ZMap, Paradigm, GeoQuest, Landmark, Charisma-YX, Charisma- XY, 

ASC. 
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The intersection line between the surface and the cube is shown as dark green line in the vertical section. 

While working in the Profile Drawing mode, when you click an arbitrary point on the vertical section, 

then a horizontal section will be created automatically such that it runs through the chosen point and is 

parallel to the loaded surface. This image will appear in the top view. 

Picture of 
horizontal section 

created by the grid 

intersection line of 
Grid and Cube 
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13.7 Horizontal sections 

Tesseral Pro implements a rather unconventional (for other gather-viewing software) mode for 

displaying horizontal slices. This mode is useful for 2D visualization of the raster 3D cubes. 

In the figure below, the horizontal (above) and the vertical (below) sections of the raster 3D velocity 

model are shown. In these sections, the profiles lines are shown, along which the horizontal/vertical 

sections were created. The profile line in the horizontal section is for creating a vertical section, and vice 

versa. 

 

To build a horizontal section, just switch to the drawing mode and click on an arbitrary point in the 

vertical section. Then, the horizontal section passing through the given point will be created 

automatically and displayed in the top view (see the top image). If a vertical line is drawn in the vertical 

section, a horizontal section will be created, whose value at each position is the average value spanning 

the drawn line (see the bottom image). The area, for which the horizontal section is created, will be 

shown by hatching. 

To remove the horizontal section while in the drawing mode, please click an arbitrary point in the 

vertical section while pressing “Ctrl” button. 
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13.8   Settings for Seismic Frame 

The majority of the visualization options can be accessed in the Seismic Frame settings. The parameters 

for displaying gather are specified in the Seismic Frame Properties tab under the Seismic 

menu. 

The properties dialog box is divided into several tabs. In the “Common” tab, the general properties for 

the visualization of the object are specified, and in the “Layout” tab, where the parameters for 

visualization of the acquisition surface are defined. 

The Units tab in the Seismic Properties window is for changing (scaling) the coordinates and 

values of the trace data in case a gather is displayed incorrectly in the Frame. In this case, the original 

file is not modified, and the changes are saved into an additional file 

<seismogram_file_name>.cr0. These new modified values will be loaded next time the file is 

opened. 

 

If you need to restore the trace parameters and coordinates, please delete the corresponding 

<seismogram_file_name>.cr0 file or select Update in the Common tab in the Seismic Property 

dialog. 

You can change color representation for displaying seismic data. The package includes 10 standard 

palettes (blue-yellow-magenta, iridescent, black-white and etc.). You can create a custom palette by 

clicking on Edit button in Common tab. The minimal and the maximal values for the color palette 

may be specified manually or left for the program to calculate these values automatically (for each 

vertical section and for the whole dataset). 

You can load seismograms into the Seismic object by clicking the Add button in the Common tab of 

the frame properties. Loading multiple files is allowed. It is assumed that all sources and receivers are in 

the same coordinate system. If this is not the case, you can (temporarily) correct the coordinates of 

individual seismic files using a linear transformation set using the settings in the Properties button 
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in the Common tab. The Calculate button allows you to restore the main parameters of the selected 

files by recalculating them from the disk. The same button cancels all previously made linear 

transformations of the coordinates of the sources and receivers. 

 

In the Layout tab, it is possible to define the parameters for visualizing the acquisition system. In the 

drop-down list of Seismic viewer from the Common tab you may select the display mode for 

the acquisition system. These modes are described in more details below. 

For different seismic files, the number of the receivers may vary from hundreds to millions, and 

therefore several ways of displaying these receivers are implemented, such as small black crosses, grey 

dots and contours. 

 

The Common tab also allows adjusting the traces displayed in the vertical section. In the Show group, 

users can select whether the traces will be displayed as wiggles or image based on the user-defined 

palette. For multi-component seismic data, users can select the component to be displayed in the 

Seismic File Properties group from the Units tab. 

In the Rulers tab, the parameters for displaying the Vertical and Horizontal rulers are specified. By 

default, both rulers are shown on the left and the right side of the object, but users have the option to 

either display the vertical scale on the left side, or just on the right side. 

The profile parameters (vertical or horizontal section) can be defined in the Profile tab. 

Receivers‟ view modes 

Axis direction 

Seismic File(s) 
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13.9   2D Snapshot Viewer 

To show the snapshots together with the shot gather, please choose the Snapshot View 

Window command under the View menu. 

 

Please press the Select Snap button to select the file with a snapshot. Please press the 

Select Shotgather button to select the corresponding gathers. If the Model Frame is opened in 

the Tesseral Pro, the contours of the model will be shown in the snapshot. Navigation through snapshots 

and gathers is done with help of the corresponding sliders. 

 

You can save the snapshots as a video by pressing Capture after which the 

Animation Properties window will appear. 

 

The movie will be saved in AVI format and the user must also specify the number of Frames 

Model Polygons 

Current Snapshot (time) 

Current Shot 
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per Second of video to be used from the Snapshot Viewer. 

 

The user can specify the Compression Quality of the video by clicking Compression. 

 

 

Also, the Temporal Quality Ratio for the compressor can be subsequently specified by 

selecting Configure. 

 

 

Once all setting are specified, click Okay and the program will start recording the Tesseral Pro 

interface. Please note that closing the Snapshot Viewer window from this point on will interrupt 

the recording, and everything recorded so far will be saved as a video! If the user wants to record the 

Snapshot Viewer window only, it is recommended that you extend it to full screen and use the 

Program Window Scope in the Animation Properties window. 
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To stop recording press Capture and the video will be saved in the specified location, with the 

specified name in the Movie file dialogue. 
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13.10 3D Snapshot Viewer 

In order to generate 3D snapshots please select check Generate 3D snapshots and select Setup 

3D Snapshots in the 3D modelling Calculations Properties window. 
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The user then needs to specify the Shot Points and the Component for which snapshots need to 

be generated, as well as for which Moments in Time. The user can also adjust the default values 

for the Mesh Step for wave field propagations along the X, Y and Z axis. 

 

As a result a SGY file will be generated for each specified shot point and its respective component, 

which will contain a snapshot image of the propagating wavefield at the specified time. In order to view 

the snapshot, the generated SGY file needs to be opened in 3D View frame (3D View>Add SEG-Y 

cube). In order to achieve the best display, the user will need to adjust the visualization parameters in 

the 3D View>Selected object properties window. 
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Typically for an optimum visualization of the wavefield, a value 85%-95% for the Opacity works 

best. Also, reducing the Magnitude within the Palette will also enhance the display of the 

whole wavefield. 
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13.11 Prepare seismic files for loading 

Sometimes, for unconventional gathers, some preliminary preparation is necessary before loading. Most 

often, the problems with loading SEG-Y files are caused by incorrect reading of the data related to the 

timing of the signal registration and incorrect reading of the data related to coordinates and altitude of 

sources and receivers. Partially, these problems can be solved in the Seismic Properties dialogue 

box (the Seismic > Seismic Frame Properties command). 

 

In the Seismic File Properties dialogue box, please select the measurement units for scaling 

of the trace coordinates and of the trace interval. In this case, the content of the gathers itself will be not 

be changed. All changes will be saved in an auxiliary file named <name of the gather file>.cr0. If you 

press the Apply button in the Seismic File Properties dialogue box, the file with the suffix 

.cr0 will be deleted and the previously entered scaling constants will be cleared. 

Sometimes, the trace coordinates in a SEG-Y file‟s header are located in non-standard 

cells. 
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To prepare a gather for loading, please choose the Seismic > Raw Trace View Window 

command. After the seismic file is chosen, 2 windows will be opened. In one of the windows, the trace 

preview is shown in the same order as the traces in the file, and in the second window, the table with 

headers of an individual trace is shown. 

The standard locations of 

source‟s and receiver‟s 

X/Y/Z coordinates in a 

SEG-Y file‟s header 
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The key point for preparing a seismic file for loading is to select the headers‟ cells which correspond to 

the coordinates of the source and receiver. It is possible to allocate the coordinates of the source and the 

receiver to any cell in the headers by clicking the right mouse button in any cell of the header. This 

information (assign some header cells to the coordinates) will be saved in the file <name of the gather 

file>.inf, and, from now on, it will be used by the program. 

Preview of all the trace headers enables to look through the trace headers as a set of values without 

name. You may specify the parameter offset to shift the starting point of displaying the headers. 

Min/Max/Avg value 

Set the meaning 

of a header 

Current trace wiggle 

Trace headers 

Current trace number 

View mode 
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The trace header may be displayed in two modes: Descriptive mode and Dump mode. In the Descriptive 

mode, only the headers with known names are listed. In the Dump mode, all headers are listed. 

While looking through the header as a whole, the location of words is in the first column, the data type is 

in the 2nd column and the values are shown in the third column. As different data types have different 

length of words, the lower part of the header is shifted automatically. 

Tesseral Pro supports the following data types: CHAR (1 byte, -127~128), SHORT (2 bytes, -

32767~32768), LONG (4 bytes, -2147483647~2147483648). 

Select meaning 

Select type 

Word number 

in header 

Offset 
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14 Map Frame. Stratigraphic Surface Maps 

In Tesseral Pro, a model can be built from stratigraphic surface maps. The model is built automatically 

as a vertical slice cutting through the calculated (loaded) surfaces vertically along the selected line.  

More information about building models by using stratigraphic surfaces is described below. Firstly, let‟s 

describe the relevant capabilities for loading, calculating, displaying and processing surfaces. 
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14.1   Load surface from text file 

Tesseral Pro supports loading surface from text files in various formats (the command File > Load 

Surface File). It is also possible to load grids in the following formats: XYV, isolines, separate 

points, Integral+, Surfer, Schlumberger, Triple, ZMap, Paradigm, GeoQuest, Landmark and Charisma. 

The user can also generate surfaces on his own, by introducing in a text file the XYZ coordinates of the 

surface in 3 separate columns and then saving the file with an XYZ extension. 

 

In the standard File Open dialogue box, please select the surface file and specify the proper format 

from the File type list for the selected surface file. 
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You may select several files of the same type for a group loading. 

Then, in the next dialogue box Calculate Isolines, please specify the parameters for calculating 

the isolines or click Cancel, if you do not want isolines to be shown on the surface. 

 

Please see the results 
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NOTE: The Undo and Redo commands do not apply to actions performed on surfaces 

(loading, calculating, processing, deleting), but they do work for the changes related to the 

Map Frame (selecting a surface for display, color adjustments, scaling, Frame re-size and 

etc). 

 

Please repeat this operation to load other surfaces. 

Tesseral Pro saves all loaded surfaces as a general block in a Tesseral Pro document. Please use the Map 

Frame to display a surface. While deleting the Map Frame, the last showed surface in this Frame is not 

deleted and it will remain in the block of the calculated (loaded) surfaces in the Tesseral Pro document. 

You can show this surface in another Map Frame by selecting it from a list. Please use Map > 

Manage/Delete Maps to manage the surfaces loaded in Tesseral Pro. More detailed information 

can be found in the Section 14.2.5. 
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14.2 Calculate surfaces using well data 

To build surfaces by using the intersection of well layers, Tesseral Pro requires an existing MS Access 

or MS SQL Server database with well coordinates, altitudes and/or inclinometry and stratigraphic well 

depth values. More detailed information about how to load such information into the geophysical 

database can be found below in the Section 17. 
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NOTE: Once Tesseral Pro is loaded, it is not yet connected to the database. Please use the 

Load Database button in the left part of the window to connect to DBMS MS SQL 

Server or to MS Access and to load the Tesseral Pro database. More information about 

connecting to the database can be found in the Section 17.4. 

NOTE: It is also possible to select a field using the command Select a field for 

the project from the context menu by right-clicking the mouse on the field‟s name in 

the database tree. 

14.2.1 Select fields for the project 

As the database may include several independent fields, users need to select the “working” field before 

surface building, which can be done using the command File > Project Properties. Please 

also select the directions of the coordinate axis for the surface maps you want to build. 
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14.2.2 Create Frame Map 

Please use the command Map > Create Map (New Frame). Then, a map with the wells of the 

selected field will appear. 

 

All commands for editing the map are located in the Map menu. 
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NOTE: If the area was selected incorrectly: (1) To cancel the last action, please use Edit 

> Undo; (2) To zoom the area, use the command Map > Zoom Mode, and then select 

the area again. 

14.2.3 Working area 

The working area (the area where the surface is built) is defined by an interval (m or ft) along the X and 

Y axis. The working area is defined in the Map Properties dialogue box of the Map Frame. 

 

The working area can also be selected visually by the mouse in the following modes: Map 

> Zoom Mode or Map > Move Mode. In both modes the selection (displacement) of the 

area is done by left-clicking the mouse on the Map Frame (press-drag-release). 

 

Please see the results 
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Use the list to select 

layers automatically 

Select layer(s) 

from list 

NOTE: Depending on the input data, the most suitable method is selected automatically 

from the list. 

14.2.4 Surface mapping 

Surface mapping is based on the intersection data of well layers. Tesseral Pro supports 8 mapping 

methods, such as the spline-approximation and Kriging. 

To create new surface maps, please use the Map > Calculation of Horizon from Well 

Tops menu command. In the Add new surfaces dialogue box please select the layers, for which 

you want to build the surface maps. 

 

Next, select one of the mapping methods available from the list. 

 

 

 

 

 

The surface calculation for the selected layers will be done automatically by the selected mapping 

method. 

Please see the results 
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NOTE: If you want to re-build surfaces using another mapping method or to build other 

layer surfaces, please choose the command Map > Add New Horizon from 

Well Tops again. The program will propose you to delete the existing surface if you 

want to re- calculate it again. 
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NOTE: The Undo/Redo commands are not supported while handling surfaces (creating, 

loading, deleting). 

14.2.5 Handling surfaces 

Please use the command Map > Manage/Delete Maps to delete and modify the properties 

(name, top and bottom) of any surface displayed in the Map Frame. 
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NOTE: The Map Frame “does not contain” the loaded and calculated surfaces. All surfaces 

are saved into a common block in the Tesseral Pro document (Map > Manage/Delete 

Maps). The Map Frame is used to display any of the loaded (calculated) surfaces. It means 

that, in any Map Frame, you can show any surface from the common list. Deleting a 

surface from this list will lead to its “disappearing” from all Map Frames where this surface 

was shown. The commands Map > Active Map (rotation, displacement, and 

smoothing) can also change the surface data itself (not only its display in the Frame). 

14.2.6 Surface display 

The display parameters for the Map Frame can be changed in the Map Properties dialogue box 

(the command Edit > Edit Frame Properties or Map > Map Frame Properties). 

 

 

To change the palette of the surface, please select the Map Frame with the mouse and then use the 

command Edit > Palette or click the Palette button in the Map Properties dialogue 

box. 
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The displayed amplitude of the surface cannot be changed (scaled down) in the 

Palette dialogue box. But it can be changed by using the command Map > Active Map> 

Properties. 

 

Here, it is also possible to change the model‟s name and the surface type. To change the surface itself 

(not only its display), please use the commands Scale, Smooth, Rotate from the menu Map > 

Active Map and in this case the commands Undo/Redo are not applicable. 



© Tesseral Technologies -User Documentation- 386 
 

Wells selected 

to the profile 

14.2.7 Build model from surfaces 

Before building a model using surfaces, it is recommended to load or calculate these surfaces in Tesseral 

Pro. You do not need to have all surfaces ready before building the model. This process can be iterative, 

i.e., you can delete, add, re-calculate surfaces and re-build the existing model using the new surface data. 

The steps to building a model from surfaces are as follows: 

STEP 1. Select the wells for the section line (profile) – To select wells among those displayed in the 

Map Frame, please right-click the mouse button on the well you want to add to the profile. Then, in the 

context menu, select the command Add Well to Profile. The picture will not be changed after 

selecting the first well. Please repeat the process to add the other wells. 

Please see the results 

 

To delete a well from the profile, please use the command Delete Well from Profile in the 

context menu or the Map > Profile menu. To clean the entire profile, use the command Map > 

Profile > Empty Profile. 

STEP 2. Draw section line – Please select the mode Map > Section Mode. Then use the left 

mouse button to draw (press-drag-release) a section line. 

Please see the results 
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STEP 3. Create a model – Please use the command Map > Transmit Horizons to Model to 

launch the Wizard for creating a model. More detailed information can be found in the Section 3.1.3. 

STEP 4. Support of thin layering – If you would like to fill the polygon‟s parameters by the well log 

data, you need to load these log curves to the wells in the model via the dialogue box Polygon 

Properties (the command Model > Edit Polygon, after you select the polygon). 

In the Polygon Properties dialogue box that opens, please select the acoustic log for automatic 

parameter setting From Log for the polygons created by surfaces. The remaining parameters of the 

Model Frame can be set right now or later via the dialogue box Model > Model Frame 

Properties. More details can be found in the Section 3.1. 

Section line 
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NOTE: Choosing the command Map > Transmit Horizons to model again 

when the Model Frame already exists will cause the model to be automatically re-built (1) 

from the selected section and profile in the map or (2) from the existing maps of the layer 

surfaces in the document. 

 

Please see the results 

 

 

Select logs to be displayed on wells 
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NOTE: During the adjustment of the polygons‟ parameters that have been created 

automatically from the Map Frame, please use the By default button in the Polygon 

Properties dialogue box to memorize these parameters; they will be automatically 

filled next time you create polygons from the same layers. 

STEP 5. Adjust model – More details can be found in the Section 3.1.10. 
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Scale 

Data 

15 3D View Frame 

In Tesseral Pro, the 3D View Frame is used for visualizing the spatial distribution of the data from a 

database, a project or from a user file. To rotate the data contained in this Frame, please use the toolbar 

buttons when this Frame is selected. The data are displayed in a cube. You can customize the scale of 

each edge of the cube by using Object Properties. Use the linear Zoom slider to zoom the 

display. For the axis, different scales may be adjusted (Horizontal/Depth Scale). To access 

object properties, please double-click on the object or use the command 3D View > Object 

Properties (in the 2nd case, the object should have been selected in advance by the mouse).  

The data can be loaded into the cube using the 3D View menu. All the data loaded to the cube are 

displayed together in a unified coordinate system. Let's describe the 3D View Frame in more details. 
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NOTE: Setting the “step” parameter too high decreases the drawing quality. 

Depth range 

Open file 

Vertical boundary of the cube 

Scheme 

15.1 Seismic Data Visualization 

The 3D View frame allows displaying seismic data in the SEG-Y, SDS-PC and TGR formats. To 

load the cube, please use the command 3D View > Add Cube. The Add Cube dialogue box will 

appear. Then, please load the target file. The receivers are shown as small blue crosses. Initially, the 

whole area is covered by the selected receivers. To select a rectangular part of the whole area, please 

draw the diagonal of the square you want to select while holding the left mouse button. Use the 

minimum/maximum depth parameter to limit the depth range of the cube. By default, the depth range is 

from the minimum to the maximum throughout the cube. After pressing OK, the Cube Properties 

dialogue box appears for users to specify the cube properties. The parameter step is the distance between 

the two neighboring nodes of the loaded grid along each of axis. This parameter can be increased to 

speed up drawing. The other parameters in this dialogue box are used to adjust the color palette. By 

default, the range of the palette is set from the minimum to maximum values obtained from the file. To 

set the range of the palette automatically for the displayed data, please select the Auto fitting by 

cube values option. 

 

 

The procedure of loading profiles is practically the same as described above. 



© Tesseral Technologies -User Documentation- 392 
 

15.2   Surface Visualization 

Surfaces are loaded from files in the same way. The command 3D View > Add Map > From 

Project is for loading surfaces from a Tesseral Pro project.  

After clicking OK in the Add Map From Project dialogue box, the Map Properties 

dialogue box will appear for each loaded surface. The palette can be defined either from the active 

surface or from any other surface (check the Filling by another surface option). The 

interval of the palette can be set by the user (Set own interval) or by the minimum and maximum 

values in the surface (Auto fitting by surface values) or by the minimum and maximum 

values in all surfaces in the Frame (Set general depth interval). Check the option Apply 

to all to apply the palette settings to all available surfaces. 
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Configuration of the 

wells in the scheme 

List of wells to display 

15.3 Visualization of inclinometry logs, well logs and layers 

To load wells from the database, please use the menu command 3D View > Add/Remove Wells, 

then in the Wells dialogue box define the list of wells you would like to see in the Frame. To set 

well properties, use the command 3D View > Well Properties. 
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15.3.1 “General” tab – General well properties 

 

A well can be shown in form of a line or a 3D pipeline with a given radius (the Fictive Radius 

parameter) by checking the Pipeline View option. If the Number of slices to form a 

pipe parameter is increased, the image quality will be improved, however, this can affect the program 

performance. The Length of a straight pipe section parameter is not for displaying the 

inclinometry data saved in the database, but for selecting the values from the database, provided that the 

distance along the well between the two neighboring values is bigger than the given value of this 

parameter. This parameter affects performance of the program in the same way as the parameter 

Number of slices to form a pipe. You can limit the well in depth by using the parameters 

Min and Max after checking the Depth range option.  

The parameters Width of well-log display region and Stratum marker: fictive 

radius are used to adjust the display of the corresponding well logs and layers and are described 

below. 
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15.3.2 Well logs visualization 

To add a well log into the Frame, please use the Well Properties dialogue box, and then go to the 

Logging tab. The Well-log list contains the names of the curves to be displayed in the Frame. All 

the options to the right of the list are for adjusting the active curve. The curves are added to the list by 

using the Select Curves dialogue box. Initially, the list in the Select Curves dialogue box 

contains all available curves from the wells in the Frame (if the Frame does not have any wells, the 

dialogue box will contains the list of all curves in the database). To obtain the list of the curves for one 

specific well, please select the required well from the list. The curve will be displayed in the Frame on 

the left or on the right of the well. The width of each curve can be edited in the Well Properties 

dialogue box. A value of 0 means that the curve will not be smoothed and it will have the minimum 

possible width. The curves with higher width values will be smoothed. The other settings for the curves 

are similar to the ones described in Section 3.2.10. The width of the region for curve display can be 

adjusted in the “General” tab by setting the Width of well-log display region parameter. 
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15.3.3 Layer Visualization 

You can display special marks at the intersections of wells with the tops of layers. To do this, go to the 

Strata tab in the Well Properties dialogue box. The list on the left of the dialogue box shows 

available layers. The layers in the list on the right will be displayed in the Frame as circles on the wells. 

You can define the circles‟ width in the General tab by setting the Stratum marker: fictive 

radius parameter. 
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Measurement units 

for the project 

16 Annex A: Measurement units 

To select the measurement units, the command File > Project Properties is 

used. 

 

Different data types and different frame types handle the measurement units selected in the project 

properties in a different way. For example, the database does not depend on the project, and each oil 

field (and even well) may have their own measurement units for depths and logging data depending on 

initially loaded data. Each gather could have been created in metric or imperial system, but it should 

correctly loaded into Tesseral Pro. Every kind of data can be “adjusted” to the chosen measurement units 

by using the appropriate settings and commands in Tesseral Pro. 

The following section describes how to convert various input data into the measurement units you need. 
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Distance Distance 

Imperial system Metric system 

16.1   Model Frame 

The Velocity and Density parameters determine the output units for velocity and density in the 

model polygons‟ properties. Distance represents the units for model‟s length/width, coordinate 

binding and acquisition geometry. If the measurement units are changed in the project, the Distance 

may be re-calculated. If parameters Velocity and Density are changed, the polygons‟ data 

display is also changed. 

 

 

If the model is loaded from other formats (File > Load Model), for which the measurement units 

are unknown, users need to specify the measurement units (Metric or Imperial) in the dialogue box 

below. 

 

After that, the loaded model will be transformed into the project‟s measurement units (if the file‟s 

measurement unit differs from the project‟s one). Additionally, the Distance of the loaded model may be 

adjusted manually by the command Model > Scale. It is possible to select the scaling coefficient for 

the model and transform the measurement units from ft to m or vice versa. 
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Separately, in a special way, units of measurement are configured for the database wells used in 

constructing the model. Details below in the Database, Conversion of Units of Measurement section.
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Coordinates in meters 

16.2 Seismic Frame 

If the measurement units are changed in the project, only the display in the current project‟s Seismic 

Frame is updated: gathers‟ distance, velocity and density are shown in the chosen measurement units; 

however, the data files themselves are not modified. 

For example, if you have selected ft as distance units for the project, the display of trace coordinates will 

change accordingly. For instance, if the Distance option in the project is set to meters, a SEG-Y file 

is displayed as follows: 

 

If the Distance option is set to feet, the same SEG-Y file is displayed as follows: 
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The measurement units 

of data in the file 

Characteristics of gather data 

 

When the displayed data is in seismic formats TGR or SEG-Y, and the data is velocity or density, then 

their values will be scaled in accordance with the selected measurement units. 

Please select the component of the seismic file to be displayed by specifying the Component 

parameter in the Seismic File Properties dialogue box which is invoked by Seismic > 

Seismic Frame Properties. 

 

Coordinates in feet 
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16.3 Map Frame 

If the project‟s measurement units are changed, the loaded and computed surfaces will be deleted. To 

transform the size of the loaded surface from m to ft or vice versa, use the command Map > Active 

Map > Scale Boundaries. 

 

 

In the dialogue box above, please press Convert from ft to m or Convert from m to 

ft to convert the measurement units for the selected surface. 

To convert the surfaces built by a database of well intersections, it is possible to change the distance 

measurement units in the database (oil field or well), and then build the surface again. 
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NOTE: Before well data is used for model building, the data must be converted to the 

project’s measurement units (the command Database > Convert Units). 

16.4   Database: transform the measurement units 

Please see Section 17 for details about content and filling of the database. 

The contents in the database do not depend on the selected measurement units in the project. 

Furthermore, some data in the database (for example, a particular field) may contain data in the imperial 

measurement system and other data may be in the metric one. To transform the data for such field from 

one measurement system to another, please select the field with mouse in the database tree, and then 

choose the command Database > Convert Units. 

 

In the dialogue box above, select the data you would like to convert and conversion direction (from ft to 

m or from m to ft). 

 

The values of curves loaded to the database may also be converted, but it has to be done one by one. To 

do this, please select the needed curve in the database tree, and choose the command Database > 

Data Properties. 
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In the Log Properties dialogue box, check Edit Log and press Transform.  

In the next dialogue box Transforming Data enter the scaling coefficient. 

 

 

 

It is recommended to perform such data transformation for all the acoustic logs in all wells of the same 

deposits, so that the same measurement units are used. 

After having normalized the logging data, it is possible to choose the measurement units for all curves of 

the model during model creation by well data, by specifying the Measurement unit parameter in 

the Log dialogue box. 
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While the polygon’s parameters are filled with interpolated well data, the logging data are first converted 

to the selected measurement units of the project (m/s, ft/s, kg/m3, g/cm3). To ensure correct conversion 

of the measurement units, the measurement units for logging must be correctly set in the 

Measurement unit parameter. 
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17 Annex B: Geophysical database 

To connect to the database, expand the upper node of the Database tree in the left pane of the Tesseral 

Pro window. 
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17.1 DBMS 

Tesseral Pro uses DBMS MS SQL Server or MS Access to store well log data. 
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17.2 Diagram of Classes 
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17.3   Description of tables and basic fields 

Tesseral Pro has the following well log data structure: 

The upper level is Fields (Fields table). The database can contain several fields. The fields contain 

wells (Wells table). Each well may only belong to a single field. 

A well can contain: 

• Stratigraphy (Strata table) with 

stratigraphic well cuttoffs. 

• Well inclinometry (Inclinometry table). 

• Well logs (Logs table)  

 

 

 

 

 

 

 

 

 

 

 

Fields: The main attribute is Name 

(name of the fields). 

 

 

 

 

Wells: Belongs to a field. The main attributes are: 

• Number – Well number (name) 

• x, y – Well coordinates 

• EBK – Elevation Kelly Bush (corresponds to the 

Elevation Kelly Bush parameter in the  

Well Properties dialogue box) 

• Borehole – Well bottom (corresponds to the Bottom parameter in the Well 

Properties dialogue box) 

Well 4 

Well 2 

Well 1 

Field 2 

Field 1 

Inclinometry 

Layers 

Well 3 

Field 3 

Log 2 

Log 1 

Well Log 
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Inclinometry: Belongs to the well. It contains the table 

with coordinates of the marks along the borehole. 

• Depth – Depth mark from the wellhead 

• x, y – Borehole deviation from the wellhead at the 

current depth mark 

• z – Absolute depth of the current well mark from 

the sea level; positive values mean 

„below the sea level‟, negative otherwise 

 

 

 

 

 

 

 

 

Strata: Belongs to the well. It contains the table of the well‟s layer-intersections. The main attributes 

are: 

• Well strata is the name of layers 

• Type defines the stratigraphic type (layer/mass/suite/stage and etc) of the current 

layer. The table of allowed database‟s stratigraphic types is strata type 

• Strata code is the layer code in the database‟s code table strata code. It is 

used for automatic building of surfaces by using the layer-intersections 

• Depth is the depth of layer intersection 

• x, y, z are the absolute coordinates of the layer intersection 

• Is Bottom –„1‟ for bottom, „0‟ for top 

Strata Code: Belongs to the layers (stratigraphy). It contains the table with the codes of field layers. 

The main attributes are: 

• Number is the layer code in the database’s code table strata code 

• Name is the name of the layer code 
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• n.of wells is the number of wells, where a layer with the specific code is 

used 

 

Strata type: Belongs to the layers (stratigraphy). It contains the table of layer types. 

 

The main attributes are: 

• stratum type is the layer’s code in 

the layers codes table of the database 
strata code: 

• name – is the layer name 

Logs (log curves): Belongs to the well. 

It contains the table of the well logs. 

The main attributes are: 

• Method is the layer’s name 

• Start, Stop are the curve’s top and 

bottom 

• Step is the curve’s sampling step 

• Vmin, Vmax are the curve’s amplitude rang 
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17.4  Database connection, creation and copying 

Connection to the database is established automatically while loading Tesseral Pro or by using the 

command Database > Connect. 

 

Please select the DBMS you would like to connect to, and adjust the connection parameters. The MS 

Access test database TesseralPro.mdb with several wells is included in the installation. 

To back up the Database, please use the command Database > Backup. For MS Access: 

It creates a copy of the “.mdb” file by using the standard Save As dialogue box. For MS SQL Server: 

Please provide the full path and name for the backup copy. It is recommended to back up the database 

before operations that could lead to data loss like loading and deletion, so that, in case of any incorrect 

actions, the database can be recovered from the backup copy. 

To create or restore a Database, please use the command Database > Create/Restore. 

MS Access creates a new “.mdb” file while creating a new database by using the standard 

Save As dialogue box. Restoring such Database is not supported, so please use the command 
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NOTE: All current data will be lost while restoring the database from a backup copy 

Database > Connect to connect to another “.mdb” database. 

When MS SQL Server creates a new database, please enter the Database Name, and then select 

Create Empty Tesseral Pro Database. To restore a database from the backup copy, please 

select Restore Backup, and then define the full file path and the name of the backup created 

previously. 
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17.5   Data loading 

The data is loaded into Tesseral Pro either from LAS files (to the Logs table) or from text files to the 

tables Wells, Inclinometry, Strata and Strata code. Data can either be loaded to an 

existing well, or loaded to a field, in which case the program “distributes” the data from the file over the 

existing wells or creates new wells automatically. 

Data in text files (TXT, CSV, and TAB) must be presented in the form of columns (the columns are 

separated by spaces, tabs or semicolons). It is preferable that each column has its own header. For 

example, 

Well Number x y ekb borehole 

1 490454.8 7172923.5 85.6 3502 

2 482493.0 7160560.5 96.4 3812 

5 484796.1 7155446.5 89.7 3555 

6 475956.6 7158533.5 100.0 3456 

7 472471.0 7156297.5 100.4 2544 

8 476867.3 7163649.5 91 3514 

9 477733.9 7156292.5 98.2 3098 

10 459056.6 7146075.5 92 3113 

11 496123.6 717966674.9 11 3221 

12 498422.6 718709668.9 12 2801 

13 480333.9 7165486.5 87.7 4121 

14 470601.8 7153447.5 105.6 3434 

The first column is the obligatory well number where the data is to be loaded. To prepare data for 

loading, please use the command Database > Prepare Text Tables. To load prepared text 

files or files in LAS format, please use the command Database > Import Data. 

STEP 1. Create a field – Please use the command Database > Add Field, and then set the name 

of the new field in the pop-up dialogue box 

STEP 2. Load well coordinates, elevations and well bottoms – Please use the mouse button 

to select the field into which you would like to load the data, and then choose the command 
Database > Prepare Text Tables 
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NOTE: There is no Undo/Redo command in the Text Table Loader dialogue 

box. Therefore, it is recommended to save partial results periodically by using the File > 

Save command. 

In the Data to import list, please select wells. 

If you have a text table with the necessary information, please use the command File > Open in the 

Text Table Loader dialogue box. If the data are in Microsoft Excel or Word format, use the 

Copy/Paste commands to transfer the data from the MS Office document to Text Table 

Loader via the Clipboard. 

 

The first column from the text table is obligatory and contains the number of wells into which the data is 

to be loaded. The light green (second) row is optional and it is intended for the headers from the input 

file. In the first yellow row, all the attribute names of the columns you want to load should be entered. 

Click the mouse inside each of the cells to select the attribute, into which the data from the column are to 

be loaded. 

It is not necessary to load coordinates, bottom of the hole, and altitude all in one table; sequential data 

loading (amending) to the wells from several files is supported. 

Please use the command File > Save as text in the Text Table Loader 

dialogue box to save the prepared table as a text file. 

 

When the table is ready, please press Import to load the data into the selected field. 

After data has been imported, it is recommended to QC the result; use the mouse to select any loaded 

well and then choose the command Database > Data Properties. 
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In the Well Properties dialogue box, you can modify any data and save them to the database 

using the OK button. 

STEP 3. Load inclinometry. Generally, loading inclinometry is similar to loading well coordinates. 

Please select a field where you would like to load the inclinometry data by the command Database 

> Prepare Text Table, and then select inclinometry from the Data to import list. 

To use the inclinometry data in Tesseral Pro, the columns depth, x, y, z need to be filled. The 

remaining columns are only informative and they do not influence the borehole shape. Apart from the 

first column (well number), the order of the other columns is not important. The rows order for 

a single well is also not important, but it is not recommended to have the data in the file related to the 

same well shaped like “blocks”; it is better to sort all wells 

by well number. 

Once the table is ready, please press Import to load the data into the selected field. 

After loading, it is recommended to check the loading result. For this purpose, please select the 

Inclinometry branch for any of the loaded wells, and then choose the command Database > 

Data Properties. 

 

For correct mapping, the table Inclinometry must be filled (for the wells you want to use for 

mapping). If you have no inclinometry data, the wells can be assumed to be vertical, and 
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NOTE: In case that the selected well already had inclinometry data, the old data will be 

deleted. 

NOTE: If you do not like the results of loaded inclinometry, please select the field with the 

mouse and then use the command Database > Delete from Field > 

Inclinometry and repeat loading again. 

then the inclinometry data can be generated automatically; this can be done by the command 

Database > Create Inclinometry. 

 

In this dialogue box, please select the wells for inclinometry generation from the list on the right, and 

then press Create inclinometry. For automatic creation of inclinometry, the information about 

the well’s altitude and bottom hole is used from the wells table. While creating inclinometry in the 

absence of this data, you will be prompted to enter the altitude and bottom of the hole manually in a 

dialogue box. 

Use the buttons Select wells without inclinometry and Select wells with altitude and bottom for 

automatically selecting the wells in the list. 

The result of executing Create inclinometry is shown below for a well. 

 

 

STEP 4. Load stratigraphy. Generally, loading stratigraphy is similar to loading well coordinates and 

well inclinometry. Please select the field you want to load the stratigraphic lay- outs with the mouse and 

then choose the command Database > Prepare Text Tables. Please select strata from the 

Data to import list. 
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The main attributes are name (layer name), depth (layer-intersection depth along the borehole), 

isBottom (1-bottom, 0-top). If the absolute coordinates of the layer-intersection are available, it is 

worth loading them into the database. Otherwise these coordinates will be calculated automatically 

every time before calculating a layer surface map. 

Apart from the first column (well number), the order of the other columns is not important. It is 

recommended to sort the rows in advance by well numbers. 

Once the table is ready, please click Import to load the data into the selected field. 

During the loading process, if a layer name is not found in the strata_code table, you will be 

prompted to assign/create a layer code for this layer in the dialogue box below. 

 

Create New is for inserting a new row into the database‟s layer code table. The new layer code in 

the well is assigned to this row. 

Assign is to assign the layer code in the well selected from the list. 

Assign Empty is for setting the layer code in the well to “0”. 

Cancel for no action 
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NOTE: If you do not like the results of the loaded stratigraphy, please select the field with 

the mouse and then use the command Database > Delete from Field > 

Strata and repeat the loading process again. 

 

It is recommended to check the results of the loaded Stratigraphy by selecting the Strata branch of 

any loaded well and then choose the command Database > Data Properties. 

 

 

STEP 5. Load well log data – The well logging curves are loaded from LAS files for a well or a field 

with the command Database > Import data. A selection of multi LAS files is supported in the 

dialogue box. After having selected the file(s) and clicking the Open button, a dialogue box will appear 

for loading the curves into the well. 

 

Please click Import to load the selected curves into the database. 

For QC of the loaded result, please select a curve from the Logs branch of the well, and then choose the 

command Database > Data Properties. 

NOTE: The layer code is of great importance for surface-layer building by layer- 

intersection data and automatic creation of polygons in the model. The attribute name is 

ignored in both cases and only the strata_code is used. Thus, it is recommended, 

whenever possible, to identify the new layer name with an existing code from the Assign 

a value dialogue box. 
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NOTE: To change the layer code name, please double click on its current name and then 

change the name in the edit field. 

17.6   Data editing 

A partial editing of the data loaded from LAS or text files for fields and wells can be done by using the 

dialogue box (Database > Data Properties). 

 

In the Well Strata List dialogue box, the layer codes in the database can be inserted, 

deleted or modified by using the Field Strata button. 

 

 

To edit the log curve, choose the command Database > Data Properties and select the 

curve name from the database tree. 
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In the Log Properties dialogue box, please check Edit Log checkbox to enter the log editing 

mode. Then select the log interval by the mouse (press-drag-release), or use the button Select All 

to select the entire log. The selected log interval can be smoothed by using the Smoothing button or 

scaled by using the Transform button, or deleted by using the Delete button. A log interval can be 

drawn manually by using the mouse (press-drag-release) while the Manual Draw checkbox is 

checked. 

Deleted 

anomalous 

values 

Smoothed 

interval 
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Initial log 
Scaled 

log 
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18 Annex C: Licensing policy 

Tesseral Technologies Inc provides several ways to license Tesseral Pro. For detailed information 

about license policy, please contact support@tetrale.com .  

mailto:support@tetrale.com
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18.1 Single-user License 

A local alpha-digital key is bundled to a particular computer. Licensing with the alpha- digital key does 

not allow using this key in any other computers. This may be the most suitable choice for the package‟s 

trial license, a public standalone PC or permanent user-independent workplaces like a computer class at 

a training facility. 

A local hardware key (HASP) provides the licensing when the HASP is plugged into a USB port of a 

computer. User can install the same Tesseral product on other workstations and use the same key. So 

this type of licensing is the most suitable for occasionally using Tesseral package on multiple work-

places, e.g. both at home and in the office. 
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18.2 Network License 

A network license is unique for the client's network. The license key is usually installed on one of the 

network PCs called a Server. It may be the best choice for bigger or scattered companies. Due to the 

increasingly toughening policies in Windows system administration, it may require some additional 

network administrating efforts (eliminating possible interference with particular network security 

features and local network Firewall settings) to support such configuration, but this type of licensing 

allows multiple users to utilize the common license directly from multiple network PCs, but a program 

must be initially installed on each of computers where Tesseral is running. 

• A network alpha-digital key license is unique for the client's network. The license key 
is installed on one of the PCs from the network (a Server PC); it may be a virtual 
machine because this type of licensing does not require special hardware. 

• A network hardware (HASP) key provides licensing when HASP is plugged into a 
USB port of any computer in the local network or VPN (Virtual Personal Network) to 
which the user's computer is connected. 
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18.3   Mixed Licenses 

Any combination of the types of keys mentioned above can be used by the client for licensing Tesseral 

products. For example, a network HASP key for 3 workplaces, 2 local USB HASP keys and 2 alpha-

digital keys can be purchased and used together as a license for 3+2+2=6 workplaces. Each type of key 

may be accompanied by a particular variant of the Tesseral product. 

Licensing for evaluation period is usually done with local alpha-digital key. 
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18.4 Setting up a license 

Licensing with Hardware key (HASP) allows users to run the Tesseral package by plugging an 

electronic USB device (called the HASP key – “Hardware Against Software Piracy”) supplied by 

Tesseral Technologies Inc into a computer’s USB port. The HASP key (Guardant) driver is Microsoft-

certified. 

A HASP key is initially coded for the latest version of a particular Tesseral product and configuration 

and might not work with future versions released as the package is developed. Upon the user request and 

payment for upgrade, this key can be coded for the upgraded version and product configuration via e-

mail (users will receive necessary instructions in this case). 

HASP key can be coded for un-limited period (permanent) or limited period (trial or leasing period), 

and, after this period, the package will not work until user gets a new permanent HASP key from 

Tesseral Technologies Inc or a code from Tesseral Technologies Inc via e-mail. 

A HASP key is not bundled with a particular Tesseral installation CD. 

The user must keep the HASP key and not lose it, because the company does not provide replacement of 

the HASP key, because it is impossible to verify the number of licenses actually used in this case. If a 

HASP key is damaged, users must inform company's Customer Service by e-mail and then send it via 

mail to the provided address to get a replacement key for its market price (about US$ 50 for shipping 

and handling). 

The green indicator on the USB device means that the drivers are correctly installed. 

IMPORTANT NOTE! 

The new (2008) HASP drivers are strictly linked to the Windows‟ (not computer’s!) bit number (32 or 

64 bit). During the installation, the program recognizes the Windows type and installs the corresponding 

drivers. Insert the USB key only after the installation has finished. You can't mix 32-bit with 64-bit 

drivers if you have to install them manually. 

The first time you run Tesseral Pro, the Registration Dialogue (see figure below) request users to specify 

corresponding license information. 

Depending on the license type, you have several 

options: 

(1) Enter the alpha-digital key and press 
“Register” 

(2) Insert the USB key and press “Insert Key” 

(3) Enter the address of a Network Key 

Server and press “Connect” 
(3) (2) 

(1) 
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18.5 Installing Guardant Network Services 

To use network USB keys, it is required to install the Guardant Network Services on your computer that 

will serve as the key server. If you are not using network license, you may skip this section. 

The Guardant Network Services can be downloaded for free by following this link: 

http://www.geopoisk.com/tesseral/download/GuardnetNetServices.zip 

Detailed guide for installing Guardant Network Services can be downloaded by following this next link: 

http://www.tesseral-geo.com/documentation/en/license/ TesseralNetworkLicenseInstallation.pdf 

More technical details are described in the key vendor's manual: http:/www.tesseral-

geo.com/documentation/en/license/Guardant_LAN_Guide.pdf Unzip and run the installation program: 

 

STEP 1. Click Next > 

 

STEP 2. Select the Destination Folder and press Next > 

http://www.geopoisk.com/tesseral/download/GuardnetNetServices.zip
http://www.tesseral-geo.com/documentation/en/license/%20TesseralNetworkLicenseInstallation.pdf
http://www.tesseral-geo.com/documentation/en/license/%20TesseralNetworkLicenseInstallation.pdf
http://tesseral-geo.com/documentation/en/license/USBKeyRemoteUpdate.pdf
http://tesseral-geo.com/documentation/en/license/USBKeyRemoteUpdate.pdf
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Please, press 
the Next button after 
you insert your key 

 

STEP 3. Insert your USB key and then press Next > 

 

a) You may run “Network key monitor” to check if your key is working properly 

 

b) ... and check: The “Host name” 
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STEP 4. To use the Remote USB key, please enter the “Host name” in the Tesseral registration 

dialogue box and press “Connect” 

 

This is the information 

about your key 

Please remember 

the Host name 
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18.6 Troubleshooting 

Read this part only when you encounter problems 

1. Technical information for system administrators 

• Guardant Network Services use the following TCP/IP ports (both ingoing and 
outgoing): 

– 3182/TCP 

– 3183/UDP 

– 3184/UDP 

• Configuration files for advanced settings: 

– For server: NNKSRV32.INI (in Guardant Net Services directory) 

– For client: GNCLIENT.INI (In Tesseral Directory) 

 

2. Setting up the Firewall for system administrators 

a. Open Start > Settings > Control Panel then Windows Firewall 

 

b. Setting up the Firewall: Click “Advanced” tab then “Settings” button 
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c. Click “Add”, then enter connection data for “3182” port, then click “OK” 

 

d. Repeat for the “3183” and “3184” ports 

Settings from “Technical 

information” section 

IP address of the 

remote computer 
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Questions and Answers: 

a. Q: Network key monitor shows “blank” window 

 

Please, try following: 

– Check if the green indicator in the USB key is lit. If not, please download and 
install the latest drivers. 

– Try to reboot your server 

Note: 

3182 is TCP, 

3183, 3184 are UDP 
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– Check your firewall (please see 2 in Section 18.6) 

b. Q: Tesseral 2D/Pro does not “see” the network key 

 

Please, try the following: 

– Check your firewall (please see 2 in Section 18.6) 

– Check the configuration in gnclient.ini file in Tesseral program directory 


